You are not logged in.

#1 2012-04-23 04:17:30

rnarch
Member
Registered: 2012-03-17
Posts: 292

conky autostart with xfce problem

I followed the instruction in the wiki for autostarting conky with xfce and put 'own_window_type override' in ~/.conkyrc and a desktop file in ~/.config/autostart/ folder. However, on start of xfce, there is conky while the screen is blank but conky disappears as soon as desktop is displayed. If I start conky after this, it shows very well. Where could be the problem?

Offline

#2 2012-04-23 05:12:01

Gcool
Member
Registered: 2011-08-16
Posts: 1,456

Re: conky autostart with xfce problem

Back in my Xfce days, I simply created a script which did "conky -c ~/.conkyrc" and added that to Xfce's autostart (through the Settings Menu).


Burninate!

Offline

#3 2012-04-23 05:26:39

KingX
Member
From: Fremont, CA
Registered: 2010-03-24
Posts: 321

Re: conky autostart with xfce problem

Can you post your conkyrc. I have conky autostarting through xfce autostart and don't have the "own_window_type override" in my conkrc. Did you try removing it?

Offline

#4 2012-04-23 07:27:02

rnarch
Member
Registered: 2012-03-17
Posts: 292

Re: conky autostart with xfce problem

Following is my current .conkyrc ; it is not showing up on desktop if put in autostart or .xinitrc

background no
use_xft yes
xftfont Bitstream Vera Sans Mono:size=10
xftalpha 0.8
update_interval 15.0
total_run_times 0
own_window yes
own_window_type override
own_window_transparent yes
own_window_colour hotpink
own_window_hints undecorated,below,skip_taskbar,sticky,skip_pager
double_buffer yes
minimum_size 280 5
draw_shades yes
draw_outline no
draw_graph_borders yes
stippled_borders 8
border_margin 4
border_width 1
maximum_width 155
default_color darkgrey
default_shade_color black
default_outline_color black
alignment middle_right
gap_x 4
gap_y 4
no_buffers yes
uppercase no
cpu_avg_samples 2
net_avg_samples 2
override_utf8_locale no
use_spacer no

TEXT
${color #5b6dad}${alignc}${nodename} ${uptime_short}

${color #5b6dad}CPU: ${color grey}$cpu%
${color #5b6dad} ${cpugraph 16,140 000000 7f8ed3}
${color #5b6dad}RAM: $color$mem/$memmax
${color #5b6dad} ${membar 6,140}
${color #5b6dad}Swap:$color$swap/$swapmax
${color #5b6dad} ${swapbar 6,140}

${color #5b6dad}ETH0 Down: $color${downspeed eth0}${alignr} k/s
${color #5b6dad} ${downspeedgraph eth0 16,140 000000 7f8ed3 150}
${color #5b6dad}ETH0 Up:   $color${upspeed eth0}${alignr} k/s
${color #5b6dad} ${upspeedgraph eth0 16,140 000000 7f8ed3 18}

${color #5b6dad}File systems:
${color #5b6dad}/       $color${fs_free /}
${color #5b6dad} ${fs_bar 6,140 /}
${color #5b6dad}storage $color${fs_free /mnt/storage}
${color #5b6dad} ${fs_bar 6,140 /mnt/storage}

${color #5b6dad}Processes:$color $processes | $running_processes
${color} Cpu usage    CPU
${color #ddaa00} ${top name 1}${offset -50} ${top cpu 1}
${color #5b6dad} ${top name 2}${offset -50} ${top cpu 2}
${color #5b6dad} ${top name 3}${offset -50} ${top cpu 3}
${color #5b6dad} ${top name 4}${offset -50} ${top cpu 4}

${color} Mem usage    MEM
${color #ddaa00} ${top_mem name 1}${offset -50} ${top_mem mem 1}
${color #5b6dad} ${top_mem name 2}${offset -50} ${top_mem mem 2}
${color #5b6dad} ${top_mem name 3}${offset -50} ${top_mem mem 3}
${color #5b6dad} ${top_mem name 4}${offset -50} ${top_mem mem 4}

${color #5b6dad}# Connections   
$color In: ${tcp_portmon 1 32767 count}  Out: ${tcp_portmon 32768 61000 count}${alignr}

It is taken from one of the forum posts like this:
https://bbs.archlinux.org/viewtopic.php?id=26162

Last edited by rnarch (2012-04-23 14:54:54)

Offline

#5 2012-04-23 12:17:40

sealclubber
Member
Registered: 2012-04-16
Posts: 34

Re: conky autostart with xfce problem

Try messing around with the own_window_type settings. I had something similar happen to me and I remember messing around with it and it worked as normal.

Unfortunately, I am at work at the moment and don't have my main arch box here to let you know what I did hmm


When I  win the lottery, the first thing I will do, before I buy a new car or a house, would be to buy a goddamn Cisco XR 12000 router and enough T3 lines to wire a country.

http://myanimelist.net/profile/sealclubber

Offline

#6 2012-04-23 12:38:28

illusionist
Member
From: localhost
Registered: 2012-04-03
Posts: 498

Re: conky autostart with xfce problem

mine is

 own_window_type desktop

this link may help you
conky objects




Edit: that was a typo in code

Last edited by illusionist (2012-04-26 18:02:45)


  Never argue with stupid people,They will drag you down to their level and then beat you with experience.--Mark Twain
@github

Offline

#7 2012-04-23 12:55:07

debdj
Member
Registered: 2012-01-19
Posts: 163

Re: conky autostart with xfce problem

if you have an .xinit file you can put in it  --    sleep 20 && conky

or (idk) if the xfce autostart utility is like the gnome autostart app,
you can just create an bash script like

#!/bin/bash
sleep 20 && conky

adjust the sleep value to your needs so that it starts after the desktop is started.

Offline

#8 2012-04-23 13:46:00

rnarch
Member
Registered: 2012-03-17
Posts: 292

Re: conky autostart with xfce problem

"sleep 20 && conky"  in .xinitrc does not work.
" own_window_type = desktop"  in .conkyrc does not work.
conky command works very well if I start it from terminal after xfce has fully started. Following is the message on command line:

$ conky
Conky: desktop window (1600003) is subwindow of root window (379)
Conky: window type - override
Conky: drawing to created window (0x2200001)
Conky: drawing to double buffer

Last edited by rnarch (2012-04-23 13:47:59)

Offline

#9 2012-04-23 20:16:52

Roken
Member
From: UK
Registered: 2012-01-16
Posts: 681

Re: conky autostart with xfce problem

Did you customise the "sleep 20" for your own particular system as debdj said. If you have "sleep 20" but your system takes 30 seconds to load the desktop, then it won't work.

Try to err on the side of caution to start, with "sleep 60 && conky" which will wait a full minute before starting conky, then shorten the sleep command until it stops working and go back to last working value.


[img=Speedtest]http://www.speedtest.net/my-result/5145583518[/img]

Nvidia GTX 670 2Gb, AMD Phenom II X4 (965BE) @ 3.6 Ghz (Overclocked) 8GB RAM
Linux user #545703

Offline

#10 2012-04-23 21:01:21

KingX
Member
From: Fremont, CA
Registered: 2010-03-24
Posts: 321

Re: conky autostart with xfce problem

What is your conky version? If you are using 1.8.1 then you don't need "=" it should simply be "own_window_type desktop". Then save yor conkyrc and restart it. Output should be similar to this

Conky: forked to background, pid is 21461

Conky: desktop window (1000003) is subwindow of root window (15a)
Conky: window type - desktop
Conky: drawing to created window (0x1800002)
Conky: drawing to double buffer

Note: I DO fork conky to the background, and you don't so that will be different. smile

Offline

#11 2012-04-24 00:51:26

rnarch
Member
Registered: 2012-03-17
Posts: 292

Re: conky autostart with xfce problem

Following (of Archbang) is working:

background yes
use_xft yes
xftfont monospace:size=9
xftalpha 1
update_interval 1.0
total_run_times 0
own_window yes
own_window_transparent yes
own_window_type desktop
own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager
own_window_colour black
double_buffer yes
minimum_size 1 1
maximum_width 240
draw_shades no
draw_outline no
draw_borders no
draw_graph_borders no
default_color gray
default_shade_color 000000
default_outline_color d9d7d6
alignment middle_right
gap_x 12
gap_y 12
no_buffers yes
uppercase no
cpu_avg_samples 2
override_utf8_locale no
color1 red
color2 gray
##############################################
#  Output
##############################################
TEXT
CPU: ${cpubar cpu0}
RAM: $membar

${font sans-serif:bold:size=8}SYSTEM ${hr 2}
${font sans-serif:normal:size=8}$sysname $kernel $alignr $machine
Host:$alignr$nodename
Uptime:$alignr$uptime

${font sans-serif:bold:size=8}TOP PROCESSES ${hr 2}
${font sans-serif:normal:size=8}${top_mem name 1}${alignr}${top mem 1} %
${top_mem name 2}${alignr}${top mem 2} %
$font${top_mem name 3}${alignr}${top mem 3} %
$font${top_mem name 4}${alignr}${top mem 4} %

${font sans-serif:bold:size=8}SHORTCUT KEYS ${hr 2}
${font sans-serif:normal:size=8}Alt+F2$alignr Run Dialog
Alt+F3$alignr Dmenu
Super+space$alignr Main Menu
Super+t$alignr Terminal
Super+f$alignr File Manager
Super+e$alignr Editor
Super+m$alignr Media Player
Super+w$alignr Web Browser
Super+q$alignr Force Quit
Super+g$alignr Character Map
Super+l$alignr Lock
Super+u$alignr System Upgrade
Super+r$alignr Read the DOC
Super+x$alignr Tiling Keybinds

Offline

#12 2012-04-25 13:09:55

debdj
Member
Registered: 2012-01-19
Posts: 163

Re: conky autostart with xfce problem

I've my own window type set to 'conky'
Also note that, if you try to put the conky startup line in .xinitrc, put that in the same line as of the the DE/WM invocation command.

so, if you're using lxde, it would be like

exec ck-launch-session dbus-launch startlxde && sleep <number> && conky

Offline

#13 2012-04-30 13:31:16

sealclubber
Member
Registered: 2012-04-16
Posts: 34

Re: conky autostart with xfce problem

Has anyone ever had problems with transparency?

After I start up conky in xfce it draws itself into its own window as normal, but the full transparency doesn't kick in until I attempt to logout. This isn't a big issue and I don't have my arch laptop with me at the moment so I can't post my rc file, but I was curious if this is something that anyone else has seen before.


When I  win the lottery, the first thing I will do, before I buy a new car or a house, would be to buy a goddamn Cisco XR 12000 router and enough T3 lines to wire a country.

http://myanimelist.net/profile/sealclubber

Offline

#14 2012-05-11 14:00:07

debdj
Member
Registered: 2012-01-19
Posts: 163

Re: conky autostart with xfce problem

Has anyone ever had problems with transparency?

After I start up conky in xfce it draws itself into its own window as normal, but the full transparency doesn't kick in until I attempt to logout. This isn't a big issue and I don't have my arch laptop with me at the moment so I can't post my rc file, but I was curious if this is something that anyone else has seen before.

what DE do you use?

Offline

#15 2012-05-14 19:08:31

alesmaci
Member
Registered: 2012-02-21
Posts: 4

Re: conky autostart with xfce problem

Bringing this thread back to its original question.

Conky fails to autostart with XFCE. This happens here as well on XFCE 4.10 with Conky 1.9.0. The wiki suggests setting own_window to override but this does not work.

Conky works fine when manually started.

Any suggestions?

Last edited by alesmaci (2012-05-14 19:10:10)

Offline

#16 2012-05-14 20:09:51

alesmaci
Member
Registered: 2012-02-21
Posts: 4

Re: conky autostart with xfce problem

This works:

edit

~/.config/autostart/conky.desktop

like this:

[Desktop Entry]
Encoding=UTF-8
Version=0.9.4
Type=Application
Name=conky
Comment=
Exec=conky -p 10
StartupNotify=false
Terminal=false
Hidden=false

The

-p 10

gives conky a 10 seconds break so that it starts drawing after the desktop is up. You can increase this pause if needs be.

Offline

#17 2013-01-20 15:34:22

Cromulent
Member
From: United Kingdom
Registered: 2011-08-28
Posts: 52

Re: conky autostart with xfce problem

alesmaci wrote:

This works:

edit

~/.config/autostart/conky.desktop

like this:

[Desktop Entry]
Encoding=UTF-8
Version=0.9.4
Type=Application
Name=conky
Comment=
Exec=conky -p 10
StartupNotify=false
Terminal=false
Hidden=false

The

-p 10

gives conky a 10 seconds break so that it starts drawing after the desktop is up. You can increase this pause if needs be.

Sorry for bumping an old thread but this answer fixed the problem for me if anyone else is having the same problem. It seems that if you start Conky at the same time as XFCE 4.10 then the XFCE desktop draws over the top of the Conky window. Adding the delay ensures that Conky is displayed on top as it should be.

Offline

#18 2013-04-23 16:28:23

taxuanthaian
Member
From: Lâm Đồng, Việt Nam
Registered: 2013-01-30
Posts: 1

Re: conky autostart with xfce problem

alesmaci wrote:

This works:

edit

~/.config/autostart/conky.desktop

like this:

[Desktop Entry]
Encoding=UTF-8
Version=0.9.4
Type=Application
Name=conky
Comment=
Exec=conky -p 10
StartupNotify=false
Terminal=false
Hidden=false

The

-p 10

gives conky a 10 seconds break so that it starts drawing after the desktop is up. You can increase this pause if needs be.

Thank You so much! it worked for me!

Offline

#19 2014-12-23 00:18:50

kozaki
Member
From: London >. < Paris
Registered: 2005-06-13
Posts: 652
Website

Re: conky autostart with xfce problem

alesmaci's setting works fine where all other ways I tried didn't (eg. ~/.xinitrc before or on same line than exec xfce4-session, $XDG_CONFIG_HOME/.../xfce4-session.xml ) ^_^
xfdesktop 4.11.8 & xfce4-session 4.11.1 here.


Seeded this month: Arch 80 gig (and Talking~ 2, ~-anywhere 46, Apricity 16)
Desktop @3.3GHz 8 gig RAM, linux-ck
laptop1 Atom 2 gig RAM, Arch linux stock i686 (6H w/ 6yrs old battery smile) & 2: ARM Tegra K1, 4 gig RAM, ChrOS
Atom Z520 2 gig RAM, OMV (Debian 7) kernel 3.16 bpo on SDHC | PGP Key: 0xFF0157D9

Offline

#20 2015-03-03 13:06:06

inukaze
Member
From: Venezuela
Registered: 2011-05-06
Posts: 15
Website

Re: conky autostart with xfce problem

Well my system needs 2m with 35 seconds for the moment i press the power button to enter to xfce desktop and i can use it i put 45 seconds for delay

Why you dont try with the "Autostart Applications" for your desktop and put this command :

sh -c 'sleep 45;sh -c "conky"'

this is very simple

open apostrophe "sh -c program" with this launch the "sleep" , with the " ; " its for start another comand its the same like " && " , and again i use sh -c "program" close apostrophe , and now with this works.

Last edited by inukaze (2015-03-03 13:18:57)

Offline

Board footer

Powered by FluxBB