You are not logged in.

#651 2013-01-18 22:48:28

abraxas88
Member
From: Cosenza, Italy
Registered: 2009-12-12
Posts: 87

Re: The linux-pf thread; BFS/CK, TuxOnIce, BFQ, AUFS3

abraxas88 wrote:

Joking apart, my problem is that, since linux 3.7, setting offline and back online one of the cores of my machines freezes the latter. Try shutting down all the cores but one, hibernate and resume and see if it freezes again.


Asus G53Jw-IX160V Intel Core i7 740M 1.73 GHz, 8 GB RAM DDR3 1333 MHz, nVidia GTX 460M 1.5 GB GDDR5. Arch Linux 64 bit, of course. wink

Offline

#652 2013-01-21 15:25:31

Lockheed
Member
Registered: 2010-03-16
Posts: 1,429

Re: The linux-pf thread; BFS/CK, TuxOnIce, BFQ, AUFS3

Apparently, it is no longer possible to compile virtualbox modules with linux-pf sources.
This is what I am getting:

sudo dkms install vboxhost/4.2.6

Kernel preparation unnecessary for this kernel.  Skipping...

Building module:
cleaning build area.....
make KERNELRELEASE=3.7-pf -C /usr/lib/modules/3.7-pf/build M=/var/lib/dkms/vboxhost/4.2.4/build........(bad exit status: 2)
Error! Bad return status for module build on kernel: 3.7-pf (x86_64)
Consult /var/lib/dkms/vboxhost/4.2.4/build/make.log for more information.

I tried older vbox versions - same thing.

EDIT:
Apparently, it was cause by adding the version.h to be able to compile nvidia drivers.

Last edited by Lockheed (2013-01-21 15:30:50)


Laptop: ThinkPad W500, C2D P9500, 8GB, Radeon RV635 (HD3650), Arch | Server/fw: Zotac AQ01, A4-5000 Kabini, 4GB, Arch/pfSense VM

Offline

#653 2013-02-04 12:11:08

nbvcxz
Member
From: Poland
Registered: 2007-12-29
Posts: 192

Re: The linux-pf thread; BFS/CK, TuxOnIce, BFQ, AUFS3

Is ZCACHE2 going to be introduced to linux-pf as default in config (as in official archlinux kernel) ? I am also interested in the pre-compiled linux-pf versions.

Last edited by nbvcxz (2013-02-04 12:16:32)


Lenovo G50 | LXQT-git | compton | conky

Offline

#654 2013-02-04 12:35:49

nous
Member
From: Across the Universe
Registered: 2006-08-18
Posts: 320

Re: The linux-pf thread; BFS/CK, TuxOnIce, BFQ, AUFS3

nbvcxz wrote:

Is ZCACHE2 going to be introduced to linux-pf as default in config (as in official archlinux kernel) ? I am also interested in the pre-compiled linux-pf versions.

It will, at the next pf release. The precompiled pf kernels also follow the AUR linux-pf config to the letter.

Offline

#655 2013-02-11 05:01:24

Phlogiston
Member
Registered: 2009-02-14
Posts: 39

Re: The linux-pf thread; BFS/CK, TuxOnIce, BFQ, AUFS3

Are you guys missing the standard linux-pf package from the official repo either? Was this removed?

Offline

#656 2013-02-11 23:48:00

nous
Member
From: Across the Universe
Registered: 2006-08-18
Posts: 320

Re: The linux-pf thread; BFS/CK, TuxOnIce, BFQ, AUFS3

Building one right now, should be up for grabs in less than an hour.

Offline

#657 2013-02-12 10:39:12

cuihao
Member
Registered: 2011-03-19
Posts: 27

Re: The linux-pf thread; BFS/CK, TuxOnIce, BFQ, AUFS3

I got this error when trying to load nvidia driver:

cuihao-tp430-arch $ sudo modprobe nvidia -v                               ~ (1)
insmod /lib/modules/3.7-pf/extramodules/nvidia.ko.gz 
modprobe: ERROR: could not insert 'nvidia': Exec format error

The kernel package (linux-pf-core2 3.7.4-1)  and driver package (nvidia-pf-core2 313.18-1) is from the dropbox repo.
Any solution?


Forgive my poor English. I am a senior student from China.

Offline

#658 2013-02-12 11:14:29

nous
Member
From: Across the Universe
Registered: 2006-08-18
Posts: 320

Re: The linux-pf thread; BFS/CK, TuxOnIce, BFQ, AUFS3

cuihao wrote:

I got this error when trying to load nvidia driver:

cuihao-tp430-arch $ sudo modprobe nvidia -v                               ~ (1)
insmod /lib/modules/3.7-pf/extramodules/nvidia.ko.gz 
modprobe: ERROR: could not insert 'nvidia': Exec format error

The kernel package (linux-pf-core2 3.7.4-1)  and driver package (nvidia-pf-core2 313.18-1) is from the dropbox repo.
Any solution?

I suspect the nvidia packages (which were built after linux-pf building finished) might be built against 3.7.4-2 (which has a small but critical change in config: ZCACHE2 and was uploaded a few hours after 3.7.4-1). Now, I use an automagic script for that job, which always downloads the latest tarballs from the AUR and it would need to rebuild all linux-pf packages again. Can't you just build nvidia-pf from the AUR? You'll need to symlink version.h first though, see comments in nvidia-304xx-pf. A "definitive" fix for version.h is in 3.7.4-3 (only in bitbucket ATM).

Offline

#659 2013-02-14 14:45:28

kostett
Member
From: Archangelsk, Russia
Registered: 2012-04-14
Posts: 34

Re: The linux-pf thread; BFS/CK, TuxOnIce, BFQ, AUFS3

had an 404 error when i try to download pre-compiled packages
where is a problem?

[kostett@asus-sielab ~]$ sudo pacman -Syu
:: Синхронизируются базы данных пакетов...
 core не устарел
 extra не устарел
 community не устарел
 pfkernel                                            9,5 KiB   484K/s 00:00 [##########################################] 100%
:: Запускается полное обновление системы...
разрешение зависимостей...
проверка на взаимную несовместимость...

Цели (2): linux-pf-atom-3.7.4-1  linux-pf-headers-atom-3.7.4-1

Будет загружено:    45,97 MiB
Будет установлено:  108,93 MiB
Изменение размера:  0,27 MiB

Приступить к установке? [Y/n] y
:: Получение пакетов с pfkernel...
ошибка: не удалось получить файл 'linux-pf-atom-3.7.4-1-i686.pkg.tar.xz' из dl.dropbox.com : The requested URL returned error: 404 NOT FOUND
предупреждение: не удалось получить некоторые файлы с pfkernel
ошибка: не удалось получить файл 'linux-pf-headers-atom-3.7.4-1-i686.pkg.tar.xz' из dl.dropbox.com : The requested URL returned error: 404 NOT FOUND
предупреждение: не удалось получить некоторые файлы с pfkernel
ошибка: не удалось завершить запрос (ошибка в библиотеке загрузки)
Обнаружены ошибки, пакеты не были обновлены.
[kostett@asus-sielab ~]$ 

Offline

#660 2013-02-14 17:16:46

nous
Member
From: Across the Universe
Registered: 2006-08-18
Posts: 320

Re: The linux-pf thread; BFS/CK, TuxOnIce, BFQ, AUFS3

kostett wrote:

had an 404 error when i try to download pre-compiled packages
where is a problem?

The build box is building 3.7.5; all 3.7.4 prebuilts are removed to make space, sorry. Please try again in a few hours for i686s - all x86_64s (including nvidia-pf ones) are up for grabs.

Offline

#661 2013-03-17 15:13:50

jakob
Member
From: Berlin
Registered: 2005-10-27
Posts: 419

Re: The linux-pf thread; BFS/CK, TuxOnIce, BFQ, AUFS3

Is TOI working with 3.8.1? I'm still using 3.6.11 here since with 3.7. there were often problems…

Offline

#662 2013-03-17 17:37:06

nous
Member
From: Across the Universe
Registered: 2006-08-18
Posts: 320

Re: The linux-pf thread; BFS/CK, TuxOnIce, BFQ, AUFS3

Haven't tested yet, the last 3.7 though froze/thawed flawlessly.

Offline

#663 2013-03-17 19:59:00

mah0
Member
Registered: 2011-04-21
Posts: 47

Re: The linux-pf thread; BFS/CK, TuxOnIce, BFQ, AUFS3

I can't install nvidia-pf:

[~]$ sudo pacman -S nvidia-pf
resolving dependencies...
warning: cannot resolve "linux-pf<3.8", a dependency of "nvidia-pf"
:: The following package cannot be upgraded due to unresolvable dependencies:
      nvidia-pf

Do you want to skip the above package for this upgrade? [y/N] 
error: failed to prepare transaction (could not satisfy dependencies)
:: nvidia-pf: requires linux-pf<3.8
[~]$ pacman -Q linux-pf
linux-pf 3.8.1-2

Offline

#664 2013-03-17 20:45:41

nous
Member
From: Across the Universe
Registered: 2006-08-18
Posts: 320

Re: The linux-pf thread; BFS/CK, TuxOnIce, BFQ, AUFS3

mah0 wrote:

I can't install nvidia-pf:

[~]$ sudo pacman -S nvidia-pf
resolving dependencies...
warning: cannot resolve "linux-pf<3.8", a dependency of "nvidia-pf"
:: The following package cannot be upgraded due to unresolvable dependencies:
      nvidia-pf

Do you want to skip the above package for this upgrade? [y/N] 
error: failed to prepare transaction (could not satisfy dependencies)
:: nvidia-pf: requires linux-pf<3.8
[~]$ pacman -Q linux-pf
linux-pf 3.8.1-2

Until the maintainer of nvidia-pf over at the AUR updates the PKGBUILD, edit the versions manually.

Offline

#665 2013-03-21 22:36:45

nous
Member
From: Across the Universe
Registered: 2006-08-18
Posts: 320

Re: The linux-pf thread; BFS/CK, TuxOnIce, BFQ, AUFS3

I've hibernated/resumed with TuxOnIce on 3.8.1 without problems in both my laptop intel core2 and my desktop amd k10.

Offline

#666 2013-03-27 09:20:19

Tsu Jan
Member
Registered: 2012-02-28
Posts: 15

Re: The linux-pf thread; BFS/CK, TuxOnIce, BFQ, AUFS3

nous wrote:

I've hibernated/resumed with TuxOnIce on 3.8.1 without problems in both my laptop intel core2 and my desktop amd k10.

Thank you, nous. After I read your reply, I dared to compile pf-kernel 3.8.1 for my Debian. Here TOI works fine too (with THP disabled before hibernation and enabled after it through pm) smile

Offline

#667 2013-03-27 10:45:55

nous
Member
From: Across the Universe
Registered: 2006-08-18
Posts: 320

Re: The linux-pf thread; BFS/CK, TuxOnIce, BFQ, AUFS3

Tsu Jan wrote:
nous wrote:

I've hibernated/resumed with TuxOnIce on 3.8.1 without problems in both my laptop intel core2 and my desktop amd k10.

Thank you, nous. After I read your reply, I dared to compile pf-kernel 3.8.1 for my Debian. Here TOI works fine too (with THP disabled before hibernation and enabled after it through pm) smile

Your post being no. 666, it's no wonder you had success!
</JK>

The patchset author usually compiles generic binaries for debian too, which could save you the trouble compiling the kernel yourself.

Offline

#668 2013-03-27 11:54:11

Tsu Jan
Member
Registered: 2012-02-28
Posts: 15

Re: The linux-pf thread; BFS/CK, TuxOnIce, BFQ, AUFS3

nous wrote:

Your post being no. 666, it's no wonder you had success!

Ha ha!

nous wrote:

The patchset author usually compiles generic binaries for debian too, which could save you the trouble compiling the kernel yourself.

Yes, I know that but I prefer to compile it myself with an extra tweak and also with the Liquorix config, which I fully trust in.

Offline

#669 2013-03-27 18:04:01

wallnuss
Member
Registered: 2012-07-11
Posts: 4

Re: The linux-pf thread; BFS/CK, TuxOnIce, BFQ, AUFS3

Hello there,

I am currently trying to get aufs3 to work (linux-pf-3.8.1 from repository).

According to the mailling list I am either using the wrong include path (In my case /lib/modules/3.8.1-pf/build/include/ after AUR ) or make headers_install ist missing in the kernel build.

The error I am getting is:

==> Beginne build()...
cc -march=native -O2 -pipe -fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2 -I./libau -O -Wall -I/lib/modules/3.8.1-pf/build/include/ -DMOUNT_CMD_PATH=\"\" -Wl,-O1,--sort-common,--as-needed,-z,relro  ver.c   -o ver
In file included from /lib/modules/3.8.1-pf/build/include/linux/aufs_type.h:19:0,
                 from ver.c:19:
/lib/modules/3.8.1-pf/build/include/uapi/linux/aufs_type.h:180:27: Error: expected »:«, »,«, »;«, »}« or »__attribute__« before »*« token
make: *** [ver] Error 1

It also might be that the patch set used in the repository was flawed and needs to be rebuild. Discussion in Maillinglist

Does anybody has managed to get aufs tu run successfully with 3.8 and if so with what settings?

Cheers Valentin

Last edited by wallnuss (2013-03-27 18:06:58)

Offline

#670 2013-03-27 18:23:19

nous
Member
From: Across the Universe
Registered: 2006-08-18
Posts: 320

Re: The linux-pf thread; BFS/CK, TuxOnIce, BFQ, AUFS3

wallnuss wrote:

Hello there,

I am currently trying to get aufs3 to work (linux-pf-3.8.1 from repository).

According to the mailling list I am either using the wrong include path (In my case /lib/modules/3.8.1-pf/build/include/ after AUR ) or make headers_install ist missing in the kernel build.

The error I am getting is:

==> Beginne build()...
cc -march=native -O2 -pipe -fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2 -I./libau -O -Wall -I/lib/modules/3.8.1-pf/build/include/ -DMOUNT_CMD_PATH=\"\" -Wl,-O1,--sort-common,--as-needed,-z,relro  ver.c   -o ver
In file included from /lib/modules/3.8.1-pf/build/include/linux/aufs_type.h:19:0,
                 from ver.c:19:
/lib/modules/3.8.1-pf/build/include/uapi/linux/aufs_type.h:180:27: Error: expected »:«, »,«, »;«, »}« or »__attribute__« before »*« token
make: *** [ver] Error 1

It also might be that the patch set used in the repository was flawed and needs to be rebuild. Discussion in Maillinglist

Does anybody has managed to get aufs tu run successfully with 3.8 and if so with what settings?

Cheers Valentin

I don't use aufs3 at all and only added it after a request. But if anyone figures out how, I'll happily fix it.

Offline

#671 2013-03-27 20:12:43

wallnuss
Member
Registered: 2012-07-11
Posts: 4

Re: The linux-pf thread; BFS/CK, TuxOnIce, BFQ, AUFS3

Sadly the kernel build isn't working for me right now...

  LD [M]  drivers/xen/xen-privcmd.o
  LD      drivers/built-in.o
==> FEHLER: Ein Fehler geschah in build().
    Breche ab ...
==> ERROR: Makepkg was unable to build linux-pf.

Sometimes I do miss genkernel smile (old gentoo user here)

When did you last rebuild the packages in the linux-pf repo? As far as I can tell there went some fixes upstream roundabout 4 days ago.

Furthermore the git url have changed, but the old ones are still there.


Cheers Valentin

Hello all,

The aufs project on SourceForge is upgrading now.
The new repositories will be
git clone git://git.code.sf.net/p/aufs/aufs3-linux aufs-aufs3-linux
git clone git://git.code.sf.net/p/aufs/aufs3-standalone aufs-aufs3-standalone
git clone git://git.code.sf.net/p/aufs/aufs-util aufs-aufs-util

The old repositories are still avaialble.
git://aufs.git.sourceforge.net/gitroot/aufs/aufs3-linux.git 
git://aufs.git.sourceforge.net/gitroot/aufs/aufs3-standalone.git 
git://aufs.git.sourceforge.net/gitroot/aufs/aufs-util.git

The SourceForge engineering team seems to be working on aufs3-linux tree
still.
Until completing the work, the GIT repository may not be accessible or
may provide obsolete status.


J. R. Okajima

Offline

#672 2013-03-27 22:23:15

nous
Member
From: Across the Universe
Registered: 2006-08-18
Posts: 320

Re: The linux-pf thread; BFS/CK, TuxOnIce, BFQ, AUFS3

wallnuss wrote:

Sadly the kernel build isn't working for me right now...

  LD [M]  drivers/xen/xen-privcmd.o
  LD      drivers/built-in.o
==> FEHLER: Ein Fehler geschah in build().
    Breche ab ...
==> ERROR: Makepkg was unable to build linux-pf.

Sometimes I do miss genkernel smile (old gentoo user here)

When did you last rebuild the packages in the linux-pf repo? As far as I can tell there went some fixes upstream roundabout 4 days ago.

Furthermore the git url have changed, but the old ones are still there.

Cheers Valentin

The packages  in the repo were built within a day after the release of 3.8.1-5. I can't test-build every now and then, obviously, but I do my best to fix all reported issues. I especially appreciate PKGBUILD patches, since my time is really limited.

Offline

#673 2013-03-28 20:54:54

wallnuss
Member
Registered: 2012-07-11
Posts: 4

Re: The linux-pf thread; BFS/CK, TuxOnIce, BFQ, AUFS3

nous wrote:

The packages  in the repo were built within a day after the release of 3.8.1-5. I can't test-build every now and then, obviously, but I do my best to fix all reported issues. I especially appreciate PKGBUILD patches, since my time is really limited.

I got it to work and you can find a diff here.

I don't know if this breaks anything and my knowledge about stuff like that is quite limited. If I can help you test please tell me.

As far as I understand via make headers_install you export the userspace kernel headers, but previously only the kernelside headers were exported. So in my understanding it might be that what I did is not right and instead of only exporting the userspace headers one should also export the kernelside headers, but to different locations. But as I said my knowledge is quite limited there.

Cheers Valentin

Offline

#674 2013-03-29 11:27:53

nous
Member
From: Across the Universe
Registered: 2006-08-18
Posts: 320

Re: The linux-pf thread; BFS/CK, TuxOnIce, BFQ, AUFS3

wallnuss wrote:

I got it to work and you can find a diff here.

I don't know if this breaks anything and my knowledge about stuff like that is quite limited. If I can help you test please tell me.

As far as I understand via make headers_install you export the userspace kernel headers, but previously only the kernelside headers were exported. So in my understanding it might be that what I did is not right and instead of only exporting the userspace headers one should also export the kernelside headers, but to different locations. But as I said my knowledge is quite limited there.

Cheers Valentin

I had already fixed the aufs3 git URL in the bitbucket repository of linux-pf, but I really don't want to deviate from the stock linux-ARCH PKGBUILD.

Eventually, I'm getting the same error as you.

hyperion:[nous]:/temp/pkgbuild/aufs3-util% LC_ALL=C makepkg
==> Making package: aufs3-util 20130111-1 (Fri Mar 29 13:12:58 EET 2013)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving Sources...
  -> Found aufs3-util-20130111.tar.gz
==> Validating source files with md5sums...
    aufs3-util-20130111.tar.gz ... Passed
==> Extracting Sources...
  -> Extracting aufs3-util-20130111.tar.gz with bsdtar
==> Removing existing pkg/ directory...
==> Starting build()...
cc -march=native -O2 -pipe -fstack-protector -I./libau -O -Wall -DMOUNT_CMD_PATH=\"\" -Wl,-O1,--sort-common,--as-needed,-z,relro,--hash-style=gnu  ver.c   -o ver
ver.c:19:29: fatal error: linux/aufs_type.h: No such file or directory
compilation terminated.
distcc[16607] ERROR: compile (null) on localhost failed
make: *** [ver] Error 1
==> ERROR: A failure occurred in build().
    Aborting...
hyperion:[nous]:/temp/pkgbuild/aufs3-util% ls -l /usr/src/linux-3.8.1-pf/include/linux/aufs_type.h
-rw-r--r-- 1 root root 811 Mar 19 11:10 /usr/src/linux-3.8.1-pf/include/linux/aufs_type.h
hyperion:[nous]:/temp/pkgbuild/aufs3-util% cd /src/aufs3-util-20130111
hyperion:[nous]:/temp/pkgbuild/aufs3-util/src/aufs3-util-20130111% less README
hyperion:[nous]:/temp/pkgbuild/aufs3-util/src/aufs3-util-20130111% export CPPFLAGS="-I /usr/src/linux-3.8.1-pf/include"
hyperion:[nous]:/temp/pkgbuild/aufs3-util/src/aufs3-util-20130111% make
cc -march=native -mtune=native -O2 -pipe -I./libau -O -Wall -I /usr/src/linux-3.8.1-pf/include -DMOUNT_CMD_PATH=\"\"   ver.c   -o ver
In file included from /usr/src/linux-3.8.1-pf/include/linux/aufs_type.h:19:0,
                 from ver.c:19:
/usr/src/linux-3.8.1-pf/include/uapi/linux/aufs_type.h:180:27: error: expected ‘:’, ‘,’, ‘;’, ‘}’ or ‘__attribute__’ before ‘*’ token
make: *** [ver] Error 1

Can you post a unified diff of the standard /usr/src/linux-3.8.1-pf/include/uapi/linux/aufs_type.h vs the working yours?

Offline

#675 2013-04-07 22:18:09

Thaodan
Member
From: Dortmund, Nordrein-Westfalen
Registered: 2012-04-28
Posts: 433

Re: The linux-pf thread; BFS/CK, TuxOnIce, BFQ, AUFS3

I updated the PKGBUILD to linux-pf 3.8.2, currently im building builds for sandy and ivvy-bridge. In the next days I'll add a repo, with the most builds for sandy, ivvy bridge , generic etc.


Linux odin 3.13.1-pf #1 SMP PREEMPT Wed Mar 5 21:47:28 CET 2014 x86_64 GNU/Linux

Offline

Board footer

Powered by FluxBB