You are not logged in.

#1 2012-12-24 22:43:52

Potomac
Member
Registered: 2011-12-25
Posts: 343

virtualbox-guest-modules and virtualbox-guest-utils require kernel 3.7

I notice a warning today with a "pacman -Syu",

résolution des dépendances...
Avertissement : impossible de résoudre « linux>=3.7 », une dépendance de « virtualbox-guest-modules »
Avertissement : impossible de résoudre « linux>=3.7 », une dépendance de « virtualbox-guest-modules »
:: Les paquets suivants ne peuvent pas être mis à jour à cause de dépendances qui ne peuvent êtres satisfaites :
      virtualbox-guest-modules  virtualbox-guest-utils

Voulez-vous ignorer les paquets ci-dessus pour cette mise à jour ? [o/N]

I have 2 packages in "community" repo :

virtualbox-guest-modules and virtualbox-guest-utils

the maintainer of these 2 package has decided to release the new version in "community repo" but these packages need a kernel 3.7 version :

dependencie :
linux<3.8 

linux>=3.7 (testing)

but the kernel 3.7 is not again in "stable repo", only in testing repo, that's why pacman shows the warnings,

as long as the kernel 3.7 is not on stable repo the maintainer should not release these 2 packages on "community repo", otherwise these packages can not be installed,

what do you think ?

Last edited by Potomac (2012-12-24 22:46:35)

Offline

#2 2012-12-24 22:48:00

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 5,126

Re: virtualbox-guest-modules and virtualbox-guest-utils require kernel 3.7

It's just an error in the dependency.

https://bugs.archlinux.org/task/33194

Offline

#3 2012-12-24 22:50:37

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: virtualbox-guest-modules and virtualbox-guest-utils require kernel 3.7

I think this is going to be fixed soon. I simply installed linux-3.7 from the testing repo, as well as virtualbox-host-modules 4.2.6-2 (the current one wasn't compiled for linux 3.7) and everything is fine. So, either go this way, or simply hold the update of virtualbox till the dependencies are corrected.


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#4 2012-12-24 22:52:36

Potomac
Member
Registered: 2011-12-25
Posts: 343

Re: virtualbox-guest-modules and virtualbox-guest-utils require kernel 3.7

Scimmia wrote:

It's just an error in the dependency.

https://bugs.archlinux.org/task/33194

an error ?

I am not sure, should I wait a new rebuild of these 2 packages ?

it's not normal to force pacman to install these 2 packages despite the warnings

Last edited by Potomac (2012-12-24 22:52:59)

Offline

#5 2012-12-25 01:55:20

HungGarTiger
Member
From: nz/auckland/
Registered: 2012-06-27
Posts: 186

Re: virtualbox-guest-modules and virtualbox-guest-utils require kernel 3.7

I'm getting the same error for

virtualbox  virtualbox-host-modules

Just hold off on the update untill 3.7 is in stable, I doubt it will take more than a week or so


"No sympathy for the devil. If you buy the ticket, take the ride."
- Hunter S. Thompson

Offline

#6 2012-12-25 08:59:00

89c51
Member
Registered: 2012-06-05
Posts: 671

Re: virtualbox-guest-modules and virtualbox-guest-utils require kernel 3.7

Is it safe to skip the package and install the rest?? I mean answer yes to the pacman question.

Last edited by 89c51 (2012-12-25 08:59:41)

Offline

#7 2012-12-25 09:16:32

Potomac
Member
Registered: 2011-12-25
Posts: 343

Re: virtualbox-guest-modules and virtualbox-guest-utils require kernel 3.7

"yes" ( = ignore package ) is the only solution,

if you type "No" pacman will try to install these packages ( virtualbox-guest-modules and virtualbox-guest-utils ) and it will fail immediatly because kernel >=3.7 is not present in your system, no package will be installed

Last edited by Potomac (2012-12-25 09:16:59)

Offline

#8 2012-12-25 11:07:51

NikTh
Member
From: GR
Registered: 2012-01-08
Posts: 40
Website

Re: virtualbox-guest-modules and virtualbox-guest-utils require kernel 3.7

Same problem here.

:: Starting full system upgrade...
resolving dependencies...
warning: cannot resolve "linux>=3.7", a dependency of "virtualbox-host-modules"
warning: cannot resolve "linux>=3.7", a dependency of "virtualbox-host-modules"
:: The following packages cannot be upgraded due to unresolvable dependencies:
      virtualbox  virtualbox-host-modules

Do you want to skip the above packages for this upgrade? [y/N] 

The default action in N(o) if you just press [Enter] and the response is

error: failed to prepare transaction (unexpected error)

I agree this is going to be resolved soon , so just wait.
If don't want to wait , hit yes to skip these packages or install Linux Kernel  3.7 from the testing repos.


KISS my Arch

Offline

#9 2012-12-25 11:18:24

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 5,126

Re: virtualbox-guest-modules and virtualbox-guest-utils require kernel 3.7

Installing 3.7 from testing would be a bad idea unless you install the rest of virtualbox from testing as well. The packages in Community are built for 3.6 even though they "depend" on 3.7. It's a simple typo.

Offline

#10 2012-12-25 13:28:56

hiob
Member
Registered: 2007-12-15
Posts: 19

Re: virtualbox-guest-modules and virtualbox-guest-utils require kernel 3.7

pacman -Sd virtualbox-host-modules

does the job and should be save, since the real dependencies (e.g. linux>=3.6) are installed.

Offline

#11 2012-12-26 02:10:06

HungGarTiger
Member
From: nz/auckland/
Registered: 2012-06-27
Posts: 186

Re: virtualbox-guest-modules and virtualbox-guest-utils require kernel 3.7

Just updated and whatever the problem was seems to be fixed now, I am running the 3.6-10 kernel and the Virtualbox dependencies had no problems this time.


"No sympathy for the devil. If you buy the ticket, take the ride."
- Hunter S. Thompson

Offline

#12 2012-12-26 12:27:57

NikTh
Member
From: GR
Registered: 2012-01-08
Posts: 40
Website

Re: virtualbox-guest-modules and virtualbox-guest-utils require kernel 3.7

Yes the problem fixed.. guys here are quick smile

Please mark the thread as [SOLVED] now.

Thanks


KISS my Arch

Offline

#13 2013-01-21 21:43:13

woznme
Member
From: Gold Coast, AU
Registered: 2013-01-13
Posts: 22

Re: virtualbox-guest-modules and virtualbox-guest-utils require kernel 3.7

This happened to me today.

:: Synchronizing package databases...
core is up to date
extra is up to date
community is up to date
multilib is up to date
:: Starting full system upgrade...
resolving dependencies...
warning: cannot resolve "linux>=3.7", a dependency of "virtualbox-guest-modules"
warning: cannot resolve "linux>=3.7", a dependency of "virtualbox-host-modules"
:: The following packages cannot be upgraded due to unresolvable dependencies:
      virtualbox-guest-modules  virtualbox-host-modules

Do you want to skip the above packages for this upgrade? [y/N]

edit: and a big thanks for the awesome wiki, distro and forum!

Last edited by woznme (2013-01-21 21:44:10)

Offline

#14 2013-01-21 21:57:54

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 5,126

Re: virtualbox-guest-modules and virtualbox-guest-utils require kernel 3.7

woznme, completely different issue. 3.7.3 is now in core, so if the dependency can't be resolved, either you're blocking the kernel upgrade or there's something wrong with your mirror. Try a pacman -Syyu first, if that doesn't work, change your mirror.

Last edited by Scimmia (2013-01-21 21:58:35)

Offline

#15 2013-01-21 22:06:43

graysky
Member
From: The worse toilet in Scotland
Registered: 2008-12-01
Posts: 8,647
Website

Re: virtualbox-guest-modules and virtualbox-guest-utils require kernel 3.7

EDIT - removed incorrect info.

Last edited by graysky (2013-01-21 22:07:10)


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#16 2013-01-22 10:29:07

woznme
Member
From: Gold Coast, AU
Registered: 2013-01-13
Posts: 22

Re: virtualbox-guest-modules and virtualbox-guest-utils require kernel 3.7

Cheers mate that did it. Didn't even occur to me to check my kernel version. Thanks for your help.

Offline

Board footer

Powered by FluxBB