You are not logged in.

#1 2005-11-03 10:17:06

Kalidor
Member
Registered: 2004-06-18
Posts: 80

gcc and â's in error messages

Since upgrading to gcc 4.02, error messages are not as useful as before... I get lots of "â"'s...

Examples:

d.cc: In function â:
d.cc:58: error: call of overloaded â is ambiguous
g++ -Wall -od d.cc
d.cc: In function â:
d.cc:19: error: â was not declared in this scope
d.cc:20: error: expected `;' before â
d.cc:41: error: â was not declared in this scope
d.cc:46: error: â was not declared in this scope
d.cc:46: error: â was not declared in this scope
make: *** [d] Error 1

It's always the same. What's wrong?


(None of my functions/variable names have an "â" in it, of course.)

Offline

#2 2005-11-03 15:30:51

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: gcc and â's in error messages

what's your locale set to? sounds like an internationalization issue to me

Offline

#3 2005-11-04 07:48:43

neri
Forum Fellow
From: Victoria, Canada
Registered: 2003-05-04
Posts: 552

Re: gcc and â's in error messages

phrakture wrote:

what's your locale set to? sounds like an internationalization issue to me

Yupp, my guess, too. *.utf8 locale and a non utf8 capable term like mrxvt or aterm.

-neri

Offline

#4 2005-11-04 08:56:29

Kalidor
Member
Registered: 2004-06-18
Posts: 80

Re: gcc and â's in error messages

Thanks for your replies.

You're right, it seems to be a "locales" problem.

When LC_ALL is set to en_US.utf8, gcc produces those "â"'s. When it is set to en_US, everything's fine with gcc. However, I would like to be able to type in umlauts (äöü) in the terminal (I'm using xterm by the way), which is only possible with the former setting. Is there any way to have both?

Offline

#5 2005-11-04 11:32:39

neri
Forum Fellow
From: Victoria, Canada
Registered: 2003-05-04
Posts: 552

Re: gcc and â's in error messages

Kalidor wrote:

Thanks for your replies.

You're right, it seems to be a "locales" problem.

When LC_ALL is set to en_US.utf8, gcc produces those "â"'s. When it is set to en_US, everything's fine with gcc. However, I would like to be able to type in umlauts (äöü) in the terminal (I'm using xterm by the way), which is only possible with the former setting. Is there any way to have both?

well, I'm pretty sure that if you use en_US.utf8 and term term issue. Please try uxterm and report if it remains. It should be possible to default xterm behaviour to utf8 by some .Xedafault settings

-neri

Offline

#6 2005-11-05 09:30:14

Kalidor
Member
Registered: 2004-06-18
Posts: 80

Re: gcc and â's in error messages

Using uxterm instead of xterm solves matters. Thanks a lot.

Offline

Board footer

Powered by FluxBB