You are not logged in.

#1 2013-01-22 18:56:52

Sakphul
Member
Registered: 2012-02-07
Posts: 3

LPcxpresso 32bit under 64bit arch

Hello everyone,
I am trying to install the LPCxpresso v5.0.12 IDE on an 64bit archlinux with Kernel 3.6.11. But when I try to start the IDE an error occurs with the following log output from
/home/albert/.eclipse/org.eclipse.platform_4.2.0_467367285/configuration/1358882673954.log

!SESSION 2013-01-22 20:49:29.142 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_18
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=de_DE
Command-line arguments:  -os linux -ws gtk -arch x86

!ENTRY org.eclipse.osgi 4 0 2013-01-22 20:49:30.191
!MESSAGE Application error
!STACK 1
java.lang.UnsatisfiedLinkError: Could not load SWT library. Reasons: 
	/home/albert/.eclipse/org.eclipse.platform_4.2.0_467367285/configuration/org.eclipse.osgi/bundles/210/1/.cp/libswt-pi-gtk-4234.so: libXtst.so.6: Kann die Shared-Object-Datei nicht öffnen: Datei oder Verzeichnis nicht gefunden
	no swt-pi-gtk in java.library.path
	/home/albert/.swt/lib/linux/x86/libswt-pi-gtk-4234.so: libXtst.so.6: Kann die Shared-Object-Datei nicht öffnen: Datei oder Verzeichnis nicht gefunden
	Can't load library: /home/albert/.swt/lib/linux/x86/libswt-pi-gtk.so

	at org.eclipse.swt.internal.Library.loadLibrary(Library.java:331)
	at org.eclipse.swt.internal.Library.loadLibrary(Library.java:240)
	at org.eclipse.swt.internal.gtk.OS.<clinit>(OS.java:22)
	at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:63)
	at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:54)
	at org.eclipse.swt.widgets.Display.<clinit>(Display.java:133)
	at org.eclipse.ui.internal.Workbench.createDisplay(Workbench.java:653)
	at org.eclipse.ui.PlatformUI.createDisplay(PlatformUI.java:161)
	at org.eclipse.ui.internal.ide.application.IDEApplication.createDisplay(IDEApplication.java:154)
	at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:96)
	at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:353)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:180)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
	at java.lang.reflect.Method.invoke(Unknown Source)
	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:629)
	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:584)
	at org.eclipse.equinox.launcher.Main.run(Main.java:1438)

It looks like the application cannot load the libswt-pi-gtk-4234.so in/home/albert.swt. But the file is present there, the only file missing is the libswt-pi-gtk.so. But i can't find any package which contains this library.

I also tried installing the regular eclipse package (LPCxpresso is based on eclipse) and this is working perfect.

Anyone got a hint for me to solve my problem? My next step would be to try an 32bit chroot if it does not work that way. Otherwise i wouldhave to change to Linux Mint, where this IDe is working flawlessly.

Offline

#2 2013-01-23 12:19:44

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,205

Re: LPcxpresso 32bit under 64bit arch

Looks like something was not setup in java correctly during your install.
Possibly the swt library supplied by LPXexpresso is not compabile with arch.
Have you tried using swt from extra repo instead of the included one ?


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#3 2013-01-24 20:30:22

Sakphul
Member
Registered: 2012-02-07
Posts: 3

Re: LPcxpresso 32bit under 64bit arch

I also tried installing the swt package from the [extra] repo, but this also did not work as expected. After that i tried a 32bit arch chroot which worked partially. I was now able to run the IDE, but was missing some menu items. So i tried an older version (Version 4.3 instead of Version 5) and now it works. Looks like there was an error within the IDE and not a problem by arch...wrote a Bugreporter to Code Red about it.

Offline

#4 2013-02-21 22:59:07

gauthier
Member
Registered: 2013-02-21
Posts: 2

Re: LPcxpresso 32bit under 64bit arch

I was having this problem with version 5, and installed version 4.3 instead.
Now I get a different log file, it is now located at ~/workspace/.metadata/.log
Java is trying to load libs from /tmp, which seems very weird. libswt-pi-gtk-3659.so is there, but not libswt-pi-gtk.so.
I created symbolic links to /usr/lib/libXtst* inside /tmp/swtlib-32/, to no av.

Any idea what is going on? What is the version of LPCexpresso you got working? I was trying 4.3.0_1025.

!SESSION 2013-02-20 06:29:03.062 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_18
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US
Command-line arguments:  -os linux -ws gtk -arch x86

!ENTRY org.eclipse.osgi 4 0 2013-02-20 06:29:09.820
!MESSAGE Application error
!STACK 1
java.lang.UnsatisfiedLinkError: Could not load SWT library. Reasons: 
    /home/gauthier/.eclipse/org.eclipse.platform_3.6.1_1223183618/configuration/org.eclipse.osgi/bundles/164/1/.cp/libswt-pi-gtk-3659.so: libXtst.so.6: cannot open shared object file: No such file or directory
	no swt-pi-gtk in java.library.path
	Can't load library: /tmp/swtlib-32/libswt-pi-gtk-3659.so
	Can't load library: /tmp/swtlib-32/libswt-pi-gtk.so
	/tmp/swtlib-32/libswt-pi-gtk-3659.so: libXtst.so.6: cannot open shared object file: No such file or directory

	at org.eclipse.swt.internal.Library.loadLibrary(Library.java:267)
	at org.eclipse.swt.internal.Library.loadLibrary(Library.java:174)
	at org.eclipse.swt.internal.gtk.OS.<clinit>(OS.java:22)
	at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:63)
	at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:54)
	at org.eclipse.swt.widgets.Display.<clinit>(Display.java:132)
	at org.eclipse.ui.internal.Workbench.createDisplay(Workbench.java:687)
	at org.eclipse.ui.PlatformUI.createDisplay(PlatformUI.java:161)
	at org.eclipse.ui.internal.ide.application.IDEApplication.createDisplay(IDEApplication.java:145)
	at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:88)
	at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
	at java.lang.reflect.Method.invoke(Unknown Source)
	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:620)
	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:575)
	at org.eclipse.equinox.launcher.Main.run(Main.java:1408)

Offline

Board footer

Powered by FluxBB