You are not logged in.

#1 2013-01-22 08:35:22

Harey
Member
From: Bavaria, Germany
Registered: 2007-03-24
Posts: 292

[SOLVED]bash-4.2.042-2 turns system unusable

Todays update from bash-4.2.042-1 to bash-4.2.042-2 turns my sytem unusable. No login Manager (KDM) anymore and trying to use tty login I could give username and password then the shell would end itself and just show the login prompt again. Logging in via ssh failed with

harvey@obelix ~ $ ssh root@gutemine
Last login: Tue Jan 22 09:09:55 2013 from 192.168.1.1
/bin/bash: Exec format error
Connection to gutemine closed.

I started with an Install disk and as you wold guess I couldn't chroot into the installation. I had to manually overwrite the files from bash-4.2.042-2 with the files from bash-4.2.042-1. After a reboot all was well again.

Filed a bug report as well: https://bugs.archlinux.org/task/33507

Harvey

Last edited by Harey (2013-01-22 11:53:23)


Linux is like a wigwam: No Gates, no Windows and an Apache inside

Offline

#2 2013-01-22 09:18:06

phanisvara
Member
From: west bengal, india
Registered: 2012-07-08
Posts: 74

Re: [SOLVED]bash-4.2.042-2 turns system unusable

strange, while i also received this update, nothing went wrong on my system. what else did happen during that update?

in my case, an update to filesystem required a little manual intervention, as i had files under /usr/lib64, and pacman initially refused to apply the update because of this.

Offline

#3 2013-01-22 11:53:06

Harey
Member
From: Bavaria, Germany
Registered: 2007-03-24
Posts: 292

Re: [SOLVED]bash-4.2.042-2 turns system unusable

this seemed to be caused by a broken download. I deleted the original download and tried again - fingers crossed. This time all was o.k. Marking this as solved.

Thanks
Harvey


Linux is like a wigwam: No Gates, no Windows and an Apache inside

Offline

#4 2013-01-22 20:13:15

adee
Member
From: The Moon
Registered: 2009-11-10
Posts: 107

Re: [SOLVED]bash-4.2.042-2 turns system unusable

But what happened to the checksum validation? Not to mention the signing key check? You shouldn't be able to install such package.

Offline

#5 2013-01-22 21:20:46

Harey
Member
From: Bavaria, Germany
Registered: 2007-03-24
Posts: 292

Re: [SOLVED]bash-4.2.042-2 turns system unusable

I have SigLevel = PackageRequired with all my repo entries in pacman.conf. So yes, this is weird and shouldn't have happened hmm

Harvey


Linux is like a wigwam: No Gates, no Windows and an Apache inside

Offline

Board footer

Powered by FluxBB