You are not logged in.

#4676 2013-01-22 21:34:13

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,299
Website

Re: The AMD/ATI Bar & Grill

catalyst 13.1 legacy

siavashserver wrote:

EDIT 1 : Sounds like only noticeable change is adding gl_ext_texture_srgb_decode OpenGL extension support for people playing Valve's Source engine powered games on Linux, nothing more.

yup, what a pity...

While today's testing i've noted how many bugfixes have been missing in legacy, it came up to me with all it's force like a jizz in a pants, darn...
It's not just about xserver 1.13, fsck it tongue, you probably won't even notice it's new features - but the way of how chromium/chrome (no compositing) or kwin's direct rendering works is just so... aaargh!... no comments.
Still i'm surprised that AMD released legacy driver, though... + at least Steam users won't spam AMD's forum that much, LOL...

I've updated AUR and repo with this new driver, what's also worth to mention is 3V0LU710N's comment:
"1) "Unsupported Hardware" logo still appears. (using control file from 12.4 fixes the problem)"
You can find control file here, overwrite /etc/ati/control with it if mentioned problem appeared.

Last edited by Vi0L0 (2013-01-22 22:22:38)

Offline

#4677 2013-01-22 23:13:46

MannImMond
Member
Registered: 2012-10-24
Posts: 7

Re: The AMD/ATI Bar & Grill

Thanks for the update Violo. Looking forward to try out TF2. I just noted that Legend of Grimrock, which previously failed with an "Failed to initialize glew" is now working properly. Not sure though if that's related to the AMD update.

Offline

#4678 2013-01-23 07:37:04

goofy03
Member
Registered: 2011-07-09
Posts: 14

Re: The AMD/ATI Bar & Grill

Vi0L0 wrote:

catalyst 13.1 legacy
It's not just about xserver 1.13, fsck it tongue, you probably won't even notice it's new features - but the way of how chromium/chrome (no compositing) or kwin's direct rendering works is just so... aaargh!... no comments.

You means don't work ? it's ironic ?

I try to lauch kwin_gles --replace but :

libEGL warning: DRI2: failed to authenticate
libEGL warning: DRI2: failed to open swrast (search paths /usr/lib/xorg/modules/dri/)
kwin(1128): Required support for binding pixmaps to EGLImages not found, disabling compositing 
kwin(1128): Failed to initialize compositing, compositing disabled 
kwin(1128): Consult http://techbase.kde.org/Projects/KWin/4.0-release-notes#Setting_up

And i must do KWIN_DIRECT_GL=1 kwin --replace & to get Direct Rendering=yes in kwin even a glxinfo | grep direct tell me that direct rendering: Yes.

Do you have some advice or tweak to get the state of the art on kde eyes candies ? :-) I saw something to change on Qt too but can't remember what …

Offline

#4679 2013-01-23 09:03:46

mannemerak
Member
Registered: 2010-03-03
Posts: 14

Re: The AMD/ATI Bar & Grill

Hi, (me again, same problem) trying to get PXP working on Dell Vostro 3560, hybrid Intel - AMD Radeon HD 7600M using latest catalyst-total-pxp from Vi0L0.
With xf86-video-intel-git, xorg-server 1.13 and kernel 3.7, nomodeset, and symlink /usr/lib64; the fglrx module just segfaults.  I am obviously missing some step somewhere?
Using the pxp switch script , going to AMD seems fine, but switching to Intel and doing a query returns "unknown"?

So, my question, where do I start debugging?

update pxp switch script working now, there was no </usr/lib/libGL.so.1.2> only </usr/lib/libGL.so.1.2.0>, created symlink and now query works as expected.

Output trying Intel (same for catalyst)

[   861.235] (II) fglrx(0): PowerXpress: Diagnostic output from /usr/lib64/fglrx/switchlibGL:
Switch to Intel

[   861.247] (EE) 
[   861.247] (EE) Backtrace:
[   861.261] (EE) 0: X (xorg_backtrace+0x36) [0x58a426]
[   861.261] (EE) 1: X (0x400000+0x18e279) [0x58e279]
[   861.261] (EE) 2: /usr/lib/libpthread.so.0 (0x7fc693e9b000+0xf1e0) [0x7fc693eaa1e0]
[   861.262] (EE) 3: /usr/lib/xorg/modules/drivers/fglrx_drv.so (xdl_xs113_atiddxPxPreInit+0x11e) [0x7fc69105b9be]
[   861.262] (EE) 4: /usr/lib/xorg/modules/drivers/fglrx_drv.so (xdl_xs113_atiddxPreInit+0x1fcb) [0x7fc6910382cb]
[   861.262] (EE) 5: X (InitOutput+0xa72) [0x479f22]
[   861.262] (EE) 6: X (0x400000+0x26786) [0x426786]
[   861.262] (EE) 7: /usr/lib/libc.so.6 (__libc_start_main+0xf5) [0x7fc692b1fa15]
[   861.262] (EE) 8: X (0x400000+0x26cad) [0x426cad]
[   861.262] (EE) 
[   861.262] (EE) Segmentation fault at address 0x50 

Last edited by mannemerak (2013-01-23 14:18:12)

Offline

#4680 2013-01-23 10:24:27

omeringen
Member
Registered: 2012-05-28
Posts: 109

Re: The AMD/ATI Bar & Grill

Thanks for the update. I am still getting same error, any ideas ?

omeringen wrote:

Hi,
After i switched to catalyst-legacy i am getting an error while trying to open Bastion game. It was fine with open source drivers, i was using bastionmesa to join.
Found this but still same.

Unhandled Exception: System.Exception: Shader error
  at Microsoft.Xna.Framework.Graphics.Effect.CompileShaderFromSource (System.String source, ShaderType shaderType) [0x00000] in <filename unknown>:0 
  at Microsoft.Xna.Framework.Graphics.Effect.CreateFragmentShaderFromSource (System.String source) [0x00000] in <filename unknown>:0 
  at Microsoft.Xna.Framework.Graphics.SpriteEffect..ctor (Microsoft.Xna.Framework.Graphics.GraphicsDevice graphicsDevice) [0x00000] in <filename unknown>:0 
  at Microsoft.Xna.Framework.Graphics.SpriteBatch..ctor (Microsoft.Xna.Framework.Graphics.GraphicsDevice graphicsDevice) [0x00000] in <filename unknown>:0 
  at GSGE.ExceptionGame.LoadContent () [0x00000] in <filename unknown>:0 
  at Microsoft.Xna.Framework.Game.Initialize () [0x00000] in <filename unknown>:0 
  at Microsoft.Xna.Framework.Game.Run (GameRunBehavior runBehavior) [0x00000] in <filename unknown>:0 
  at Microsoft.Xna.Framework.Game.Run () [0x00000] in <filename unknown>:0 
  at GSGE.App.Run[App] () [0x00000] in <filename unknown>:0 
  at GSGE.App.Main (System.String[] args) [0x00000] in <filename unknown>:0 
[ERROR] FATAL UNHANDLED EXCEPTION: System.Exception: Shader error
  at Microsoft.Xna.Framework.Graphics.Effect.CompileShaderFromSource (System.String source, ShaderType shaderType) [0x00000] in <filename unknown>:0 
  at Microsoft.Xna.Framework.Graphics.Effect.CreateFragmentShaderFromSource (System.String source) [0x00000] in <filename unknown>:0 
  at Microsoft.Xna.Framework.Graphics.SpriteEffect..ctor (Microsoft.Xna.Framework.Graphics.GraphicsDevice graphicsDevice) [0x00000] in <filename unknown>:0 
  at Microsoft.Xna.Framework.Graphics.SpriteBatch..ctor (Microsoft.Xna.Framework.Graphics.GraphicsDevice graphicsDevice) [0x00000] in <filename unknown>:0 
  at GSGE.ExceptionGame.LoadContent () [0x00000] in <filename unknown>:0 
  at Microsoft.Xna.Framework.Game.Initialize () [0x00000] in <filename unknown>:0 
  at Microsoft.Xna.Framework.Game.Run (GameRunBehavior runBehavior) [0x00000] in <filename unknown>:0 
  at Microsoft.Xna.Framework.Game.Run () [0x00000] in <filename unknown>:0 
  at GSGE.App.Run[App] () [0x00000] in <filename unknown>:0 
  at GSGE.App.Main (System.String[] args) [0x00000] in <filename unknown>:0 

Offline

#4681 2013-01-23 21:56:27

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,299
Website

Re: The AMD/ATI Bar & Grill

@goofy03:
afaik there is no way of improving kwin's direct rendering for catalyst.

AMD has fixed it in newer catalysts and it became pretty much stable, fast and without glitches.
catalyst legacy came without fixes, and so:
- movies are tearing even when tear-free option is checked;
- there's a glitching mess on the screen if only you will try to run opengl app or game;
- overall performance is not that good;
if only you will enable kwin's dri.

Personally i'm using /etc/profile entry:

export KWIN_DIRECT_GL=1

(+ kde's systemsettings) to enable it.
Edit: i'm also enabling kde's v-sync when using tear-free feature (so non-stop), otherwise it's laggy (at least on hd 7850).



@mannemerak:
many thanks for this useful feedback!
I will update -pxp packages as soon as i can (probably on the weekend).

BTW: symlinking anything to /usr/lib is kinda risky, be aware when removing that kind of symlink (imho it's safer to use `unlink <symlink>` command :>).
With next update i'm gonna just put those switching scripts into /usr/lib64/fglrx/ dir, without symlinking (this doesn't probably mean that you have to remove your symlink).

Last edited by Vi0L0 (2013-01-23 22:14:51)

Offline

#4682 2013-01-23 23:30:19

Cdh
Member
Registered: 2009-02-03
Posts: 1,098

Re: The AMD/ATI Bar & Grill

By the way,

LC_ALL=C pacman -Qo /usr/lib64
/usr/lib64 is owned by filesystem 2013.01-1

is in testing


฿ 18PRsqbZCrwPUrVnJe1BZvza7bwSDbpxZz

Offline

#4683 2013-01-24 08:39:33

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,299
Website

Re: The AMD/ATI Bar & Grill

Cdh wrote:

By the way,

LC_ALL=C pacman -Qo /usr/lib64
/usr/lib64 is owned by filesystem 2013.01-1

is in testing

Thanks for the info, indeed:

Allan McRae wrote:

/lib and /lib64 symlinks have been moved from glibc to the filesystem
package. Also a /usr/lib64 symlink has been added

Turns out i won't have to move switching scripts to the /usr/lib64, because it will already be there.
Wondering when new filesystem will appear in [core].

Offline

#4684 2013-01-24 22:38:17

ChemBro
Member
Registered: 2008-10-22
Posts: 665

Re: The AMD/ATI Bar & Grill

Catalyst 13.2 beta will be released next week.

Sauce: https://twitter.com/CatalystCreator/sta … 8653185024

Hopefully, this is the performance driver, they were talking about.

Offline

#4685 2013-01-25 05:03:48

deags
Member
Registered: 2012-12-28
Posts: 23

Re: The AMD/ATI Bar & Grill

I tried updating from catalyst-test (I think this what i got from AUR) to catalyst-hook. Had issues with X screensavers; it'd go into low power mode, then I could not get out. Also if I ctrl alt F'ed into another session, I'd just get a black screen and not be able to do anything. I removed everything related to catalyst (If I just removed -hook then pacman would refuse to install -total due to conflicts), put on -total from scratch and no issues now.

In case someone has the same issue.

Offline

#4686 2013-01-25 06:52:03

DarksideEE7
Member
From: Arkansas, United States
Registered: 2009-06-06
Posts: 356

Re: The AMD/ATI Bar & Grill

Just wanted to mention (for anyone interested) that the 7950 works perfectly with the latest catalyst-dkms.  Tear-free works, H264 looks great, etc.  All of this in kwin.  I never really found any concrete info regarding this before I ordered my card so hopefully someone else might find this useful.

Offline

#4687 2013-01-25 15:54:22

Nabobalis
Member
Registered: 2009-07-25
Posts: 6

Re: The AMD/ATI Bar & Grill

Is it possible to get the amd drivers to work with xcompmgr? I've enabled composite in xorg.conf but that doesn't seem to work so I would assume that I can't.

Edit: Never mind, I can't use composite and Xinerama at the same time. So I can't get any transparency effects?

Edit2: I stopped using Xinerama and created a multi monitor setup with the display manager. Now it works.

Last edited by Nabobalis (2013-01-25 16:02:53)

Offline

#4688 2013-01-25 21:35:04

PLANTROON
Member
From: Slovakia
Registered: 2012-08-08
Posts: 61

Re: The AMD/ATI Bar & Grill

I can't build fglrx module for linux-pf kernel sad

/var/log/catalyst-install.log:

...
patching file kcl_acpi.c
OsVersion says: SMP=1
file /proc/kallsyms says: SMP=1
file /usr/lib/modules/3.7-pf/build/include/generated/autoconf.h says: SMP=1
file /usr/lib/modules/3.7-pf/build/include/generated/autoconf.h says: MODVERSIO$
file /usr/lib/modules/3.7-pf/build/arch/x86/include/asm/compat.h says: COMPAT_A$
make: Entering directory `/usr/src/linux-3.7-pf'
  CC [M]  /tmp/catalyst.uSusFY/firegl_public.o
/tmp/catalyst.uSusFY/firegl_public.c: In function ‘KCL_MEM_VM_MapRegion’:
/tmp/catalyst.uSusFY/firegl_public.c:3714:39: error: ‘VM_RESERVED’ undeclared ($
/tmp/catalyst.uSusFY/firegl_public.c:3714:39: note: each undeclared identifier $
make[1]: *** [/tmp/catalyst.uSusFY/firegl_public.o] Error 1
make: *** [_module_/tmp/catalyst.uSusFY] Error 2
make: Leaving directory `/usr/src/linux-3.7-pf'

EDIT: Umm .... Started TF2, played a bit .. then I stopped playing cos it was so laggy. Then I decided I will try to play it again and ... Error message: Could not create opengl device .... and a link to support for DirectX ... yay sad playing World of Goo (with Vsync set to always on and tear free dekstop on.... the image is still tearing)

Last edited by PLANTROON (2013-01-25 22:02:52)

Offline

#4689 2013-01-25 23:02:04

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,299
Website

Re: The AMD/ATI Bar & Grill

@PLANTROON: so you did compile it on linux-pf?
The bug is telling that the patch for 3.7 kernel was not applied, i dunno why, could be something with your kernel config

Offline

#4690 2013-01-25 23:09:26

PLANTROON
Member
From: Slovakia
Registered: 2012-08-08
Posts: 61

Re: The AMD/ATI Bar & Grill

Vi0L0 wrote:

@PLANTROON: so you did compile it on linux-pf?
The bug is telling that the patch for 3.7 kernel was not applied, i dunno why, could be something with your kernel config

I could compile it on the default archlinux kernel (3.7.4-1-ARCH) On linux-pf it doesn't compile.

Last edited by PLANTROON (2013-01-25 23:10:48)

Offline

#4691 2013-01-25 23:24:01

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,299
Website

Re: The AMD/ATI Bar & Grill

PLANTROON wrote:
Vi0L0 wrote:

@PLANTROON: so you did compile it on linux-pf?
The bug is telling that the patch for 3.7 kernel was not applied, i dunno why, could be something with your kernel config

I could compile it on the default archlinux kernel (3.7.4-1-ARCH) On linux-pf it doesn't compile.

Which catalyst package are you using to compile? + what's the output of `uname -r`on linux-pf?

Offline

#4692 2013-01-26 08:31:13

PLANTROON
Member
From: Slovakia
Registered: 2012-08-08
Posts: 61

Re: The AMD/ATI Bar & Grill

Vi0L0 wrote:
PLANTROON wrote:
Vi0L0 wrote:

@PLANTROON: so you did compile it on linux-pf?
The bug is telling that the patch for 3.7 kernel was not applied, i dunno why, could be something with your kernel config

I could compile it on the default archlinux kernel (3.7.4-1-ARCH) On linux-pf it doesn't compile.

Which catalyst package are you using to compile? + what's the output of `uname -r`on linux-pf?

I'm using catalyst-hook from your repo.

uname -r on linux-pf:

3.7-PF

Offline

#4693 2013-01-26 10:04:21

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,299
Website

Re: The AMD/ATI Bar & Grill

@PLANTROON:
fix your kernel release please - there's no kernel in version 3.7 actually, but 3.7.1, 3.7.2 and so...

Offline

#4694 2013-01-26 20:16:38

PLANTROON
Member
From: Slovakia
Registered: 2012-08-08
Posts: 61

Re: The AMD/ATI Bar & Grill

Vi0L0 wrote:

@PLANTROON:
fix your kernel release please - there's no kernel in version 3.7 actually, but 3.7.1, 3.7.2 and so...

I'm not sure if I did it right, but I installed linux-pf from AUR this time. Still not working. sad on PF kernel I never get 3.7.X version. I know that back in December 2012 it worked with 12.6 driver. Now it doesn't sad The problem seems to be somewhere else sad

Offline

#4695 2013-01-27 10:22:02

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,299
Website

Re: The AMD/ATI Bar & Grill

PLANTROON wrote:
Vi0L0 wrote:

@PLANTROON:
fix your kernel release please - there's no kernel in version 3.7 actually, but 3.7.1, 3.7.2 and so...

I'm not sure if I did it right, but I installed linux-pf from AUR this time. Still not working. sad on PF kernel I never get 3.7.X version. I know that back in December 2012 it worked with 12.6 driver. Now it doesn't sad The problem seems to be somewhere else sad

Maybe it was working because there was no patch to apply? You are using mainline catalyst (not legacy), right?
The error:

firegl_public.c:3714:39: error: ‘VM_RESERVED’ undeclared ($

is directly saying that 3.7 patch was not applied.

Look, the patch is using preprocessor' directives ie.

#if LINUX_VERSION_CODE < KERNEL_VERSION(3,7,0)

as you can see KERNEL_VERSION is described with 3 numbers (a,b,c), if i'm right (i rly could be wrong here, not sure) and uname -r is returning values likewise KERNEL_VERSION - then it means that you are using 2 numbers (a,b) to describe KERNEL_VERSION. If it is so then this is a bug and should be fixed by linux-pf maintainer. In whole linux we are using (a,b,c), even first 3.0 line kernel was versioned as 3.0.0, not 3.0

+ the log you paste is not full, i guess. Can you paste all "patching" lines?

Last edited by Vi0L0 (2013-01-27 10:36:28)

Offline

#4696 2013-01-27 22:12:07

PLANTROON
Member
From: Slovakia
Registered: 2012-08-08
Posts: 61

Re: The AMD/ATI Bar & Grill

Vi0L0 wrote:
PLANTROON wrote:
Vi0L0 wrote:

@PLANTROON:
fix your kernel release please - there's no kernel in version 3.7 actually, but 3.7.1, 3.7.2 and so...

I'm not sure if I did it right, but I installed linux-pf from AUR this time. Still not working. sad on PF kernel I never get 3.7.X version. I know that back in December 2012 it worked with 12.6 driver. Now it doesn't sad The problem seems to be somewhere else sad

Maybe it was working because there was no patch to apply? You are using mainline catalyst (not legacy), right?
The error:

firegl_public.c:3714:39: error: ‘VM_RESERVED’ undeclared ($

is directly saying that 3.7 patch was not applied.

Look, the patch is using preprocessor' directives ie.

#if LINUX_VERSION_CODE < KERNEL_VERSION(3,7,0)

as you can see KERNEL_VERSION is described with 3 numbers (a,b,c), if i'm right (i rly could be wrong here, not sure) and uname -r is returning values likewise KERNEL_VERSION - then it means that you are using 2 numbers (a,b) to describe KERNEL_VERSION. If it is so then this is a bug and should be fixed by linux-pf maintainer. In whole linux we are using (a,b,c), even first 3.0 line kernel was versioned as 3.0.0, not 3.0

+ the log you paste is not full, i guess. Can you paste all "patching" lines?

K for now stock arch kernel is good for me ... Thx for ur help anyway. I'm gonna try to get a new GPU because I think AMD will never improve performance in Source Engine games and TF2 was running at 10 FPS max sad

Offline

#4697 2013-01-27 22:20:34

Foks
Member
Registered: 2010-12-27
Posts: 18

Re: The AMD/ATI Bar & Grill

Vi0L0 wrote:

how chromium/chrome (no compositing) or kwin's direct rendering works is just so... aaargh!... no comments.

It seems to work better with "OpenGL 2 Shaders" disabled in systemsettings.

Offline

#4698 2013-01-28 01:38:24

CyberNhull
Member
Registered: 2013-01-27
Posts: 68

Re: The AMD/ATI Bar & Grill

Hello people. I had a problem with the legacy drivers..i have a hd 5145 (which is a HD 4xxx overclocked) and tried to install 13.1 legacy drivers from repositories. So what i did was add to repository:

[catalyst-hd234k]
Server = http://catalyst.apocalypsus.net/repo/ca … 234k/$arch

[xorg112]
Server = http://catalyst.apocalypsus.net/repo/xorg112/$arch

Did the downgrade:

 sudo pacman -Suu 

Installed the catalyst drivers

 sudo pacman -S catalyst catalyst-utils

But when i do the aticonfig  --initial command it says there are no adapters detected and if i reboot i am greated with my tty.
What is it that i'm doing wrong? xD
Thanks in advance.


If it does not kill you....It will make you smarter

Offline

#4699 2013-01-28 03:47:09

ChemBro
Member
Registered: 2008-10-22
Posts: 665

Re: The AMD/ATI Bar & Grill

CyberNhull wrote:

aticonfig  --initial

I thought, this is obsolete and it is now amdconfig. Also "-f" works great (amdconfig --initial -f).

Offline

#4700 2013-01-28 09:22:25

dffx
Member
Registered: 2011-05-02
Posts: 15

Re: The AMD/ATI Bar & Grill

I've been wrestling with the fglrx drivers for weeks now (AMD 7970M with Intel integrated, Enduro, Clevo P150EM) and I've finally got it working. However, I'm running into an issue when using fglrx with xrandr -- I get dual monitors working, but there's a lot of strange artifacting and other flickering in on my windows (when hovering buttons with the mouse, for instance) or moving windows.

Has anyone run into this? Do I have to manually set refresh rates and such?

Using latest catalyst-total-pxp

EDIT: To clarify, there's no flickering when I'm either only using the laptop monitor, or have them cloned.

Last edited by dffx (2013-01-28 09:23:18)

Offline

Board footer

Powered by FluxBB