You are not logged in.

#1 2012-12-23 21:26:53

fawkes5
Member
From: Canada
Registered: 2012-12-23
Posts: 84

net-auto-wireless.service failed

Hello,

New to arch, just installed yesturday, still finding my bearings.

Everything going smoothly except wireless. I have to manually connect to wireless each time i log in,
using wifi-menu. My auto-wireless doesnt work.

Heres my systemctl status net-auto-wireless.service output:

net-auto-wireless.service - Automatic wireless network connection on 
	  Loaded: loaded (/usr/lib/systemd/system/net-auto-wireless.service; disabled)
	  Active: inactive (dead)
	  CGroup: name=systemd:/system/net-auto-wireless.service

Dec 23 15:27:28 localhost netcfg-wpa_actiond[248]: Could not read interface wlan0 flags: No such device
Dec 23 15:27:28 localhost netcfg-wpa_actiond[248]: Could not read interface wlan0 flags: No such device
Dec 23 15:27:28 localhost netcfg-wpa_actiond[248]: Could not read interface wlan0 flags: No such device
Dec 23 15:27:28 localhost netcfg-wpa_actiond[248]: WEXT: Could not set interface 'wlan0' UP
Dec 23 15:27:28 localhost netcfg-wpa_actiond[248]: wlan0: Failed to initialize driver interface
Dec 23 15:27:29 localhost systemd[1]: Failed to start Provides automatic netcfg wireless connection.
Dec 23 15:27:29 localhost systemd[1]: Unit net-auto-wireless.service entered failed state
Dec 23 15:51:06 localhost systemd[1]: Dependency failed for Automatic wireless network connection on .
Dec 23 15:53:33 localhost systemd[1]: Dependency failed for Automatic wireless network connection on .
Dec 23 16:07:57 localhost systemd[1]: Dependency failed for Automatic wireless network connection on .

How do i find this dependency failure? What other information do you need to help me?

Thank you so much!

Offline

#2 2012-12-23 22:00:03

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: net-auto-wireless.service failed

rfkill

Offline

#3 2012-12-23 22:17:27

fawkes5
Member
From: Canada
Registered: 2012-12-23
Posts: 84

Re: net-auto-wireless.service failed

I installed rfkill

 pacman -S rfkill 

and then rebooted.

But then i still get the exact same systemctl status report as above

Last edited by fawkes5 (2012-12-23 23:21:37)

Offline

#4 2012-12-24 00:19:47

metgz
Member
From: United States
Registered: 2012-11-13
Posts: 21

Re: net-auto-wireless.service failed

I had a similar problem a while back.

It seems like net-auto-wireless can't find the interface.

Try running

# ip link set wlan0 up

That will essentially 'create' wlan0. If that works, try starting net-auto-wireless, and see if you get the same error.

If it is a stationary machine (i.e. not a laptop), you could just use the wpa_supplicant daemon instead of net-auto-wireless.

# systemctl enable wpa_supplicant

Offline

#5 2012-12-28 19:52:36

fawkes5
Member
From: Canada
Registered: 2012-12-23
Posts: 84

Re: net-auto-wireless.service failed

Doesn't change anything. However i think your onto something.
My netcfg unit also has trouble
Running systemctl status netcfg i get:

netcfg.service - Netcfg multi-profile daemon
	  Loaded: loaded (/usr/lib/systemd/system/netcfg.service; enabled)
	  Active: active (exited) since Fri, 2012-12-28 14:32:35 EST; 15min ago
	 Process: 659 ExecStart=/usr/bin/netcfg-daemon start (code=exited, status=0/SUCCESS)
	  CGroup: name=systemd:/system/netcfg.service

Dec 28 14:32:35 localhost systemd[1]: Starting Netcfg multi-profile daemon...
Dec 28 14:32:35 localhost netcfg-daemon[659]: :: wlan0-robertson up interface wlan0 does not exist
Dec 28 14:32:35 localhost netcfg-daemon[659]: [fail]
Dec 28 14:32:35 localhost systemd[1]: Started Netcfg multi-profile daemon.

This might be a bug according to:
https://bbs.archlinux.org/viewtopic.php?id=151662

But i dont understand. I can manually connect to my network using netcfg, so the interface must exist?
Anyways i have a feeling that this is connected to my original problem

Last edited by fawkes5 (2012-12-28 19:58:21)

Offline

#6 2012-12-28 21:08:45

metgz
Member
From: United States
Registered: 2012-11-13
Posts: 21

Re: net-auto-wireless.service failed

That bug sounds familiar. I could never get netcfg to work properly, I eventually gave up and switched to NetworkManager. It is a hell of a lot easier to configure.

Consider trying NetworkManager, because you are more than likely encountering that bug.

The bug arises from the fact that net-auto-wireless is started by systemd before the interface is set up. There might be a workaround. You can disable net-auto-wireless, and then manually start it AFTER you set the interface up, and see if it still can't find the interface.

# systemctl disable net-auto-wireless
# systemctl stop net-auto-wireless 
# ip link set wlan0 down
# ip link set wlan0 up
# systemctl start net-auto-wireless
# ping -c 3 google.com

The problem with this setup is, you still have to manually start net-auto-wireless every time you want to connect to the internet, thus defeating the point of netcfg.

Last edited by metgz (2012-12-28 21:18:28)

Offline

#7 2012-12-29 03:41:00

fawkes5
Member
From: Canada
Registered: 2012-12-23
Posts: 84

Re: net-auto-wireless.service failed

Hey metgz,

Thanks for the suggestion. I've removed netcfg and switched to NetworkManager and all is well.  Just getting used to it. Havn't been able to find nice documentation on using nmcli but i'm figuring it out.

Should i title this thread solved?

Offline

#8 2012-12-29 03:56:32

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,661

Re: net-auto-wireless.service failed

If it is a bug in netcfg has anybody reported it?


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#9 2012-12-29 05:42:05

metgz
Member
From: United States
Registered: 2012-11-13
Posts: 21

Re: net-auto-wireless.service failed

fawkes5: It is a matter of personal opinion. You found a solution that works for you, but the initial problem is left unsolved. Personally, I would mark it as semi-solved.

cfr: Yes, although the bug report is from 2 months ago, and the solution is to not use netcfg with systemd. It isn't even a 'bug'. It's a design flaw that can't be fixed.

Offline

#10 2012-12-29 09:06:40

Alber
Member
From: Spain - España
Registered: 2011-11-11
Posts: 172

Re: net-auto-wireless.service failed

I'm thinking in another workaround.
If using a X environment, could it be write 'netcfg your-wifi-cfg' in xinitrc (or samething like openbox/start, bashrc...)

Offline

#11 2012-12-30 02:50:37

metgz
Member
From: United States
Registered: 2012-11-13
Posts: 21

Re: net-auto-wireless.service failed

Alber: That would probably work, but I wouldn't suggest it as a solution. Honestly, netcfg is on its way out the door. NetworkManager is just better.

Offline

#12 2012-12-30 11:41:46

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,054

Re: net-auto-wireless.service failed

MN has a LOT MORE dependencies then netcfg.

example : NM has wpa_supplicant as a hard dependency , for netcfg it's an optional dependency.

My desktop only uses wired connections, i have no need for wpa_supplicant there.

Alber : since the problems are between netcfg and systemd, you could also switch to another init system.


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#13 2012-12-30 12:27:36

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,390
Website

Re: net-auto-wireless.service failed

I'm not usually into self-promoting such things, but as this may help those struggling here, I have just announced a new (wireless only) network tool with automatic connection abilities: https://bbs.archlinux.org/viewtopic.php?id=155381

This does properly put the interface up, and will connect at boot if the service file is activated.  It also has minimal dependencies (you almost certainly have them all installed already).

EDIT: lone_wolf, if you only use wired, why do you need any management tool?  Just enable dhcpcd@eth0.service.

Last edited by Trilby (2012-12-30 12:29:55)


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#14 2012-12-30 13:07:59

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,054

Re: net-auto-wireless.service failed

My desktop has 2 network connections, 1 is used for normal traffic with a static ipv4-address and an autoconfigured ipv6 address.
The other is setup as a bridge for VMs, uses dhcp for both ipv4 and ipv6 and is brought up/down manually.
Using netcfg means all my network settings for my desktop are stored in 2 profile files and i am in full control.

interesting tool, Trilby. After i get around to switching my laptop to openrc, i'll consider looking into it.

Alber : looks like trilby's new tool might be just what you're looking for.


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#15 2012-12-30 14:24:26

Alber
Member
From: Spain - España
Registered: 2011-11-11
Posts: 172

Re: net-auto-wireless.service failed

I was waiting for net-auto-wireless fixed its bug. Meanwhile, when it failed, I wrote down 'netcfg homewifi' (in a terminal emulator), and wifi working.
But, when I've read:

metgz wrote:

Yes, although the bug report is from 2 months ago, and the solution is to not use netcfg with systemd. It isn't even a 'bug'. It's a design flaw that can't be fixed.

So I was thinking in use a solution as using .config/openbox/autostart (I'm using Openbox). I like netcfg.
I'll try your solutions, nm and swifer.

Thank you by your ideas.

Offline

#16 2013-01-23 15:59:43

phil
Member
Registered: 2012-09-22
Posts: 72

Re: net-auto-wireless.service failed

netcfg is not connecting to wifi network after boot, net-auto-wireless is enabled but fails to start. I think because it cannot find wlan0 interface. If I start net-auto-wireless manually it connects just fine.
Is this a bug? Will it be fixed? Can I somehow make netcfg wait for wlan0 to come up or something with the same effect?

Offline

#17 2013-01-23 17:14:41

Alber
Member
From: Spain - España
Registered: 2011-11-11
Posts: 172

Re: net-auto-wireless.service failed

It's a consequence from parallelization in systemd. Init was sequential and this problem didn't appear.
You can use "Wants", "Requires", "After", and "Before" to stablish a order.
But by now (I have not much time), I don't know what service net-auto-wireless could wait to set up wlan0.

Last edited by Alber (2013-01-23 17:34:55)

Offline

#18 2013-01-29 03:26:11

phil
Member
Registered: 2012-09-22
Posts: 72

Re: net-auto-wireless.service failed

Made a workaround by making the file

/usr/lib/systemd/system/net-auto-wireless.timer

[Timer]
OnStartupSec=5

[Install]
WantedBy=multi-user.target

Then, I disabled the net-auto-wireless.service and enabled the timer.

Last edited by phil (2013-01-29 03:27:21)

Offline

#19 2013-01-29 14:05:29

dag
Member
From: US
Registered: 2013-01-20
Posts: 216

Re: net-auto-wireless.service failed

phil:

are you sure the interface is called wlan0 try iwconfig to see what is shown. have you used a profile.

Last edited by dag (2013-01-29 14:12:45)


--------------------------------------
alcoves wonder creates the wonder unto the ages; never lose that.

Offline

#20 2013-01-29 14:21:16

phil
Member
Registered: 2012-09-22
Posts: 72

Re: net-auto-wireless.service failed

iwconfig shows:

wconfig
eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11bg  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=off   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off

If I restarted the service after starting X, it worked.

What do you mean by have you used a profile? I use a profile in  netcfg which works and I enabled it in /etc/conf.d/netcfg.

Offline

#21 2013-01-29 17:50:59

dag
Member
From: US
Registered: 2013-01-20
Posts: 216

Re: net-auto-wireless.service failed

Phil wrote:

What do you mean by have you used a profile? I use a profile in  netcfg which works and I enabled it in /etc/conf.d/netcfg.

I mean /etc/network.d profiles that show the network you want to connect to automatically.

It is working fine for me.


--------------------------------------
alcoves wonder creates the wonder unto the ages; never lose that.

Offline

#22 2013-01-30 17:42:33

phil
Member
Registered: 2012-09-22
Posts: 72

Re: net-auto-wireless.service failed

I still don't get it.
So I used netcfg and I have a profile in /etc/network.d. I was able to connect to that network manually, but not automatically on boot.
After creating the timer it works fine.

Offline

#23 2013-03-31 00:25:23

donniezazen
Member
From: Salt Lake City
Registered: 2011-06-24
Posts: 671
Website

Re: net-auto-wireless.service failed

I have the same problem. Thanks for the timer file. I hope this is fixed in future versions of systemd.

Offline

Board footer

Powered by FluxBB