You are not logged in.

#1 2013-01-23 21:09:27

Primoz
Member
From: Ljubljana-Slovena-EU
Registered: 2009-03-04
Posts: 658

Amarok dependancy should be changed from liblastfm0 to liblastfm1

Maybe this isn't the best place to request this, but still, if someone is wondering why last.fm isn't working with Amarok all of the sudden...
Anyway, after I noticed that Amarok not only doesn't scrobble, but also doesn't have the option to set last.fm on, I went to Amarok forums to ask what's the problem, and they said it's probably because Arch still uses liblastfm0 as a dependency.
I checked that and it apparently still does:

S amarok
resolving dependencies...
looking for inter-conflicts...

Targets (5): liblastfm-0.3.3-3  mesa-9.0.1-1  qtscriptgenerator-0.2.0-1  taglib-extras-1.0.1-2  amarok-2.7.0-1

So dependency should be changed to liblastfm1, which is currently unsupported in AUR.

I'll also report the bug, if it wasn't already.
EDIT: It was already reported

Last edited by Primoz (2013-01-23 21:20:56)


Arch x86_64 ATI AMD APU KDE frameworks 5
---------------------------------
Whatever I do, I always end up with something horribly mis-configured.

Offline

#2 2013-01-23 21:56:12

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 4,783

Re: Amarok dependancy should be changed from liblastfm0 to liblastfm1

It shouldn't have been reported as a bug. The Amarok package depends on liblastfm without a specified version; the problem is that liblastfm is out of date. You do NOT report bugs for out of date packages. liblastfm was marked as out of date 4 days ago, you just have to wait for the maintainer to update it.

Last edited by Scimmia (2013-01-23 21:56:46)

Offline

Board footer

Powered by FluxBB