You are not logged in.

#1 2013-01-26 23:26:55

AlecB
Member
Registered: 2013-01-26
Posts: 114

Pacstrap gives "Connection Timeout " error message.

Hello everyone,
   
I am installing Arch for the first time, and am attempting to install the "base" and "base-devel" package using pacstrap. When I run

pacstrap /mnt base base-devel

  as per the Beginners' Guide,I get a Connection Timeout error after each mirror. I can't ping my mirrors, but I can ping google. All help is appreciated.

Thanks

Last edited by AlecB (2013-01-30 03:44:21)


I believe in Christianity as I believe that the sun has risen: not only because I see it, but because by it I see everything else.
C. S. Lewis

Offline

#2 2013-01-27 14:51:55

TheRatze94
Member
Registered: 2012-07-01
Posts: 33

Re: Pacstrap gives "Connection Timeout " error message.

I had the same problem. Either your network card or your router doesn't support ipv6.

You have to reboot the system and add 'ipv6.disable=1' to your kernel line. (Edit the line using Tab).
You have to edit your grub.cfg after the installation too.

Offline

#3 2013-01-27 16:03:47

AlecB
Member
Registered: 2013-01-26
Posts: 114

Re: Pacstrap gives "Connection Timeout " error message.

How should I edit grub.cfg? I already disabled ipv6.


I believe in Christianity as I believe that the sun has risen: not only because I see it, but because by it I see everything else.
C. S. Lewis

Offline

#4 2013-01-27 18:50:44

TheRatze94
Member
Registered: 2012-07-01
Posts: 33

Re: Pacstrap gives "Connection Timeout " error message.

Open /boot/grub/grub.cfg in your installed system with root privileges and search the section for your Arch system.
It should be after:
### BEGIN /etc/grub.d/10_linux ###

There you search the 'linux' line and put 'ipv6.disable=1' at the end of it.

Hopefully I could help you smile

Offline

#5 2013-01-28 01:46:52

AlecB
Member
Registered: 2013-01-26
Posts: 114

Re: Pacstrap gives "Connection Timeout " error message.

Thanks! Sorry, I'm new to Linux: What command do i use to open the file?:)

Last edited by AlecB (2013-01-28 01:51:05)


I believe in Christianity as I believe that the sun has risen: not only because I see it, but because by it I see everything else.
C. S. Lewis

Offline

#6 2013-01-28 02:25:04

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Pacstrap gives "Connection Timeout " error message.

AlecB, these are things that you can easily use the google for.  This is not a hand holding distro or forum and that may be one of the worst hand holding requests I have ever seen.

Offline

#7 2013-01-28 03:53:21

AlecB
Member
Registered: 2013-01-26
Posts: 114

Re: Pacstrap gives "Connection Timeout " error message.

Ok, thanks for the criticism.


I believe in Christianity as I believe that the sun has risen: not only because I see it, but because by it I see everything else.
C. S. Lewis

Offline

#8 2013-01-28 05:05:54

AlecB
Member
Registered: 2013-01-26
Posts: 114

Re: Pacstrap gives "Connection Timeout " error message.

OK, the linux line currently reads

 linux   /boot/vmlinuz-linux root=UUID=ad4103fa-d940-47ca-8506-301d8071d467 ro quiet 

Should I insert ipv6.disable=1 after quiet?


I believe in Christianity as I believe that the sun has risen: not only because I see it, but because by it I see everything else.
C. S. Lewis

Offline

#9 2013-01-28 05:18:45

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Pacstrap gives "Connection Timeout " error message.

Yes that would work.  You should use the wiki, there is a page specifically for disabling ipv6.

Not trying to make you feel bad, but using Arch Linux basically means that you are willing to not only learn, but also put the work in to find information.  As advertised, Arch Linux is for intermediate to advanced Linux users.  This doesn't preclude beginners from using it, it just means that you are going to have to put in work (lots of reading).  This is why we have our amazing wiki in place.  Honestly, I think it is probably one of the best Linux resources available, and is entirely community driven (like the ditsribution itself).  So your question of how to open a config file may just seem a bit lazy.  It also makes me suspicious as to whether you are using pure Arch Linux and if so, how in the world did you manage to install it without opening a configuration file?

Offline

#10 2013-01-28 07:08:17

hunterthomson
Member
Registered: 2008-06-22
Posts: 794
Website

Re: Pacstrap gives "Connection Timeout " error message.

WonderWoofy wrote:

Yes that would work.  You should use the wiki, there is a page specifically for disabling ipv6.

Not trying to make you feel bad, but using Arch Linux basically means that you are willing to not only learn, but also put the work in to find information.  As advertised, Arch Linux is for intermediate to advanced Linux users.  This doesn't preclude beginners from using it, it just means that you are going to have to put in work (lots of reading).  This is why we have our amazing wiki in place.  Honestly, I think it is probably one of the best Linux resources available, and is entirely community driven (like the ditsribution itself).  So your question of how to open a config file may just seem a bit lazy.  It also makes me suspicious as to whether you are using pure Arch Linux and if so, how in the world did you manage to install it without opening a configuration file?

I agree, but your posts do come off a little harsher then I am sure you intend. Personally, I suggest that new Linux users use Arch Linux, because it is really the best way to learn how Linux works. However, like I said I agree with you. My suggestion comes with the expectation that the new Linux user will learn how to search Wiki's and forms for instruction.

Anyway, it dose not sound like the OP has gotten Arch Linux installed yet. He is not able to run `pacstrap /mnt base base-devel`

AlecB, can you ping google.com like the domain name and not just an IP address?
If not you also need to make sure you have a nameserver configured in /etc/resolv.conf Like `echo 'nameserver 8.8.8.8' > /etc/resolv.conf`

Last edited by hunterthomson (2013-01-28 07:11:38)


OpenBSD-current Thinkpad X230, i7-3520M, 16GB CL9 Kingston, Samsung 830 256GB
Contributor: linux-grsec

Offline

#11 2013-01-28 17:00:55

AlecB
Member
Registered: 2013-01-26
Posts: 114

Re: Pacstrap gives "Connection Timeout " error message.

Yes, I can ping Google, and I have two namserver lines in /etc/resolv.conf. Am I supposed to have just one? By the way, I already disabled ipv6 in the kernel line, as per the wiki.

Last edited by AlecB (2013-01-28 17:03:08)


I believe in Christianity as I believe that the sun has risen: not only because I see it, but because by it I see everything else.
C. S. Lewis

Offline

#12 2013-01-28 22:49:10

hunterthomson
Member
Registered: 2008-06-22
Posts: 794
Website

Re: Pacstrap gives "Connection Timeout " error message.

Try changing the mirrors your using.

Then, try installing the text based web browser elinks in the Arch Live environment itself. Then go to google.com with that like...

pacman -S elinks

elinks google.com

OpenBSD-current Thinkpad X230, i7-3520M, 16GB CL9 Kingston, Samsung 830 256GB
Contributor: linux-grsec

Offline

#13 2013-01-28 23:09:42

AlecB
Member
Registered: 2013-01-26
Posts: 114

Re: Pacstrap gives "Connection Timeout " error message.

Elinks works. I still need that base package though.


I believe in Christianity as I believe that the sun has risen: not only because I see it, but because by it I see everything else.
C. S. Lewis

Offline

#14 2013-01-29 06:18:23

hunterthomson
Member
Registered: 2008-06-22
Posts: 794
Website

Re: Pacstrap gives "Connection Timeout " error message.

Okay, so you have full Internet access then AND you can connect to the mirrors you have configured.

You must be skipping a step in the instructions.
Start over and read the Wiki instructions carefully.
You can also read Wiki pages specific to each command and process if you need more info.

https://wiki.archlinux.org/index.php/Beginners%27_Guide


OpenBSD-current Thinkpad X230, i7-3520M, 16GB CL9 Kingston, Samsung 830 256GB
Contributor: linux-grsec

Offline

#15 2013-01-29 17:16:46

AlecB
Member
Registered: 2013-01-26
Posts: 114

Re: Pacstrap gives "Connection Timeout " error message.

Hmm, now when I attempt to ping my mirrors, I get an unknown host error. I can still ping google.


I believe in Christianity as I believe that the sun has risen: not only because I see it, but because by it I see everything else.
C. S. Lewis

Offline

#16 2013-01-30 05:00:03

hunterthomson
Member
Registered: 2008-06-22
Posts: 794
Website

Re: Pacstrap gives "Connection Timeout " error message.

AlecB wrote:

Hmm, now when I attempt to ping my mirrors, I get an unknown host error. I can still ping google.

echo 'nameserver 8.8.8.8' > /etc/resolv.conf


OpenBSD-current Thinkpad X230, i7-3520M, 16GB CL9 Kingston, Samsung 830 256GB
Contributor: linux-grsec

Offline

#17 2013-01-30 16:57:54

AlecB
Member
Registered: 2013-01-26
Posts: 114

Re: Pacstrap gives "Connection Timeout " error message.

I ran that, and I still get an unknown host error when I attempt to ping my mirrors.


I believe in Christianity as I believe that the sun has risen: not only because I see it, but because by it I see everything else.
C. S. Lewis

Offline

#18 2013-01-31 01:47:56

hunterthomson
Member
Registered: 2008-06-22
Posts: 794
Website

Re: Pacstrap gives "Connection Timeout " error message.

This error...

[user@localhost:~]% ping google.com
ping: unknown host google.com

Means that you can not resolve the DNS name.

https://wiki.archlinux.org/index.php/Network

Last edited by hunterthomson (2013-01-31 01:50:18)


OpenBSD-current Thinkpad X230, i7-3520M, 16GB CL9 Kingston, Samsung 830 256GB
Contributor: linux-grsec

Offline

#19 2013-01-31 02:01:57

AlecB
Member
Registered: 2013-01-26
Posts: 114

Re: Pacstrap gives "Connection Timeout " error message.

Well, I tried again and it worked. All packages downloaded. I still don't know what the problem was, but at least it's working.


I believe in Christianity as I believe that the sun has risen: not only because I see it, but because by it I see everything else.
C. S. Lewis

Offline

Board footer

Powered by FluxBB