You are not logged in.

#1 2013-01-26 13:33:15

bmanuel
Member
Registered: 2011-10-06
Posts: 103

[SOLVED BY DOWNGRADING] Mouse input jump and lag after update

After updating to linux-3.7.4-1, xorg-server-1.13.2-1, xorg-server-common-1.13.2-1 and nvidia-313.18-1 i've noticeable lag whenever i hover the mouse cursor on something that changes the cursor shape and it's 100% reproducible: load a web page with lot of links (such as this subreddit and move the cursor vertically across the links, the mouse will start moving skipping lot of pixels instead of smooth movement, CPU usage also increase. No matter what browser you use, even Firefox will make this happen. Anyone experiencing the same?
Also, move across window borders to reproduce it, but it will be less noticeable since the mouse cursor will not change as much faster, or move it on a block of text to make it change and you'll notice the behavior.

Name           : xorg-server
Version        : 1.13.2-1

Name           : xorg-server-common
Version        : 1.13.2-1

Name           : nvidia
Version        : 313.18-1

Name           : linux
Version        : 3.7.4-1

Last edited by bmanuel (2013-01-27 14:40:38)

Offline

#2 2013-01-26 15:32:32

bmanuel
Member
Registered: 2011-10-06
Posts: 103

Re: [SOLVED BY DOWNGRADING] Mouse input jump and lag after update

Noticed /usr/bin/Xorg spikes to 80%-100% when the mouse change cursor type

Offline

#3 2013-01-26 19:41:09

brebs
Member
Registered: 2007-04-03
Posts: 3,408

Re: [SOLVED BY DOWNGRADING] Mouse input jump and lag after update

I had a similar issue months ago, which I think was caused by the CONFIG_COMPACTION kernel option - try turning that off.

Offline

#4 2013-01-26 23:24:23

bmanuel
Member
Registered: 2011-10-06
Posts: 103

Re: [SOLVED BY DOWNGRADING] Mouse input jump and lag after update

brebs wrote:

I had a similar issue months ago, which I think was caused by the CONFIG_COMPACTION kernel option - try turning that off.

Thank you for the tip, however i cannot find much information about this flag: does this imply to recompile the kernel (and maintain it updated with new releases)?

Offline

#5 2013-01-26 23:53:17

brebs
Member
Registered: 2007-04-03
Posts: 3,408

Re: [SOLVED BY DOWNGRADING] Mouse input jump and lag after update

Yes, you would need to recompile the kernel, there is no boot parameter to disable compaction, sadly.

Another related thing that's easy to try now:

echo 0 > /sys/kernel/mm/ksm/run

Offline

#6 2013-01-27 00:00:29

bmanuel
Member
Registered: 2011-10-06
Posts: 103

Re: [SOLVED BY DOWNGRADING] Mouse input jump and lag after update

$ cat /sys/kernel/mm/ksm/run 
0

It looks like KSM is already disabled on my system, but how does this relate to Xorg cursor glyph switching? And how did you discover that in your case this specific option did make a difference? o_O

Offline

#7 2013-01-27 00:13:40

brebs
Member
Registered: 2007-04-03
Posts: 3,408

Re: [SOLVED BY DOWNGRADING] Mouse input jump and lag after update

I discovered by trial-and-error, and lots of googling, and pondering the various ways that things can slow down either by design or by being buggy wink

If you're going to recompile the kernel, I would suggest trying 1000hz for a desktop instead of 300 also, but bear in mind that it may cause instability (I strongly suspect that 1000hz causes freezes on my laptop, but e.g. 432hz and 600hz are OK).

Offline

#8 2013-01-27 00:44:03

bmanuel
Member
Registered: 2011-10-06
Posts: 103

Re: [SOLVED BY DOWNGRADING] Mouse input jump and lag after update

I tried recompiling and using it but it looks like i also need to recompile every module and driver i'm using (nvidia/virtualbox/..), and that looks a bit of a daunting task to maintain to just solve this stupid problem ;-#
Anyway, i discovered that also *ANY* animated cursor will make the jump behave crazily, missing DPIs look like a mouse from the early 70.. or windows without ps2rate smile

Offline

#9 2013-01-27 04:41:36

yjcong
Member
Registered: 2009-07-06
Posts: 59

Re: [SOLVED BY DOWNGRADING] Mouse input jump and lag after update

hi,

I have the similar problem(laptop). The touchpad is unusable now, but a usb mouse is ok. I did google this, and found some solutions concerning   xorg.conf setting. but that does not work for me.

Offline

#10 2013-01-27 13:57:37

bmanuel
Member
Registered: 2011-10-06
Posts: 103

Re: [SOLVED BY DOWNGRADING] Mouse input jump and lag after update

Ok, so, putting this:

Option    "HWCursor"    "false"

make it so the jumping cursor problem goes away, but there is a new one: the cursor in always invisible when not moving.. smile

Offline

#11 2013-01-27 14:18:13

bmanuel
Member
Registered: 2011-10-06
Posts: 103

Re: [SOLVED BY DOWNGRADING] Mouse input jump and lag after update

Oh well, completely solved by installing latest stable nvidia driver (11/december/2012).

Offline

#12 2013-01-27 14:30:12

brebs
Member
Registered: 2007-04-03
Posts: 3,408

Re: [SOLVED BY DOWNGRADING] Mouse input jump and lag after update

Don't turn it into a crossword puzzle, simply state the version number. You mean downgrading from 313.18 to 304.64, or 310.32, or what?

Offline

#13 2013-01-27 14:40:12

yjcong
Member
Registered: 2009-07-06
Posts: 59

Re: [SOLVED BY DOWNGRADING] Mouse input jump and lag after update

bmanuel wrote:

Oh well, completely solved by installing latest stable nvidia driver (11/december/2012).

I dont think this will work for me, because I only need intel-driver

Last edited by yjcong (2013-01-27 14:40:49)

Offline

#14 2013-01-27 14:40:16

bmanuel
Member
Registered: 2011-10-06
Posts: 103

Re: [SOLVED BY DOWNGRADING] Mouse input jump and lag after update

Downgraded to these;

Name           : nvidia
Version        : 310.19-3

Name           : nvidia-utils
Version        : 310.19-1

Didn't intend to make it difficult, but i had to search for these packages around the net by date since there are no old packages in the repos.

Offline

#15 2013-01-27 15:46:30

teekay
Member
Registered: 2011-10-26
Posts: 270

Re: [SOLVED BY DOWNGRADING] Mouse input jump and lag after update

I have similar laggy mouse issues with the 313.18 nvidia drivers. Disabling "Sync to VBlank" in nvidia-settings helped here.
Not sure why it matters, maybe because kwin runs with effects/composite enabled.

Offline

Board footer

Powered by FluxBB