You are not logged in.

#1 2013-01-26 20:34:07

fixles
Member
Registered: 2012-09-15
Posts: 101

Intel Mobile 945GSE graphics but kernel driver in use i915?

Hi,

Yesterday I installed arch on an old netbook with the intention of plugging it into my TV to watch youtube etc on. However youtube videos are really laggy when full screened. I though maybe I'd forgotten to install the intel drivers but:

[ ~]$ pacman -Qs intel
local/intel-dri 9.0.2-1
    Mesa DRI drivers for Intel
local/xf86-video-intel 2.20.19-1 (xorg-drivers xorg)
    X.org Intel i810/i830/i915/945G/G965+ video drivers

Looking at lspci -k the card is a "Intel Corporation Mobile 945GSE Express Integrated Graphics" but the driver in use is i915??? Is this the problem? How do I use the 945G drivers that come with xf86-video-intel?

Thanks.

[ ~]$ sudo lspci -k
00:00.0 Host bridge: Intel Corporation Mobile 945GSE Express Memory Controller Hub (rev 03)
	Subsystem: ASUSTeK Computer Inc. Device 8340
	Kernel driver in use: agpgart-intel
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GSE Express Integrated Graphics Controller (rev 03)
	Subsystem: ASUSTeK Computer Inc. Device 8340
	Kernel driver in use: i915
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
	Subsystem: ASUSTeK Computer Inc. Device 8340
00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 02)
	Subsystem: ASUSTeK Computer Inc. Device 83ce
	Kernel driver in use: snd_hda_intel
00:1c.0 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 1 (rev 02)
	Kernel driver in use: pcieport
00:1c.1 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 2 (rev 02)
	Kernel driver in use: pcieport
00:1c.3 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 4 (rev 02)
	Kernel driver in use: pcieport
00:1d.0 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #1 (rev 02)
	Subsystem: ASUSTeK Computer Inc. Device 830f
	Kernel driver in use: uhci_hcd
00:1d.1 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #2 (rev 02)
	Subsystem: ASUSTeK Computer Inc. Device 830f
	Kernel driver in use: uhci_hcd
00:1d.2 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #3 (rev 02)
	Subsystem: ASUSTeK Computer Inc. Device 830f
	Kernel driver in use: uhci_hcd
00:1d.3 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #4 (rev 02)
	Subsystem: ASUSTeK Computer Inc. Device 830f
	Kernel driver in use: uhci_hcd
00:1d.7 USB controller: Intel Corporation NM10/ICH7 Family USB2 EHCI Controller (rev 02)
	Subsystem: ASUSTeK Computer Inc. Device 830f
	Kernel driver in use: ehci_hcd
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
	Subsystem: ASUSTeK Computer Inc. Device 830f
	Kernel driver in use: lpc_ich
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 02)
	Subsystem: ASUSTeK Computer Inc. Device 830f
	Kernel driver in use: ata_piix
00:1f.2 SATA controller: Intel Corporation 82801GBM/GHM (ICH7-M Family) SATA Controller [AHCI mode] (rev 02)
	Subsystem: ASUSTeK Computer Inc. Device 830f
	Kernel driver in use: ahci
01:00.0 Ethernet controller: Atheros Communications Inc. AR8132 Fast Ethernet (rev c0)
	Subsystem: ASUSTeK Computer Inc. Device 838a
	Kernel driver in use: atl1c
02:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
	Subsystem: AzureWave AW-NE785 / AW-NE785H 802.11bgn Wireless Full or Half-size Mini PCIe Card
	Kernel driver in use: ath9k

Moderator: Please use [ code ] tags around such listings. I put some in for you to keep the mess readable. - bernarcher

Last edited by bernarcher (2013-01-26 20:40:40)

Offline

#2 2013-01-26 21:00:49

Gusar
Member
Registered: 2009-08-25
Posts: 3,472

Re: Intel Mobile 945GSE graphics but kernel driver in use i915?

You're mixing up a lot of stuff here. A graphics driver has three parts: kernel module, 2d userspace component, 3d userspace component.

When it comes to Intel: The kernel module is always i915. The 2d component is always intel_drv, it's in the xf86-video-intel package. The 3d component is either i915_dri (for i8xx, i915 and i945 graphics) or i965_dri (for everything newer than i945), they're both in the intel-dri package.

What's your display setup - clone or extended desktop? And if extended desktop, what's the combined resolution of both displays? i945 graphics has a maximum texture size of 2048x2048, if your combined resolution is larger than that, 3d acceleration won't work, so having laggy flash is expected.

Offline

#3 2013-01-26 22:38:14

fixles
Member
Registered: 2012-09-15
Posts: 101

Re: Intel Mobile 945GSE graphics but kernel driver in use i915?

Gusar wrote:

You're mixing up a lot of stuff here. A graphics driver has three parts: kernel module, 2d userspace component, 3d userspace component.

When it comes to Intel: The kernel module is always i915. The 2d component is always intel_drv, it's in the xf86-video-intel package. The 3d component is either i915_dri (for i8xx, i915 and i945 graphics) or i965_dri (for everything newer than i945), they're both in the intel-dri package.

What's your display setup - clone or extended desktop? And if extended desktop, what's the combined resolution of both displays? i945 graphics has a maximum texture size of 2048x2048, if your combined resolution is larger than that, 3d acceleration won't work, so having laggy flash is expected.


Ahh ok that makes sense, thanks. I'm plugging the netbook into my TV by VGA which is 1360x768 resolution and just outputing to the TV only and not the netbook screen. I'm running XFCE and have turned the compositing effects off. Nothing else is running in the background and the CPU is idle and only couple hundred MB of ram in use before starting firefox or chromium. The netbook has 1GB of ram and a Atom N270 1.6ghz dual core. I'm only trying to run youtube videos at 480p. They play fine in the window but when I full screen them they lag horribly,

I installed the mesa package I think. Should I uninstall that?

Last edited by fixles (2013-01-26 22:38:48)

Offline

#4 2013-01-26 22:54:54

Gusar
Member
Registered: 2009-08-25
Posts: 3,472

Re: Intel Mobile 945GSE graphics but kernel driver in use i915?

The mesa package is irrelevant in your particular situation, it makes no difference if it's there or not.

Do you have OverrideGPUValidation=true in /etc/adobe/mms.conf? Also, try flashplugin-10 from AUR.

Offline

#5 2013-01-27 00:44:18

fixles
Member
Registered: 2012-09-15
Posts: 101

Re: Intel Mobile 945GSE graphics but kernel driver in use i915?

Gusar wrote:

The mesa package is irrelevant in your particular situation, it makes no difference if it's there or not.

Do you have OverrideGPUValidation=true in /etc/adobe/mms.conf? Also, try flashplugin-10 from AUR.

Downgrading to flashplayer 10 and adding that line to the config file appears to have solved it. Many thanks!

Offline

Board footer

Powered by FluxBB