You are not logged in.

#1 2013-01-27 05:02:44

yjcong
Member
Registered: 2009-07-06
Posts: 59

[solved]some of Keyboard input are out of order:::27, Jan

Hi,

After the daily upgrade, this morning I found I counld not use some of the keyboard. Such as, there is no response from Super, Arrows, HOME/END,  Delete, right_Alt becomes the second Enter, page_down opening a "menu"...........

The new packages are
sudo-1.8.6.p5-1-i686.pkg.tar.xz
xorg-server-1.13.2-1-i686.pkg.tar.xz
xorg-server-common-1.13.2-1-i686.pkg.tar.xz
colord-0.1.28-1-i686.pkg.tar.xz
cpupower-3.7-5-i686.pkg.tar.xz
qtwebkit-2.3.beta1-1.1-i686.pkg.tar.xz

so, I thinks xorg-server and xorg-server-common could be the source of the problem.

Last edited by yjcong (2013-01-27 09:29:13)

Offline

#2 2013-01-27 05:32:46

yjcong
Member
Registered: 2009-07-06
Posts: 59

Re: [solved]some of Keyboard input are out of order:::27, Jan

just downgraded xorg-server-1.13.2-1 to xorg-server-1.13.1-1 and xorg-server-common-1.13.1-1, problems are still there.

Offline

#3 2013-01-27 06:07:40

the sad clown
Member
From: 192.168.0.X
Registered: 2011-03-20
Posts: 833

Re: [solved]some of Keyboard input are out of order:::27, Jan

What is the output from:

setxkbmap -print -verbose 10

Perhaps one of your config files was overwritten?

Check here for possibilities: https://wiki.archlinux.org/index.php/Xo … d_settings

Last edited by the sad clown (2013-01-27 06:11:14)


I laugh, yet the joke is on me

Offline

#4 2013-01-27 06:19:05

yjcong
Member
Registered: 2009-07-06
Posts: 59

Re: [solved]some of Keyboard input are out of order:::27, Jan

the sad clown wrote:

What is the output from:

setxkbmap -print -verbose 10

Perhaps one of your config files was overwritten?

Check here for possibilities: https://wiki.archlinux.org/index.php/Xo … d_settings

Thanks.

I use german keyboard. but keys such as üäß could be used.

The output is

Setting verbose level to 10
locale is C
Trying to load rules file ./rules/evdev...
Trying to load rules file /usr/share/X11/xkb/rules/evdev...
Success.
Applied rules from evdev:
rules:      evdev
model:      evdev
layout:     de
Trying to build keymap using the following components:
keycodes:   evdev+aliases(qwertz)
types:      complete
compat:     complete
symbols:    pc+de+inet(evdev)
geometry:   pc(pc104)
xkb_keymap {
    xkb_keycodes  { include "evdev+aliases(qwertz)"    };
    xkb_types     { include "complete"    };
    xkb_compat    { include "complete"    };
    xkb_symbols   { include "pc+de+inet(evdev)"    };
    xkb_geometry  { include "pc(pc104)"    };
};

Offline

#5 2013-01-27 07:15:09

yjcong
Member
Registered: 2009-07-06
Posts: 59

Re: [solved]some of Keyboard input are out of order:::27, Jan

Because I use de keyboard, I put "setxkbmap -layout de" in ".xinitrc"file. This had  worked fine for years.

Right now, even there is  "setxkbmap -layout de" command in the file, I need to run it once more in the terminal after startx in order to get back all keyboard functions.

Offline

#6 2013-01-27 07:22:41

the sad clown
Member
From: 192.168.0.X
Registered: 2011-03-20
Posts: 833

Re: [solved]some of Keyboard input are out of order:::27, Jan

Not sure what is going wrong with that.  Obviously your .xinitrc file isn't being read correctly if you have to pass the argument again.  You said that it has been working fine until now?  Could you post your .xinitrc?

Why not try a different method for permanently setting your keyboard layout: https://wiki.archlinux.org/index.php/Xo … t-plugging

That might work better than trying to do it though your .xinitrc

Last edited by the sad clown (2013-01-27 07:28:05)


I laugh, yet the joke is on me

Offline

#7 2013-01-27 09:18:18

yjcong
Member
Registered: 2009-07-06
Posts: 59

Re: [solved]some of Keyboard input are out of order:::27, Jan

the sad clown wrote:

Not sure what is going wrong with that.  Obviously your .xinitrc file isn't being read correctly if you have to pass the argument again.  You said that it has been working fine until now?  Could you post your .xinitrc?

Why not try a different method for permanently setting your keyboard layout: https://wiki.archlinux.org/index.php/Xo … t-plugging

That might work better than trying to do it though your .xinitrc

thanks for your help.

Now I have figured out that the problem is caused by fcitx(Flexible Context-aware Input Tool with eXtension).

After downgrading fcitx-4.2.7-1 to fcitx-4.2.6.1-5, everything works fine, except the touchpad/cursor.

Last edited by yjcong (2013-01-28 07:02:28)

Offline

Board footer

Powered by FluxBB