You are not logged in.

#1 2013-01-27 12:18:18

cyph3r
Member
Registered: 2012-01-13
Posts: 11

Update filesystem-2013.01-1 and glibc-2.17-2 together problem

Hello,

I didn't check the news today (mistake #1) and I updated Arch. And I had configured pacman to first update glibc and then everything else (mistake #2).
So I got the following:

:: The following packages should be upgraded first :
    glibc
:: Do you want to cancel the current operation
:: and upgrade these packages now? [Y/n] 

resolving dependencies...
looking for inter-conflicts...

Targets (1): glibc-2.17-2

Total Download Size:    7.75 MiB
Total Installed Size:   37.92 MiB
Net Upgrade Size:       0.00 MiB

Proceed with installation? [Y/n] 
:: Retrieving packages from core...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 7932k  100 7932k    0     0   578k      0  0:00:13  0:00:13 --:--:--  442k
(1/1) checking package integrity                      [----------------------------] 100%
(1/1) loading package files                           [----------------------------] 100%
(1/1) checking for file conflicts                     [----------------------------] 100%
(1/1) checking available disk space                   [----------------------------] 100%
(1/1) upgrading glibc                                 [----------------------------] 100%
call to execv failed (No such file or directory)
error: command failed to execute correctly
:: Synchronizing aur database...
/usr/bin/packer: line 514: /usr/bin/pacman: No such file or directory
/usr/bin/packer: line 518: /usr/bin/grep: No such file or directory

:: Starting full aur upgrade...
 local database is up to date

And now for every command I type in my terminal I get something like "No such file or directory"

Is there a solution because I'm sure that if I reboot I won't be able to boot again.

Offline

#2 2013-01-27 12:52:34

masteryod
Member
Registered: 2010-05-19
Posts: 433

Re: Update filesystem-2013.01-1 and glibc-2.17-2 together problem

Boot Arch live-cd and chroot then try to reinstal glibc and filesystem. Remember to boot same architecture live-cd as your main OS (i686 or x86_64).

Last edited by masteryod (2013-01-27 12:52:48)

Offline

#3 2013-01-27 13:02:02

bootleg
Member
Registered: 2010-12-08
Posts: 38

Re: Update filesystem-2013.01-1 and glibc-2.17-2 together problem

Hello, same here.

I boot from a live-cd and I had to recreate the /lib symlinks in order to be able to chroot, otherwise /usr/bin/bash was not found. I reinstalled glibc, but even then filesystem fails to upgrade because of the symlinks. But without them all commands are 'no such file or directory'.

Offline

#4 2013-01-27 13:37:11

pright
Member
Registered: 2010-10-21
Posts: 2

Re: Update filesystem-2013.01-1 and glibc-2.17-2 together problem

I came across the problem like yours, though in a different situation. Somehow glibc updated to 2.17.2, but filesystem still remains 2012.12-1.
I tried downgrading glibc to 2.17.1, but still got "glibc: /lib exists in filesystem". So I did "pacman -Uf " to install gblic 2.17.1. and did "pacman -Syu" again. Everything seems fine for now.

Last edited by pright (2013-01-27 13:38:05)

Offline

#5 2013-01-27 13:45:01

loafer
Member
From: the pub
Registered: 2009-04-14
Posts: 1,707

Re: Update filesystem-2013.01-1 and glibc-2.17-2 together problem

pright wrote:

Somehow glibc updated to 2.17.2, but filesystem still remains 2012.12-1.

Post the relevant lines from your pacman.log please.  I though glibc 2.17-2 depends on filesystem>=2013.01?


All men have stood for freedom...
For freedom is the man that will turn the world upside down.
Gerrard Winstanley.

Offline

#6 2013-01-27 13:50:28

cyph3r
Member
Registered: 2012-01-13
Posts: 11

Re: Update filesystem-2013.01-1 and glibc-2.17-2 together problem

I booted from the arch linux live cd and mounted my / partition and did
pacman -Sy
and
pacman --root /path/to/mounted/root -S filesystem
and it got installed and everything is ok now smile
Thanks everyone!

Offline

#7 2013-01-27 13:54:33

Allan
Developer
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,416
Website

Re: Update filesystem-2013.01-1 and glibc-2.17-2 together problem

cyph3r wrote:
:: The following packages should be upgraded first :
    glibc
:: Do you want to cancel the current operation
:: and upgrade these packages now? [Y/n] 

What config has glibc in SyncFirst?   Is that a packer thing?

Offline

#8 2013-01-27 13:55:19

cyph3r
Member
Registered: 2012-01-13
Posts: 11

Re: Update filesystem-2013.01-1 and glibc-2.17-2 together problem

Yeah i had it in SyncFirst in pacman.conf. I removed it now.

Offline

#9 2013-01-27 14:09:00

pright
Member
Registered: 2010-10-21
Posts: 2

Re: Update filesystem-2013.01-1 and glibc-2.17-2 together problem

loafer wrote:
pright wrote:

Somehow glibc updated to 2.17.2, but filesystem still remains 2012.12-1.

Post the relevant lines from your pacman.log please.  I though glibc 2.17-2 depends on filesystem>=2013.01?

Yes, you're right. I checked my pacman.log, and realized that I did "pacman -S glibc filesystem" before because the page says "it is required to update glibc-2.12-2 and filesystem-2013.01-1 together". I didn't notice "partial updates are not supported ", my bad.

Offline

#10 2013-01-27 18:58:47

nouveau
Member
From: Germany
Registered: 2011-01-16
Posts: 12

Re: Update filesystem-2013.01-1 and glibc-2.17-2 together problem

loafer wrote:
pright wrote:

Somehow glibc updated to 2.17.2, but filesystem still remains 2012.12-1.

Post the relevant lines from your pacman.log please.  I though glibc 2.17-2 depends on filesystem>=2013.01?

It seems that it doesn't depend on filesystem>=2013.01. At least for me "pacman -Syu" only upgraded glibc and not filesystem which went me into some trouble (you can find it here).

Since you were intered in the pacman.log:

[2013-01-27 17:09] Running 'pacman -Syu'
[2013-01-27 17:09] synchronizing package lists
[2013-01-27 17:09] starting full system upgrade
[2013-01-27 17:12] upgraded acl (2.2.51-2 -> 2.2.51-3)
[2013-01-27 17:12] upgraded linux-api-headers (3.7.1-1 -> 3.7.4-1)
[2013-01-27 17:12] Konnte execv nicht aufrufen (Datei oder Verzeichnis nicht gefunden)
[2013-01-27 17:12] upgraded glibc (2.17-1 -> 2.17-2)
[2013-01-27 17:12] Konnte execv nicht aufrufen (Datei oder Verzeichnis nicht gefunden)
[2013-01-27 17:12] upgraded bash (4.2.042-1 -> 4.2.042-2)
[2013-01-27 17:12] Konnte execv nicht aufrufen (Datei oder Verzeichnis nicht gefunden)
[2013-01-27 17:12] upgraded calibre (0.9.15-2 -> 0.9.16-1)
[2013-01-27 17:12] Konnte execv nicht aufrufen (Datei oder Verzeichnis nicht gefunden)
[2013-01-27 17:12] upgraded cantarell-fonts (0.0.11-3 -> 0.0.12-1)
[2013-01-27 17:12] upgraded libwbclient (3.6.10-1 -> 3.6.11-2)
[2013-01-27 17:12] upgraded cifs-utils (5.8-1 -> 5.9-1)
[2013-01-27 17:12] upgraded liblastfm (0.3.3-3 -> 1.0.6-1)
[2013-01-27 17:12] Konnte execv nicht aufrufen (Datei oder Verzeichnis nicht gefunden)
[2013-01-27 17:12] upgraded clementine (1.1.1-3 -> 1.1.1-4)
[2013-01-27 17:12] upgraded clutter-gst (1.9.92-1 -> 2.0.0-1)
[2013-01-27 17:12] upgraded clutter-gtk (1.4.0-1 -> 1.4.2-1)
[2013-01-27 17:12] Konnte execv nicht aufrufen (Datei oder Verzeichnis nicht gefunden)
[2013-01-27 17:12] upgraded colord (0.1.24-3 -> 0.1.28-1)
[2013-01-27 17:12] Konnte execv nicht aufrufen (Datei oder Verzeichnis nicht gefunden)
[2013-01-27 17:12] upgraded evolution-data-server (3.6.2-1 -> 3.6.3-1)
[2013-01-27 17:12] Konnte execv nicht aufrufen (Datei oder Verzeichnis nicht gefunden)
[2013-01-27 17:12] upgraded gcc-libs (4.7.2-3 -> 4.7.2-4)
[2013-01-27 17:12] Konnte execv nicht aufrufen (Datei oder Verzeichnis nicht gefunden)
[2013-01-27 17:12] upgraded gcc (4.7.2-3 -> 4.7.2-4)
[2013-01-27 17:12] upgraded json-c (0.9-1 -> 0.10-1)
[2013-01-27 17:12] upgraded lib32-glibc (2.17-1 -> 2.17-2)
[2013-01-27 17:12] upgraded lib32-gcc-libs (4.7.2-3 -> 4.7.2-4)
[2013-01-27 17:12] upgraded libgee (0.6.6.1-1 -> 0.6.7-1)
[2013-01-27 17:12] Konnte execv nicht aufrufen (Datei oder Verzeichnis nicht gefunden)
[2013-01-27 17:12] upgraded mkinitcpio (0.12.0-2 -> 0.12.0-3)
[2013-01-27 17:12] Konnte execv nicht aufrufen (Datei oder Verzeichnis nicht gefunden)
[2013-01-27 17:12] upgraded mtools (4.0.17-2 -> 4.0.18-1)
[2013-01-27 17:12] upgraded ruby-glib2 (1.1.9-1 -> 1.2.0-1)
[2013-01-27 17:12] upgraded ruby-atk (1.1.9-1 -> 1.2.0-1)
[2013-01-27 17:12] upgraded ruby-gdkpixbuf2 (1.1.9-1 -> 1.2.0-1)
[2013-01-27 17:12] upgraded ruby-pango (1.1.9-1 -> 1.2.0-1)
[2013-01-27 17:12] upgraded ruby-gtk2 (1.1.9-1 -> 1.2.0-1)
[2013-01-27 17:12] upgraded smbclient (3.6.10-1 -> 3.6.11-2)
[2013-01-27 17:12] upgraded sudo (1.8.6.p4-1 -> 1.8.6.p5-1)
[2013-01-27 17:12] Konnte execv nicht aufrufen (Datei oder Verzeichnis nicht gefunden)
[2013-01-27 17:12] upgraded transmission-cli (2.75-1 -> 2.76-2)
[2013-01-27 17:12] Konnte execv nicht aufrufen (Datei oder Verzeichnis nicht gefunden)
[2013-01-27 17:12] upgraded transmission-gtk (2.75-1 -> 2.76-2)

filesystem didn't got upgraded and remains at version 2012.12-x.

Offline

#11 2013-01-28 07:38:26

loafer
Member
From: the pub
Registered: 2009-04-14
Posts: 1,707

Re: Update filesystem-2013.01-1 and glibc-2.17-2 together problem

nouveau wrote:

It seems that it doesn't depend on filesystem>=2013.01. At least for me "pacman -Syu" only upgraded glibc and not filesystem which went me into some trouble (you can find it here).

According to the thread in the URL you have quoted the problem is that you are using cinnarch and not Arch.


All men have stood for freedom...
For freedom is the man that will turn the world upside down.
Gerrard Winstanley.

Offline

Board footer

Powered by FluxBB