You are not logged in.

#1 2013-01-26 12:38:47

ijiboom
Member
Registered: 2012-05-19
Posts: 21

[SOLVED] Arch lags for 10 minutes after booting

I recently decided to delete my Windows partition and did so from the Arch LiveCD. While doing that, I also expanded the arch partition to fit my entire hard disk. I have only one partition, which is /dev/sda1. This partition is bootable and has GRUb correctly configured on it. But ever since I went 100% Arch, the startup process lags for about 10' after showing the typical /dev/sda1 clean: ...

After the 10', arch loads as usual and everything works fine. The lag is a big pain in the neck though... I've tried reinstalling GRUB, deactivating some useless modules I had, I'm kind of lost here.
Any help would be appreciated.

Last edited by ijiboom (2013-01-27 14:01:25)


"Flying is learning how to throw yourself at the ground and miss." Douglas Adams, Life, the universe and everything

Offline

#2 2013-01-26 13:04:51

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,510
Website

Re: [SOLVED] Arch lags for 10 minutes after booting

Do you use uuid's in your grub config?  If you do - the uuid of your root partition changed when you resized it.


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#3 2013-01-26 13:19:08

DSpider
Member
From: Romania
Registered: 2009-08-23
Posts: 2,273

Re: [SOLVED] Arch lags for 10 minutes after booting

This is what happens when you have a large root partition. The HDD read head needs to travel too much (especially over time, with updates and such) to get to the files. They're spread across the entire drive. Your root partition should not be bigger than 10-15 GB.

Edit: Wrong tile. "Stuck" is not the same as "lags for 10 seconds". "Stuck" implies that it's no longer working, that it's stuck.

Last edited by DSpider (2013-01-26 13:21:07)


"How to Succeed with Linux"

I have made a personal commitment not to reply in topics that start with a lowercase letter. Proper grammar and punctuation is a sign of respect, and if you do not show any, you will NOT receive any help (at least not from me).

Offline

#4 2013-01-26 17:42:59

ijiboom
Member
Registered: 2012-05-19
Posts: 21

Re: [SOLVED] Arch lags for 10 minutes after booting

DSpider: Well, first of all, 10' stands for 10 "minutes", not seconds. Second, I used to have Arch cover my entire hard disk, and I'm pretty sure it did not lag like this.

Last edited by ijiboom (2013-01-26 17:43:22)


"Flying is learning how to throw yourself at the ground and miss." Douglas Adams, Life, the universe and everything

Offline

#5 2013-01-26 21:58:46

Stebalien
Member
Registered: 2010-04-27
Posts: 1,218
Website

Re: [SOLVED] Arch lags for 10 minutes after booting

Reboot and then post the output of 'journalctl -b'.


Steven [ web : git ]
GPG:  327B 20CE 21EA 68CF A7748675 7C92 3221 5899 410C
Do not email: honeypot@stebalien.com

Offline

#6 2013-01-26 23:07:25

ijiboom
Member
Registered: 2012-05-19
Posts: 21

Re: [SOLVED] Arch lags for 10 minutes after booting

here is the output of "sudo journalctl -b"

Jan 26 23:54:57 ***** systemd-journal[161]: Allowing runtime journal files to grow to 396.8M.
Jan 26 23:54:57 ***** kernel: Initializing cgroup subsys cpuset
Jan 26 23:54:57 ***** kernel: Initializing cgroup subsys cpu
Jan 26 23:54:57 ***** kernel: Linux version 3.7.4-1-ARCH (tobias@T-POWA-LX) (gcc version 4.7.2 (GCC) ) #1 SMP PREEMPT Mon Jan 21 23:05:29 CET 2013
Jan 26 23:54:57 ***** kernel: Command line: BOOT_IMAGE=/boot/vmlinuz-linux root=UUID=1dcca66f-4fbc-4bcc-a915-ab4e47e9006c ro quiet
Jan 26 23:54:57 ***** kernel: e820: BIOS-provided physical RAM map:
Jan 26 23:54:57 ***** kernel: BIOS-e820: [mem 0x0000000000000000-0x000000000009d7ff] usable
Jan 26 23:54:57 ***** kernel: BIOS-e820: [mem 0x000000000009d800-0x000000000009ffff] reserved
Jan 26 23:54:57 ***** kernel: BIOS-e820: [mem 0x00000000000e0000-0x00000000000fffff] reserved
Jan 26 23:54:57 ***** kernel: BIOS-e820: [mem 0x0000000000100000-0x000000009ce3efff] usable
Jan 26 23:54:57 ***** kernel: BIOS-e820: [mem 0x000000009ce3f000-0x000000009cebefff] reserved
Jan 26 23:54:57 ***** kernel: BIOS-e820: [mem 0x000000009cebf000-0x000000009cfbefff] ACPI NVS
Jan 26 23:54:57 ***** kernel: BIOS-e820: [mem 0x000000009cfbf000-0x000000009cffefff] ACPI data
Jan 26 23:54:57 ***** kernel: BIOS-e820: [mem 0x000000009cfff000-0x000000009cffffff] usable
Jan 26 23:54:57 ***** kernel: BIOS-e820: [mem 0x000000009d000000-0x000000009f9fffff] reserved
Jan 26 23:54:57 ***** kernel: BIOS-e820: [mem 0x00000000e0000000-0x00000000efffffff] reserved
Jan 26 23:54:57 ***** kernel: BIOS-e820: [mem 0x00000000feb00000-0x00000000feb03fff] reserved
Jan 26 23:54:57 ***** kernel: BIOS-e820: [mem 0x00000000fec00000-0x00000000fec00fff] reserved
Jan 26 23:54:57 ***** kernel: BIOS-e820: [mem 0x00000000fed10000-0x00000000fed19fff] reserved
Jan 26 23:54:57 ***** kernel: BIOS-e820: [mem 0x00000000fed1c000-0x00000000fed1ffff] reserved
Jan 26 23:54:57 ***** kernel: BIOS-e820: [mem 0x00000000fee00000-0x00000000fee00fff] reserved
Jan 26 23:54:57 ***** kernel: BIOS-e820: [mem 0x00000000ffd80000-0x00000000ffffffff] reserved
Jan 26 23:54:57 ***** kernel: BIOS-e820: [mem 0x0000000100000000-0x000000025fdfffff] usable
Jan 26 23:54:57 ***** kernel: NX (Execute Disable) protection: active
Jan 26 23:54:57 ***** kernel: DMI 2.7 present.
Jan 26 23:54:57 ***** kernel: DMI: Alienware M14xR1/M14xR1, BIOS A01 03/25/2011
Jan 26 23:54:57 ***** kernel: e820: update [mem 0x00000000-0x0000ffff] usable ==> reserved
Jan 26 23:54:57 ***** kernel: e820: remove [mem 0x000a0000-0x000fffff] usable
Jan 26 23:54:57 ***** kernel: No AGP bridge found
Jan 26 23:54:57 ***** kernel: e820: last_pfn = 0x25fe00 max_arch_pfn = 0x400000000
Jan 26 23:54:57 ***** kernel: MTRR default type: uncachable
Jan 26 23:54:57 ***** kernel: MTRR fixed ranges enabled:
Jan 26 23:54:57 ***** kernel:   00000-9FFFF write-back
Jan 26 23:54:57 ***** kernel:   A0000-BFFFF uncachable
Jan 26 23:54:57 ***** kernel:   C0000-EFFFF write-protect
Jan 26 23:54:57 ***** kernel:   F0000-FFFFF write-combining

and here is the output of "journalctl -b"

Jan 26 23:56:55 ***** gnome-session[598]: EggSMClient-WARNING: Invalid Version string '0.9.4' in /home/****/.config/autostart/window manager.desktop
Jan 26 23:56:56 ***** pulseaudio[652]: [pulseaudio] bluetooth-util.c: org.bluez.Manager.GetProperties() failed: org.freedesktop.systemd1.LoadFailed:
Jan 26 23:56:56 ***** pulseaudio[681]: [pulseaudio] pid.c: Daemon already running.
Jan 26 23:56:57 ***** gnome-session[598]: WARNING: Can't load fallback CSS resource: Failed to import: The resource at '/org/gnome/adwaita/gtk-fallb
Jan 26 23:57:01 ***** goa[749]: goa-daemon version 3.6.2 starting [main.c:112, main()]
Jan 26 23:57:01 ***** gnome-keyring-daemon[596]: keyring alias directory: /home/****/.local/share/keyrings

"Flying is learning how to throw yourself at the ground and miss." Douglas Adams, Life, the universe and everything

Offline

#7 2013-01-27 00:21:45

progandy
Member
Registered: 2012-05-17
Posts: 2,146

Re: [SOLVED] Arch lags for 10 minutes after booting

You modified your partition scheme, you should verify the entries in your /etc/fstab.
I also suggest to create at least two partitions a smaller root (max 30GB for linux, packages, package cache and logs) and the rest for /home.

Last edited by progandy (2013-01-27 00:24:09)

Offline

#8 2013-01-27 14:01:07

ijiboom
Member
Registered: 2012-05-19
Posts: 21

Re: [SOLVED] Arch lags for 10 minutes after booting

propagandy: Thanks, that fixed it! I took away the line in /etc/fstab referring to my previous /dev/sda5 partition (now non-existent). Arch boots up like a charm now. dev/sda1 's UUID had not changed though, so I left it as-is.


"Flying is learning how to throw yourself at the ground and miss." Douglas Adams, Life, the universe and everything

Offline

Board footer

Powered by FluxBB