You are not logged in.

#1 2013-01-27 13:57:09

maggie
Member
Registered: 2011-02-12
Posts: 248

System update borked due to Lzma library error/need advice [FIXED]

It seems that my glibc update was bad and now my system is throwing error I can't fix.  I do not know how to recover from this.

$ sudo pacman -Syu
:: Synchronizing package databases...
 core                                               105.1 KiB   408K/s 00:00 [############################################] 100%
 extra                                             1438.6 KiB  1671K/s 00:01 [############################################] 100%
 community                                         1888.9 KiB  2006K/s 00:01 [############################################] 100%
:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...

Targets (15): bash-4.2.042-2  cifs-utils-5.9-1  colord-0.1.28-1  filesystem-2013.01-1  gcc-4.7.2-4  gcc-libs-4.7.2-4
              glibc-2.17-2  json-c-0.10-1  libwbclient-3.6.11-2  linux-api-headers-3.7.4-1  lxpanel-0.5.12-1
              mkinitcpio-0.12.0-3  qtwebkit-2.3.beta1-1.1  smbclient-3.6.11-2  sudo-1.8.6.p5-1

Total Download Size:    45.63 MiB
Total Installed Size:   219.79 MiB
Net Upgrade Size:       1.90 MiB

Proceed with installation? [Y/n] 
:: Retrieving packages from core...
 linux-api-headers-3.7.4-1-i686                     614.8 KiB   995K/s 00:01 [############################################] 100%
 glibc-2.17-2-i686                                    7.6 MiB  2.85M/s 00:03 [############################################] 100%
 bash-4.2.042-2-i686                                774.7 KiB  2.11M/s 00:00 [############################################] 100%
 filesystem-2013.01-1-i686                            5.9 KiB  3.76M/s 00:00 [############################################] 100%
 gcc-libs-4.7.2-4-i686                              813.2 KiB  2.47M/s 00:00 [############################################] 100%
 gcc-4.7.2-4-i686                                    17.7 MiB  2.57M/s 00:07 [############################################] 100%
 mkinitcpio-0.12.0-3-any                             28.9 KiB  2017K/s 00:00 [############################################] 100%
 sudo-1.8.6.p5-1-i686                               567.2 KiB  2.06M/s 00:00 [############################################] 100%
:: Retrieving packages from extra...
 libwbclient-3.6.11-2-i686                           27.2 KiB  3.20M/s 00:00 [############################################] 100%
 cifs-utils-5.9-1-i686                               65.1 KiB  1613K/s 00:00 [############################################] 100%
 colord-0.1.28-1-i686                               287.2 KiB  2.16M/s 00:00 [############################################] 100%
 json-c-0.10-1-i686                                  32.2 KiB  3.21M/s 00:00 [############################################] 100%
 qtwebkit-2.3.beta1-1.1-i686                          8.3 MiB  1788K/s 00:05 [############################################] 100%
 smbclient-3.6.11-2-i686                              7.8 MiB  2.04M/s 00:04 [############################################] 100%
:: Retrieving packages from community...
 lxpanel-0.5.12-1-i686                             1070.3 KiB  1679K/s 00:01 [############################################] 100%
(15/15) checking package integrity                                           [############################################] 100%
(15/15) loading package files                                                [############################################] 100%
(15/15) checking for file conflicts                                          [############################################] 100%
( 1/15) upgrading linux-api-headers                                          [############################################] 100%
( 2/15) upgrading glibc                                                      [############################################] 100%
error: could not extract usr/share/i18n/charmaps/GB2312.gz (Lzma library error: Corrupted input data)
error: problem occurred while upgrading glibc
Generating locales...
  en_US.UTF-8...character map file `UTF-8' not found: No such file or directory

gzip: stdout: Broken pipe
default character map file `ANSI_X3.4-1968' not found: No such file or directory
error: could not commit transaction
error: failed to commit transaction (transaction aborted)
Errors occurred, no packages were upgraded.

Last edited by maggie (2013-01-27 14:45:40)

Offline

#2 2013-01-27 14:01:06

graysky
Member
From: /run/user/1000
Registered: 2008-12-01
Posts: 8,517
Website

Re: System update borked due to Lzma library error/need advice [FIXED]

Can you downgrade glibc and filesystem from the ARM and repeat?


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Online

#3 2013-01-27 14:07:02

maggie
Member
Registered: 2011-02-12
Posts: 248

Re: System update borked due to Lzma library error/need advice [FIXED]

It still gives me conflicting file errors and the news items say to not to force it.

Offline

#4 2013-01-27 14:09:37

graysky
Member
From: /run/user/1000
Registered: 2008-12-01
Posts: 8,517
Website

Re: System update borked due to Lzma library error/need advice [FIXED]

I believe that refers to the new update, since you are restoring a previous state, I don't think it matters... you can try to force it or wait for someone with more experience with these things to post.  I would force it, but I have pretty robust backups.  Your call.


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Online

#5 2013-01-27 14:12:28

maggie
Member
Registered: 2011-02-12
Posts: 248

Re: System update borked due to Lzma library error/need advice [FIXED]

Downgrading with forcing worked and my update was successful. What would cause those errors? Why didn't pacman fail the package if it was broken before it tried to install the package?

error: could not extract usr/share/i18n/charmaps/GB2312.gz (Lzma library error: Corrupted input data)
error: problem occurred while upgrading glibc

Offline

#6 2013-01-27 14:14:18

graysky
Member
From: /run/user/1000
Registered: 2008-12-01
Posts: 8,517
Website

Re: System update borked due to Lzma library error/need advice [FIXED]

Glad it worked for you.  I have no idea why the package failed the integrity check.  Maybe Allan or falconindy will see this thread and comment?

Last edited by graysky (2013-01-27 14:26:06)


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Online

#7 2013-01-27 14:23:41

Allan
Developer
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,406
Website

Re: System update borked due to Lzma library error/need advice [FIXED]

It passed the integrity check, so the download is fine.   I'd be running memcheck....

Offline

#8 2013-01-27 14:46:10

maggie
Member
Registered: 2011-02-12
Posts: 248

Re: System update borked due to Lzma library error/need advice [FIXED]

Thank you graysky and allan. The memtest fails within 20 seconds. Time to RMA the memory.

Offline

Board footer

Powered by FluxBB