You are not logged in.

#1 2013-01-27 18:55:50

zooky
Member
Registered: 2013-01-27
Posts: 2

[bumblebee] Unable to use second GPU - KMS not enabled

Hello,

I have a sony S15 laptop with hybrid graphics. I'm trying to get my second GPU working... This is a Nvidia GeForce 640M LE  (the first one is an intel) :

$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation Device 0fd3 (rev a1) 

I installed bumblebee but have the following error when trying to use optirun :

$ optirun *some program*
[ 4200.276918] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) [drm] KMS not enabled
[ 4200.276971] [ERROR]Aborting because fallback start is disabled.

I tried the "early KMS start" method explained on the wiki, but it doesn't seem to work. No option is provided to the kernel.

Does somebody know how to get it working ?

Offline

#2 2013-01-27 20:38:48

nojan
Member
Registered: 2012-11-07
Posts: 15

Re: [bumblebee] Unable to use second GPU - KMS not enabled

I have a S13 laptop myself and got the same error when using the nouveau drivers. Switching to the nvidia drivers instead solved the problem for me.

Offline

#3 2013-01-28 13:37:24

zooky
Member
Registered: 2013-01-27
Posts: 2

Re: [bumblebee] Unable to use second GPU - KMS not enabled

Thank's, I installed nvidia driver and it's working now (although I have some other problems...)
It seems normal as nvidia driver doesn't require KMS.

The problem isn't really resolved... but if I can use my GPU, it's already a great thing !

Offline

Board footer

Powered by FluxBB