You are not logged in.

#1 2013-01-27 20:42:26

jujojujo_2003
Member
Registered: 2012-03-18
Posts: 9
Website

Loading module at boot (nvidiabl)

I want to load the nvidiabl at boot. I tried creating nvidiabl.conf in /etc/modules-load.d/ with the contents "nvidiabl screen_type=3" , but it doesnt launch, it throws an error. SO i guess this module needs to be loaded after xorg starts.
Any idea how i can autoload this modules?

Offline

#2 2013-01-27 22:45:43

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,094
Website

Re: Loading module at boot (nvidiabl)

modules to be loaded go in /etc/modules-load.d. Module options go in /etc/modprobe.conf. You cannot mix and match the two.

Offline

#3 2013-01-28 06:08:02

jujojujo_2003
Member
Registered: 2012-03-18
Posts: 9
Website

Re: Loading module at boot (nvidiabl)

I tried it without the options , just loading nvidiabl as it is and it still doesnt allow me to load it on boot. it says systemd[1] failed to load modules (not the exact message but similar).

[EDIT]
I dont know how but it started working after i copied the loading scripts from nvidia_bl aur.
here are the exact contents

/etc/modprobe.d/nvidiabl.conf

blacklist mbp_nvidia_bl

#If your backlight is very dim, try uncommented this option.
options nvidiabl screen_type=3

/etc/modules-load.d/nvidiabl.conf

# Load nvidiabl
nvidiabl

Last edited by jujojujo_2003 (2013-01-28 06:44:39)

Offline

#4 2013-01-28 13:50:50

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,094
Website

Re: Loading module at boot (nvidiabl)

Then look at the journal for errors... You'll need to look at messages for the PID that systemd-load-modules ran as. Messages will not show up for the service. 'systemctl status' shows you the pid, and then you can run 'journalctl -b _PID=$pid'

Last edited by falconindy (2013-01-28 13:51:44)

Offline

Board footer

Powered by FluxBB