You are not logged in.

#1 2013-01-28 16:16:44

cedricmc
Member
From: Madrid, Spain
Registered: 2011-11-20
Posts: 48

[SOLVED] How to set the default file browser

Hi guys,

since I installed Quod Libet (around 1 year ago), Ex Falso is my default file browser. I have stated this behavior in two different computers as a system wide setting. Since I am using Gnome3, I would like to have Nautilus as default file browser. What can I do? How can I know what setting files where modified by Quod Libet upon installation?

Thx, folks!

SOLVED down there #5!

Last edited by cedricmc (2013-02-02 12:09:51)

Offline

#2 2013-01-28 20:35:39

dustykhan
Member
Registered: 2012-01-12
Posts: 21

Re: [SOLVED] How to set the default file browser

I have the same issue when clicking on 'Open containing Folder' in firefox. Would love to know how to fix this!

Offline

#3 2013-01-28 21:38:32

anonymous_user
Member
Registered: 2009-08-28
Posts: 3,058

Re: [SOLVED] How to set the default file browser

What is the output of xdg-mime query default inode/directory? If its not nautilus, you can make it the default with:

xdg-mime default nautilus.desktop inode/directory

Offline

#4 2013-01-30 22:49:22

dustykhan
Member
Registered: 2012-01-12
Posts: 21

Re: [SOLVED] How to set the default file browser

Thank you very much. I swaped nautilus for, pcmanfm and it sorted out my problem just fine. So thanks again wink

Offline

#5 2013-02-02 11:38:22

cedricmc
Member
From: Madrid, Spain
Registered: 2011-11-20
Posts: 48

Re: [SOLVED] How to set the default file browser

Thx anonymous_user! Even though your command did not solve the wide system setting problem, pulling from that hint I managed to find where was exactly the problem and how to solve it. However I still don't know how did I get there...

After issuing

$ xdg-mime query default inode/directory
exfalso.desktop

I determined that Ex Falso was (at least) the per-user default file browser. In fact,

$ xdg-open ~

was lauching Ex Falso on my home directory. I therefore executed

$ xdg-mime default nautilus.desktop inode/directory
$ xdg-mime query default inode/directory
nautilus.desktop
$ xdg-open ~

and now my per-user setting was corrected. But still not the system wide one.

I noticed that ~/.local/share/applications/mimeapps.list had a new line

[Default Applications]
 inode/directory=nautilus.desktop;

Although the file /usr/share/applications/mimeapps.list does not exist, /usr/share/applications/mimeinfo.cache does and had the line

[Default Applications]
 inode/directory=exfalso.desktop;nautilus.desktop;

that I changed to

[Default Applications]
 inode/directory=nautilus.desktop;

I deleted the corresponding one from ~/.local/share/applications/mimeapps.list and now the problem is solved, my common sense system wide configuration is correct. And yet I don't know from where it came.

UPDATE: updating the system may launch update-desktop-database (from the desktop-file-utils package) and revert the changes made in /usr/share/applications/mimeinfo.cache. A workaround is to delete the mimetype field of /usr/share/applications/exfalso.desktop.

Last edited by cedricmc (2013-02-08 15:03:40)

Offline

Board footer

Powered by FluxBB