You are not logged in.

#1 2013-01-28 22:00:33

mihok
Member
From: Toronto, Canada
Registered: 2012-11-13
Posts: 4
Website

[SOLVED] Arch terminal issues

Having some trouble with my terminal in Arch. I currently have Arch running with i3 and using Terminator emulating xterm. Everything is fine except something is causing the terminal instance to wrap the cursor way too earlier (before the end of the columns) and it wraps back to the start of the line rather than the beginning of a new line. I'm not sure how this would have happened or if there is some option to fix this. It works fine when I have no seperate tiles, adding vertical tiles causes the weird word wrap but horizontal tiling doesn't affect it. It's almost like its trying to programmatically figure out the word wrap point but gets halved with you add vertical tiles

Thanks for any help!

Last edited by mihok (2013-01-29 14:27:04)

Offline

#2 2013-01-28 22:47:18

jv2112
Member
Registered: 2011-07-23
Posts: 154

Re: [SOLVED] Arch terminal issues

I have the same issue on a intermittent basis with gnome-terminal in open-box. I can't figure it out either sad


Life is pleasant. Death is peaceful. It's the transition that's troublesome. Isaac Asimov - / -  My Pastebin

Offline

#3 2013-01-28 22:53:23

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,371
Website

Re: [SOLVED] Arch terminal issues

It sounds like unescaped color codes in your PS1.

To test, set PS1 to something simple (eg `PS1='>'`).  If that fixes it, then fix your custom PS1.


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#4 2013-01-29 00:11:51

jv2112
Member
Registered: 2011-07-23
Posts: 154

Re: [SOLVED] Arch terminal issues

Thanks for the suggestion but I still get the behavior aorund 70% of the way into the line.  sad


echo $PS1
\e[00;31m[-\e[107;34m\u@\h\e[00;31m-] |-\e[107;31m in [* \W *]\e[00;31m-|->\e[00m

Life is pleasant. Death is peaceful. It's the transition that's troublesome. Isaac Asimov - / -  My Pastebin

Offline

#5 2013-01-29 00:26:35

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,371
Website

Re: [SOLVED] Arch terminal issues

Yes, and that PS1 is the problem.  You need to surround color codes (or any other non-printing characters with \[ \].  None of your color sequences are in these brackets.


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#6 2013-01-29 10:42:57

jv2112
Member
Registered: 2011-07-23
Posts: 154

Re: [SOLVED] Arch terminal issues

Thanks Trilby.

 
echo $PS1

\e\[[00;31m\][-\e\[[107;34m\]\u@\h\e\[[00;31m\]-] |-\e\[[107;31m\] in [* \W *]\e\[[00;31m\]-|->\e\[[00m\]

Life is pleasant. Death is peaceful. It's the transition that's troublesome. Isaac Asimov - / -  My Pastebin

Offline

#7 2013-01-29 11:59:54

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,371
Website

Re: [SOLVED] Arch terminal issues

Does that work?  It shouldn't.

\e\[[00;31m\] should be \[\e[00;31m\] for example.


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#8 2013-01-29 14:22:48

mihok
Member
From: Toronto, Canada
Registered: 2012-11-13
Posts: 4
Website

Re: [SOLVED] Arch terminal issues

Amazing!! This also did it for me, thank you so much!

Offline

#9 2013-01-29 22:43:23

jv2112
Member
Registered: 2011-07-23
Posts: 154

Re: [SOLVED] Arch terminal issues

Thanks for the direction.  cool

PS1="\[\e[00;31m\][- \[\e[107;34m\]\u@\h\[\e[00;31m\]- ]
|-\[\e[107;31m\] in [* \W * ]\[\e[00;31m\]-|-->\[\e[00m\]"
------------------------------------------------------------------------------
[- joe@Tux-Box- ]
|- in [* Tunes * ]-|-->

Life is pleasant. Death is peaceful. It's the transition that's troublesome. Isaac Asimov - / -  My Pastebin

Offline

Board footer

Powered by FluxBB