You are not logged in.

#1 2013-01-28 16:51:53

JohnnyDeacon
Member
From: Colombia
Registered: 2012-01-18
Posts: 81

[SOLVED]ERROR: Slim don't load

Since I recently install Arch with Xfce 4.10, I cant' get working any DM, I try LightDM, LXDM and Slim, I've been googling for a solution without success.

I get this error when booting the system with slim:


╒══[ /home/jairo ]═══╕
  └> systemctl status slim
slim.service - SLiM Simple Login Manager
	  Loaded: loaded (/usr/lib/systemd/system/slim.service; disabled)
	  Active: inactive (dead)

Jan 26 13:24:09 Killer slim[330]: [618:618:0126/132409:ERROR:zygote_host_impl_linux.cc(474)] Failed to send GetTerminationStatus message to zygote
Jan 26 13:24:09 Killer slim[330]: [618:618:0126/132409:ERROR:zygote_host_impl_linux.cc(474)] Failed to send GetTerminationStatus message to zygote
Jan 26 13:24:09 Killer slim[330]: [618:618:0126/132409:ERROR:zygote_host_impl_linux.cc(474)] Failed to send GetTerminationStatus message to zygote
Jan 26 13:24:09 Killer slim[330]: [618:618:0126/132409:ERROR:zygote_host_impl_linux.cc(474)] Failed to send GetTerminationStatus message to zygote
Jan 26 13:24:09 Killer slim[330]: [618:618:0126/132409:ERROR:zygote_host_impl_linux.cc(474)] Failed to send GetTerminationStatus message to zygote
Jan 26 13:24:09 Killer slim[330]: [618:618:0126/132409:ERROR:zygote_host_impl_linux.cc(474)] Failed to send GetTerminationStatus message to zygote
Jan 26 13:24:09 Killer slim[330]: Server terminated successfully (0). Closing log file.
Jan 26 13:24:10 Killer systemd[1]: slim.service: main process exited, code=exited, status=1/FAILURE
Jan 26 13:24:10 Killer systemd[1]: Stopped SLiM Simple Login Manager.
Jan 26 13:24:10 Killer systemd[1]: Unit slim.service entered failed state

~/.xinitrc

#!/bin/sh
#
# ~/.xinitrc
#
# Executed by startx (run your window manager from here)

if [ -d /etc/X11/xinit/xinitrc.d ]; then
  for f in /etc/X11/xinit/xinitrc.d/*; do
    [ -x "$f" ] && . "$f"
  done
  unset f
fi

# exec gnome-session
# exec startkde
exec startxfce4
# ...or the Window Manager of your choice

slim.conf

# Path, X server and arguments (if needed)
# Note: -xauth $authfile is automatically appended
default_path        /bin:/usr/bin:/usr/local/bin
default_xserver     /usr/bin/X
xserver_arguments -nolisten tcp vt07

# Commands for halt, login, etc.
halt_cmd            /sbin/shutdown -h now
reboot_cmd          /sbin/shutdown -r now
console_cmd         /usr/bin/xterm -C -fg white -bg black +sb -T "Console login" -e /bin/sh -c "/bin/cat /etc/issue; exec /bin/login"
#suspend_cmd        /usr/sbin/suspend

# Full path to the xauth binary
xauth_path         /usr/bin/xauth 

# Xauth file for server
authfile           /var/run/slim.auth


# Activate numlock when slim starts. Valid values: on|off
# numlock             on

# Hide the mouse cursor (note: does not work with some WMs).
# Valid values: true|false
# hidecursor          false

# This command is executed after a succesful login.
# you can place the %session and %theme variables
# to handle launching of specific commands in .xinitrc
# depending of chosen session and slim theme
#
# NOTE: if your system does not have bash you need
# to adjust the command according to your preferred shell,
# i.e. for freebsd use:
# login_cmd           exec /bin/sh - ~/.xinitrc %session
login_cmd           exec /bin/bash -login ~/.xinitrc %session

# Commands executed when starting and exiting a session.
# They can be used for registering a X11 session with
# sessreg. You can use the %user variable
#
# sessionstart_cmd	some command
# sessionstop_cmd	some command

# Start in daemon mode. Valid values: yes | no
# Note that this can be overriden by the command line
# options "-d" and "-nodaemon"
# daemon	yes

# Available sessions (first one is the default).
# The current chosen session name is replaced in the login_cmd
# above, so your login command can handle different sessions.
# see the xinitrc.sample file shipped with slim sources
sessions            xfce4,icewm-session,wmaker,blackbox

# Executed when pressing F11 (requires imagemagick)
screenshot_cmd      import -window root /slim.png

# welcome message. Available variables: %host, %domain
welcome_msg         Welcome to %host

# Session message. Prepended to the session name when pressing F1
# session_msg         Session: 

# shutdown / reboot messages
shutdown_msg       The system is halting...
reboot_msg         The system is rebooting...

# default user, leave blank or remove this line
# for avoid pre-loading the username.
#default_user        simone

# Focus the password field on start when default_user is set
# Set to "yes" to enable this feature
#focus_password      no

# Automatically login the default user (without entering
# the password. Set to "yes" to enable this feature
#auto_login          no


# current theme, use comma separated list to specify a set to 
# randomly choose from
current_theme       default

# Lock file
lockfile            /var/lock/slim.lock

# Log file
logfile             /var/log/slim.log

Any help are welcome

Thanks in advance.

Last edited by JohnnyDeacon (2013-01-30 13:21:00)

Offline

#2 2013-01-28 17:52:20

DarkCerberus
Member
From: /dev/null
Registered: 2011-12-31
Posts: 246

Re: [SOLVED]ERROR: Slim don't load

Have you tried the following:

 systemctl disable slim.service

and then

 systemctl enable slim.service

and in the ~/.xinitrc file just place the following:

 exec startxfce4

without anything else in that file

Offline

#3 2013-01-28 18:09:36

JohnnyDeacon
Member
From: Colombia
Registered: 2012-01-18
Posts: 81

Re: [SOLVED]ERROR: Slim don't load

DarkCerberus wrote:

Have you tried the following:

 systemctl disable slim.service

and then

 systemctl enable slim.service

and in the ~/.xinitrc file just place the following:

 exec startxfce4

without anything else in that file

Thanks for response, first command works without problem, the second one show me this:

 ╒══[ /home/jairo ]═══╕
  └> systemctl enable slim.service
Failed to issue method call: File exists

Also change the lines in .xinitrc, but it's not working. . .

When I boot my system, in tty1, I need to execute:

# systemctl start slim

then I can get slim and login without problema

Last edited by JohnnyDeacon (2013-01-28 18:16:26)

Offline

#4 2013-01-28 19:42:57

derhamster
Member
Registered: 2012-07-08
Posts: 86

Re: [SOLVED]ERROR: Slim don't load

Check if the symlink /etc/systemd/system/display-manager.service exists, and where it points to in case it exists.

If it exists, you probably have another display manager (LightDM?) enabled. Disable it through systemctl and then enable Slim.

Offline

#5 2013-01-28 23:00:08

JohnnyDeacon
Member
From: Colombia
Registered: 2012-01-18
Posts: 81

Re: [SOLVED]ERROR: Slim don't load

derhamster wrote:

Check if the symlink /etc/systemd/system/display-manager.service exists, and where it points to in case it exists.

If it exists, you probably have another display manager (LightDM?) enabled. Disable it through systemctl and then enable Slim.

File display-manager.service exists

  ╒══[ /home/jairo ]═══╕
  └> ls /etc/systemd/system/display-manager.service 
/etc/systemd/system/display-manager.service

but. . .

  ╒══[ /home/jairo ]═══╕
  └> systemctl disable lxdm.service
Failed to issue method call: No such file or directory
  ╒══[ /home/jairo ]═══╕
  └> systemctl disable lightdm.service
Failed to issue method call: No such file or directory

Display-Manager status:

  ╒══[ /home/jairo ]══════╕
  └> systemctl status display-manager
display-manager.service
	  Loaded: error (Reason: No such file or directory)
	  Active: inactive (dead)

Jan 23 08:59:37 Killer systemd[1]: Cannot add dependency job for unit display-manager.service, ignoring: Unit display-manager.service failed to load: No s...or details.
Jan 23 09:20:52 Killer systemd[1]: Cannot add dependency job for unit display-manager.service, ignoring: Unit display-manager.service failed to load: No s...or details.
Jan 25 03:16:12 Killer systemd[1]: Cannot add dependency job for unit display-manager.service, ignoring: Unit display-manager.service failed to load: No s...or details.

Offline

#6 2013-01-28 23:16:34

derhamster
Member
Registered: 2012-07-08
Posts: 86

Re: [SOLVED]ERROR: Slim don't load

And did you check to what service the symlink points? Is it even a symlink? Run

file /etc/systemd/system/display-manager.service

If it is a regular file (not a symlink), show us the contents. Or probably easier, just delete it and then try to enable slim.

Offline

#7 2013-01-29 00:14:49

JohnnyDeacon
Member
From: Colombia
Registered: 2012-01-18
Posts: 81

Re: [SOLVED]ERROR: Slim don't load

derhamster wrote:

And did you check to what service the symlink points? Is it even a symlink? Run

file /etc/systemd/system/display-manager.service

If it is a regular file (not a symlink), show us the contents. Or probably easier, just delete it and then try to enable slim.

 ╒══[ /home/jairo ]════╕
  └> ls -lh /etc/systemd/system/display-manager.service 
lrwxrwxrwx 1 root root 36 Jan 28 18:13 /etc/systemd/system/display-manager.service -> /usr/lib/systemd/system/slim.service

What a weird thing. . .

Last edited by JohnnyDeacon (2013-01-29 00:15:17)

Offline

#8 2013-01-29 00:19:04

jv2112
Member
Registered: 2011-07-23
Posts: 154

Re: [SOLVED]ERROR: Slim don't load

I had the same issue so I forced it and life was good smile

syetemctl -f enable slim.service

Life is pleasant. Death is peaceful. It's the transition that's troublesome. Isaac Asimov - / -  My Pastebin

Offline

#9 2013-01-29 14:27:08

JohnnyDeacon
Member
From: Colombia
Registered: 2012-01-18
Posts: 81

Re: [SOLVED]ERROR: Slim don't load

@jv2112

Not working, I'm getting used to access the system with systemctl start slim or startxfce4

This is display-manager.service file:

[Unit]
Description=SLiM Simple Login Manager
After=systemd-user-sessions.service

[Service]
ExecStart=/usr/bin/slim 

[Install]
Alias=display-manager.service

And the default target is linking to multi-user target:

lrwxrwxrwx 1 root root   41 Jan 25 22:51 default.target -> /usr/lib/systemd/system/multi-user.target

Is that right?

Last edited by JohnnyDeacon (2013-01-29 14:31:24)

Offline

#10 2013-01-29 23:03:29

jv2112
Member
Registered: 2011-07-23
Posts: 154

Re: [SOLVED]ERROR: Slim don't load

No , I believe it should be linked to the slim service.


Life is pleasant. Death is peaceful. It's the transition that's troublesome. Isaac Asimov - / -  My Pastebin

Offline

#11 2013-01-30 09:07:21

derhamster
Member
Registered: 2012-07-08
Posts: 86

Re: [SOLVED]ERROR: Slim don't load

No it should not. Slim is a service not a target.
The symlink to multi-user.target is probably the reason slim doesn't start. IMO you don't actually need a default.target symlink, because systemd defaults to graphical.target, which in turn "Wants" display-manager.service.

So just remove the default.target with

systemctl disable multi-user.target

Offline

#12 2013-01-30 13:20:30

JohnnyDeacon
Member
From: Colombia
Registered: 2012-01-18
Posts: 81

Re: [SOLVED]ERROR: Slim don't load

derhamster wrote:

No it should not. Slim is a service not a target.
The symlink to multi-user.target is probably the reason slim doesn't start. IMO you don't actually need a default.target symlink, because systemd defaults to graphical.target, which in turn "Wants" display-manager.service.

So just remove the default.target with

systemctl disable multi-user.target

You are a GOD that solve my problem! Damn, fuck logic

Offline

#13 2013-02-03 02:27:14

1archgamenon2
Banned
Registered: 2011-07-12
Posts: 201

Re: [SOLVED]ERROR: Slim don't load

JohnnyDeacon wrote:
derhamster wrote:

No it should not. Slim is a service not a target.
The symlink to multi-user.target is probably the reason slim doesn't start. IMO you don't actually need a default.target symlink, because systemd defaults to graphical.target, which in turn "Wants" display-manager.service.

So just remove the default.target with

systemctl disable multi-user.target

Got the same inconvenient!: I have to write systemctl start slim at each start on other tty2...

xinitrc:

#!/bin/sh
#
# ~/.xinitrc
#
# Executed by startx (run your window manager from here)

if [ -d /etc/X11/xinit/xinitrc.d ]; then
  for f in /etc/X11/xinit/xinitrc.d/*; do
    [ -x "$f" ] && . "$f"
  done
  unset f
fi

# exec gnome-session
# exec startkde
 exec startxfce4
# ...or the Window Manager of your choice

/etc/slim.conf:

# Path, X server and arguments (if needed)
# Note: -xauth $authfile is automatically appended
default_path        /bin:/usr/bin:/usr/local/bin
default_xserver     /usr/bin/X
xserver_arguments -nolisten tcp vt07

# Commands for halt, login, etc.
halt_cmd            /sbin/shutdown -h now
reboot_cmd          /sbin/shutdown -r now
console_cmd         /usr/bin/xterm -C -fg white -bg black +sb -T "Console login" -e /bin/sh -c "/bin/cat /etc/issue; exec /bin/login"
#suspend_cmd        /usr/sbin/suspend

# Full path to the xauth binary
xauth_path         /usr/bin/xauth 

# Xauth file for server
authfile           /var/run/slim.auth


# Activate numlock when slim starts. Valid values: on|off
# numlock             on

# Hide the mouse cursor (note: does not work with some WMs).
# Valid values: true|false
# hidecursor          false

# This command is executed after a succesful login.
# you can place the %session and %theme variables
# to handle launching of specific commands in .xinitrc
# depending of chosen session and slim theme
#
# NOTE: if your system does not have bash you need
# to adjust the command according to your preferred shell,
# i.e. for freebsd use:
# login_cmd           exec /bin/sh - ~/.xinitrc %session
login_cmd           exec /bin/bash -login ~/.xinitrc %session

# Commands executed when starting and exiting a session.
# They can be used for registering a X11 session with
# sessreg. You can use the %user variable
#
# sessionstart_cmd	some command
# sessionstop_cmd	some command

# Start in daemon mode. Valid values: yes | no
# Note that this can be overriden by the command line
# options "-d" and "-nodaemon"
# daemon	yes

# Available sessions (first one is the default).
# The current chosen session name is replaced in the login_cmd
# above, so your login command can handle different sessions.
# see the xinitrc.sample file shipped with slim sources
sessions            xfce4,icewm-session,wmaker,blackbox

# Executed when pressing F11 (requires imagemagick)
screenshot_cmd      import -window root /slim.png

# welcome message. Available variables: %host, %domain
welcome_msg         Welcome to %host

# Session message. Prepended to the session name when pressing F1
# session_msg         Session: 

# shutdown / reboot messages
shutdown_msg       The system is halting...
reboot_msg         The system is rebooting...

# default user, leave blank or remove this line
# for avoid pre-loading the username.
#default_user        simone

# Focus the password field on start when default_user is set
# Set to "yes" to enable this feature
#focus_password      no

# Automatically login the default user (without entering
# the password. Set to "yes" to enable this feature
#auto_login          no


# current theme, use comma separated list to specify a set to 
# randomly choose from
current_theme       default

# Lock file
lockfile            /var/lock/slim.lock

# Log file
logfile             /var/log/slim.log

sorry for hijackin the post...

edit:

https://bugs.archlinux.org/task/32177

systemctl status slim

$ systemctl status slim

slim.service - SLiM Simple Login Manager
	  Loaded: loaded (/usr/lib/systemd/system/slim.service; disabled)
	  Active: active (running) since Sat 2013-02-02 19:49:09 UTC; 59min ago
	Main PID: 305 (slim)
	  CGroup: name=systemd:/system/slim.service
		  `-307 /usr/bin/X -nolisten tcp vt07 -auth /var/run/slim.aut...
		  > 305 /usr/bin/slim -nodaemon
$ ls /usr/lib/systemd/system/ |grep slim
slim.service
Feb 02 20:28:39 arch slim[305]: Failed to open VDPAU backend libvdpau_nvidi...ry
Feb 02 20:30:08 arch slim[305]: Failed to open VDPAU backend libvdpau_nvidi...ry
Feb 02 20:37:16 arch slim[305]: Fontconfig warning: "/etc/fonts/conf.d/50-u...d.
Feb 02 20:48:27 arch slim[305]: Fontconfig warning: "/etc/fonts/conf.d/50-u...d.
Feb 02 20:57:23 arch slim[305]: Fontconfig warning: "/etc/fonts/conf.d/50-u...d.
Feb 02 21:01:11 arch slim[305]: Failed to open VDPAU backend libvdpau_nvidi...ry
Feb 02 21:03:27 arch slim[305]: Fontconfig warning: "/etc/fonts/conf.d/50-u...d.
Feb 02 21:04:12 arch slim[305]: NOTE: child process received `Goodbye', clo...wn
Feb 02 21:11:17 arch slim[305]: Failed to open VDPAU backend libvdpau_nvidi...ry
Feb 02 21:14:18 arch slim[305]: NOTE: child process received `Goodbye', clo...wn

Last edited by 1archgamenon2 (2013-02-03 03:21:47)

Offline

#14 2013-02-03 11:49:08

derhamster
Member
Registered: 2012-07-08
Posts: 86

Re: [SOLVED]ERROR: Slim don't load

1archgamenon2 wrote:

systemctl status slim

$ systemctl status slim

slim.service - SLiM Simple Login Manager
	  Loaded: loaded (/usr/lib/systemd/system/slim.service; disabled)
	  Active: active (running) since Sat 2013-02-02 19:49:09 UTC; 59min ago
	Main PID: 305 (slim)
	  CGroup: name=systemd:/system/slim.service
		  `-307 /usr/bin/X -nolisten tcp vt07 -auth /var/run/slim.aut...
		  > 305 /usr/bin/slim -nodaemon

There is your error. Slim is not enabled. Run

systemctl enable slim.service

to enable Slim.

But remember: even if Slim is enabled, it will only be started when you boot into graphical.target. The OP booted into multi-user.target, which does not cause Slim to start.

Offline

#15 2013-02-03 12:05:05

1archgamenon2
Banned
Registered: 2011-07-12
Posts: 201

Re: [SOLVED]ERROR: Slim don't load

derhamster wrote:
1archgamenon2 wrote:

systemctl status slim

$ systemctl status slim

slim.service - SLiM Simple Login Manager
	  Loaded: loaded (/usr/lib/systemd/system/slim.service; disabled)
	  Active: active (running) since Sat 2013-02-02 19:49:09 UTC; 59min ago
	Main PID: 305 (slim)
	  CGroup: name=systemd:/system/slim.service
		  `-307 /usr/bin/X -nolisten tcp vt07 -auth /var/run/slim.aut...
		  > 305 /usr/bin/slim -nodaemon

There is your error. Slim is not enabled. Run

systemctl enable slim.service

to enable Slim.

But remember: even if Slim is enabled, it will only be started when you boot into graphical.target. The OP booted into multi-user.target, which does not cause Slim to start.

th 4 the reply!

# systemctl enable slim.service
Failed to issue method call: File exists

Offline

#16 2013-02-04 14:23:16

JohnnyDeacon
Member
From: Colombia
Registered: 2012-01-18
Posts: 81

Re: [SOLVED]ERROR: Slim don't load

1archgamenon2 wrote:
derhamster wrote:
1archgamenon2 wrote:

systemctl status slim

$ systemctl status slim

slim.service - SLiM Simple Login Manager
	  Loaded: loaded (/usr/lib/systemd/system/slim.service; disabled)
	  Active: active (running) since Sat 2013-02-02 19:49:09 UTC; 59min ago
	Main PID: 305 (slim)
	  CGroup: name=systemd:/system/slim.service
		  `-307 /usr/bin/X -nolisten tcp vt07 -auth /var/run/slim.aut...
		  > 305 /usr/bin/slim -nodaemon

There is your error. Slim is not enabled. Run

systemctl enable slim.service

to enable Slim.

But remember: even if Slim is enabled, it will only be started when you boot into graphical.target. The OP booted into multi-user.target, which does not cause Slim to start.

th 4 the reply!

# systemctl enable slim.service
Failed to issue method call: File exists

Do

# systemctl reenable slim

or

# systemctl -f enable slim.service

Offline

Board footer

Powered by FluxBB