You are not logged in.

#1 2013-01-29 13:00:43

-MacNuke-
Member
Registered: 2013-01-29
Posts: 11

Bluetooth gone after suspend

Hi,

i have a MacBook 3,1 with an up to date ArchLinux with GNOME 3.6 in EFI-Mode running. Everything works fine so far, except for bluetooth (and another thing, but this may be another thread).

When I boot my system, bluetooth works like a charme. But after suspend (to RAM, close the lid) and resume, bluetooth is completely gone. The Bluetooth Icon in GNOME vanished and my bluetooth mouse stopped working. Then nothing of the following works:

systemctl restart bluetooth
rmmod btusb
modprobe btusb

I have to restart the system to get bluetooth back. I tried to search for a solution and found something in this forum. I added a systemd sleep script to stop bluetooth and then start it after resume. But this does not work. I works sometimes but mostly is does not.

/usr/lib/systemd/system-sleep/10_bluetooth.sh

#!/bin/sh

case $1/$2 in
    pre/*)
      echo "10_bluetooth.sh - Going to $2. Killing Bluetooth..."
      systemctl stop bluetooth
      rfkill block bluetooth
      rmmod btusb
      ;;
    post/*)
      echo "10_bluetooth.sh - Waking up from $2. Restarting Bluetooth..."
      modprobe btusb
      sleep 3
      rfkill unblock bluetooth
      systemctl start bluetooth
      ;;
    *)
      ;;
esac

exit

As I see in journalctl systemd runs this script. But then nothing is found by the bluetooth module i think.

Has anybody an idea?

Thanks.

Offline

#2 2013-01-29 21:16:24

-MacNuke-
Member
Registered: 2013-01-29
Posts: 11

Re: Bluetooth gone after suspend

I have also tried to add:

hciconfig hci0 down

hciconfig hci0 up

in this script, but it seems that the bluetooth device is gone after suspend. hciconfig can't find hci0 anymore.

Offline

#3 2013-02-02 15:32:42

wesker
Member
Registered: 2013-02-02
Posts: 2

Re: Bluetooth gone after suspend

Is it possible that your bluetooth device gets hard blocked on closing the lid, and is not properly unblocked on opening? What gives rfkill list all before and after suspend?

Offline

#4 2013-07-02 12:26:55

Leduck
Member
From: Brazil
Registered: 2011-04-25
Posts: 34
Website

Re: Bluetooth gone after suspend

MacNuke, installed my system a few days ago and am experiencing the same problem, you could find a solution??

Offline

#5 2013-07-07 14:16:47

drasticraft
Member
From: mars
Registered: 2013-07-05
Posts: 55
Website

Re: Bluetooth gone after suspend

You posted that you tried to use 'systemctl restart bluetooth' to restart the bluetooth.
Have you tried

systemctl start bluetooth

You might need to act as if it was never started.

Last edited by drasticraft (2013-07-07 14:17:54)

Offline

Board footer

Powered by FluxBB