You are not logged in.

#1 2013-01-29 23:29:51

eruditorum
Member
Registered: 2012-11-12
Posts: 130

[SOLVED] Can't disable Wake-on-Lan on Realtek Lan adapter

Hello!

My laptop's battery is running fast in sleep but I want to minimize power usage in sleep mode (S3)!
And ethernet adapter seem to be main power-consumer on the system because of Wake on Lan which is always enabled and I can do nothing with it sad(

Device is: "PCI Device: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller"
Kernel module: r8169


powertop:

Bad           Wake-on-lan status for device eth0

ethtool:

:sudo ethtool eth0|grep Wake
24:	Supports Wake-on: pumbg
25:	Wake-on: pumbg

"sudo ethtool -s eth0 wol d" doesn't change anything.
Also,

:cat /sys/class/net/eth0/device/power/wakeup
disabled

but this is obviously not true.

Please help!

Last edited by eruditorum (2013-02-16 11:09:30)

Offline

#2 2013-01-29 23:41:33

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,804
Website

Re: [SOLVED] Can't disable Wake-on-Lan on Realtek Lan adapter

I've never done this, so take this only as brainstorming - but you can have pre- and post- sleep hooks to put the eth0 interface down before sleeping and bring it back up after waking.  I'd suspect this should do it.


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#3 2013-01-30 02:25:28

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED] Can't disable Wake-on-Lan on Realtek Lan adapter

Can you try this with the r8168 package?  It is the module provided by realtek.  I have a rev 7 of the same card (not sure what yours is, lspci will tell you), and I had all kinds of trouble with the in kernel module.  Though I have communicated with countless others who say their card works find with the module from the kernel (r8169).

Just install the r8168 package, and then blacklist the r8169 module.

Offline

#4 2013-01-30 05:05:17

eruditorum
Member
Registered: 2012-11-12
Posts: 130

Re: [SOLVED] Can't disable Wake-on-Lan on Realtek Lan adapter

Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)

Offline

#5 2013-01-30 06:04:10

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED] Can't disable Wake-on-Lan on Realtek Lan adapter

Ummm.. okay... so did you try it?

Offline

#6 2013-01-30 06:49:52

eruditorum
Member
Registered: 2012-11-12
Posts: 130

Re: [SOLVED] Can't disable Wake-on-Lan on Realtek Lan adapter

Of course!

Well, it works, but adapter itself eats about 1W even when idle (powertop says it doesn't, but I see whole system power ~6.5W idle whereas it was ~5.5W idle with Ethernet disabled in BIOS).
If I disable it in BIOS then I can't disable WoL on adapter, so it will consume energy in S3 mode.

Am I wrong somewhere?

Last edited by eruditorum (2013-01-30 06:54:15)

Offline

#7 2013-01-30 07:49:01

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED] Can't disable Wake-on-Lan on Realtek Lan adapter

I don't quite understand... how are you disabling it in the BIOS and able to do anything with it?

Edit: Still learning how to type with android's autocorrect...

Last edited by WonderWoofy (2013-01-30 07:50:22)

Offline

#8 2013-01-30 09:41:57

eruditorum
Member
Registered: 2012-11-12
Posts: 130

Re: [SOLVED] Can't disable Wake-on-Lan on Realtek Lan adapter

No no no.
I mean that if adapter is disabled in BIOS it will drain battery in S3.
If not - I can disable WoL in it and it doesn't drain battery in S3, but eats ~1W during runtime.

Offline

#9 2013-01-30 10:32:50

mich41
Member
Registered: 2012-06-22
Posts: 592

Re: [SOLVED] Can't disable Wake-on-Lan on Realtek Lan adapter

Does it still drain 1W if you "down" it?

Offline

#10 2013-01-31 01:57:41

eruditorum
Member
Registered: 2012-11-12
Posts: 130

Re: [SOLVED] Can't disable Wake-on-Lan on Realtek Lan adapter

mich41 wrote:

Does it still drain 1W if you "down" it?

Yes, it does (already was "down")

Offline

Board footer

Powered by FluxBB