You are not logged in.

#1 2005-11-04 20:39:05

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,211

file:/// how to enable it ?

When i try to configure kmyfirewall i get a message like this :

file:///root/xxxx.kmgfrs not found

Also when i try to setup a local repo for pacman, pacman doesn' t seem to be able to find the db.


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#2 2005-11-05 00:31:39

jftaylor21
Member
From: Arch Linux Forums
Registered: 2004-02-21
Posts: 237

Re: file:/// how to enable it ?

it should already be "enabled". Try to just type file:/// into your browser of choice and it should display the root directory. Are you sure that /root/xxxx.kmgfrs exists?

As for the pacman part. Did you follow the wiki Local repository HOW-TO?

Wow, the wiki forum mod sure is nice.

Offline

#3 2005-11-06 22:56:06

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,211

Re: file:/// how to enable it ?

file:/// works from a browser, so it looks like that is working, atleast for logged-in users.

I've tried to use this :
Custom local repository with ABS and gensync .

gensync gave no problems, but it seems archlinux is VERY strict on security.

pacman run as root IS NOT allowed to access file:// or ftp:// links.

I guess i must use pacman -A until i figure out how to get an ftp-server up.


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#4 2005-11-07 07:57:19

jftaylor21
Member
From: Arch Linux Forums
Registered: 2004-02-21
Posts: 237

Re: file:/// how to enable it ?

Once you gensync your repo. You should be able to use it by adding it to pacman.conf

[custom]
Server = file:///home/custompkgs

Is this where pacman gives you errors?

Offline

#5 2005-11-07 19:02:43

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,211

Re: file:/// how to enable it ?

found it.

at first i had this :
[Lone_Wolf]
Server = file:///home/ftp/Lone_Wolf-repo

this gave the error that pacman couldn't open the db Lone_Wolf.

then i changed it to this :
[Lone_Wolf-repo]
Server = file:///home/ftp/Lone_Wolf-repo

now it works.

It appears the name of the repo needs to match the directory.


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#6 2005-11-07 21:52:00

T-Dawg
Forum Fellow
From: Wilmington, NC
Registered: 2005-01-29
Posts: 2,734

Re: file:/// how to enable it ?

was Lone_Wolf the name of your db.tar.gz? Thats what it should be looking at anyway.

Offline

#7 2005-11-07 23:26:47

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,211

Re: file:/// how to enable it ?

at first the db file was named Lone_Wolf.db.tar.gz , while the directory was named Lone_Wolf-repo.

Now in pacman.conf, folder and db-file i use Lone_Wolf-repo.


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

Board footer

Powered by FluxBB