You are not logged in.

#1 2013-01-31 04:17:22

dlin
Member
From: Taipei,Taiwan
Registered: 2005-09-21
Posts: 264

[SOLVED] How to disable distcc in /etc/makepkg?

I've ever set DISTCC in /etc/makepkg.
But, found some compile error, so I want back to single thread build.
What's the correct method?

I just remove distcc package and commented out MAKEFLAGS  & DISTCC_HOSTS.

It shows following error message:

 $ makepkg -A --skippgpcheck --skipinteg --nocheck
==> ERROR: Cannot find the distcc binary required for distributed compilation.

Last edited by dlin (2013-01-31 04:25:37)


Running 4 ArchLinux including sh4twbox,server,notebook,desktop. my AUR packages, old project Arch on colinux,

Offline

#2 2013-01-31 04:23:59

Allan
Developer
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,396
Website

Re: [SOLVED] How to disable distcc in /etc/makepkg?

Look at the BUILDENV variable of makepkg.conf.  It should have distcc disabled:

BUILDENV=(fakeroot !distcc color !ccache check !sign)

Offline

Board footer

Powered by FluxBB