You are not logged in.

#1 2005-11-03 18:56:37

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Configuring fonts with gnome-control-center while using fvwm

Some of my fonts in apps (moreamp and firefox) are too large and I would like to have them smaller.  Although I am using FVWM, I started gnome-control-center and changed the 'Desktop' fonts to a smaller size and everything is OK. However, every time I log out, the fonts come back to their large size. I restart gnome-control-center, open the font panel and nothing has changed. If I start moreamp after that, the fonts are back to the small size I want them to be.  Does anyone know how to make the font change permanent? Do I get this behavior because I'm using FVWM and not Gnome?

I've also tried changing /etc/fonts/local.conf without much success. The moreamp fonts stays the same even though I notice the change in my conky font size. 

The main reason I'm doing this is because of moreamp: http://www.astro.umontreal.ca/~belanger/main.gif
I don't really care about the fonts in firefox. They are not that bad.

Offline

#2 2005-11-04 05:40:08

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: Configuring fonts with gnome-control-center while using fvwm

I just installed gnome and it starts with the fonts selected in the gnome-control-center. I'll  need to forget about using gnome-control-center to configure my fonts in FVWM.

I'll give /etc/fonts/local.conf a more serious try.

Offline

#3 2005-11-04 19:50:13

iBertus
Member
From: Greenville, NC
Registered: 2004-11-04
Posts: 2,228

Re: Configuring fonts with gnome-control-center while using fvwm

Snowman wrote:

I just installed gnome and it starts with the fonts selected in the gnome-control-center. I'll  need to forget about using gnome-control-center to configure my fonts in FVWM.

I'll give /etc/fonts/local.conf a more serious try.

I think local.conf is the best way to go for configuring fonts. You can use gtk-chtheme to change your GTK+ theme and set a new font for everything, but you can't change rendering options. To make fonts look really good you have to set the DPI correctly in local.conf.

Offline

#4 2005-11-06 23:20:35

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: Configuring fonts with gnome-control-center while using fvwm

iBertus, thanks for your answer. smile

I finally made it work by setting dpi in local.conf:

  <match target="pattern">
      <edit name="dpi" mode="assign">
         <double>75</double>
      </edit>
   </match>

And adding

DisplaySize  347 260

to my monitor section in my xorg.conf.

Offline

#5 2005-11-07 23:37:18

JGC
Developer
Registered: 2003-12-03
Posts: 1,659

Re: Configuring fonts with gnome-control-center while using fvwm

What gnome-control-center actually does is firing up gnome-settings-daemon, which applies all these settings for you.

Offline

#6 2005-11-08 01:38:10

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: Configuring fonts with gnome-control-center while using fvwm

Thanks for the explanation. smile In fact, I did notice that it was modifying ~/.gconfd/saved_state. Probably, these changes were lost when logging out...

Offline

#7 2005-11-08 08:19:55

High|ander
Member
From: Skövde, Sweden
Registered: 2005-10-28
Posts: 188
Website

Re: Configuring fonts with gnome-control-center while using fvwm

you can also alter the .gtkrc-2.0 and then all the gtk-apps are modified. My .gtkrc-2.0 looks like this:

include "/home/highlander/.themes/Clearlooks-graphite/gtk-2.0/gtkrc"
gtk-font-name = "Bitstream Vera Sans 8"

When death smiles at you, all you can do is smile back!
Blog

Offline

Board footer

Powered by FluxBB