You are not logged in.

#1 2013-02-01 21:16:03

w201
Member
Registered: 2012-10-04
Posts: 243

[SOLVED] Need Help Configuring My URXVT Terminal in Awesome

Hi guys. Hope y'all are doing great.

I've been searching for three days pulling my hair out trying to figure out how to configure my urxvt terminal, and for the life of me, I cannot figure this out. I really have to say that I tried on this one.

So basically, nothing I try seems to have an effect on the terminal itself. Here's a few things that i've done so far:

1. created an .Xresrouces file on ~/. (I can post the contents of the file upon request.)
2. Configured my rc.lua file to spawn urxvt (which it does. At least I got that part correct)
3. configured my ~/.xinitrc by adding:
[[ -f ~/.Xresources ]] && xrdb -merge ~/.Xresources

Regardless, none of it seems to have any effect. Anything you need to know, please ask. Thanks

Last edited by w201 (2013-02-02 03:39:35)

Offline

#2 2013-02-01 21:40:49

skanky
Member
From: WAIS
Registered: 2009-10-23
Posts: 1,839

Re: [SOLVED] Need Help Configuring My URXVT Terminal in Awesome

Dunno about (2) but you will probably need to post both the .Xresources and .xinitrc files.


"...one cannot be angry when one looks at a penguin."  - John Ruskin
"Life in general is a bit shit, and so too is the internet. And that's all there is." - scepticisle

Offline

#3 2013-02-01 21:41:59

drcouzelis
Member
From: Connecticut, USA
Registered: 2009-11-09
Posts: 3,522
Website

Re: [SOLVED] Need Help Configuring My URXVT Terminal in Awesome

What settings are you trying to change? What's in your configuration file? Does it work if you instead use the (deprecated) ".Xdefaults" file?

Offline

#4 2013-02-01 21:47:21

w201
Member
Registered: 2012-10-04
Posts: 243

Re: [SOLVED] Need Help Configuring My URXVT Terminal in Awesome

Ok, here we go... My resources file is from a template I found online, so it's not ultimately how I want it to look.

.Xresources:

! Xresources file
! urxvt*termName:	rxvt-256color
urxvt*loginShell:	true
urxvt*scrollBar:	fale
urxvt*secondaryScroll:  true
urxvt*saveLines:	65535
urxvt*cursorBlinkL:	fale
urxvt*urgentOnBell:	true
!urxvt*override-redirect: fale
!urxvt*borderLess:	false
!urxvt*internalBorder:	0
!urxvt*externalBorder:  0

! Extensions
urxvt*perl-lib:		/usr/lib/urxvt/perl
urxvt*perl-ext-common:	default,matcher,searchable-scrollback
urxvt*urlLauncher:	/usr/bin/firefox
urxvt*matcher.button:	1

! Appearance
! - use a bitmap font
urxvt*font: 		-xos4-terminus-medium-*-*-*-12-*-*-*-*-*-*-*
urxvt*boldFont:		-xos4-terminus-bold-*-*-*-12-*-*-*-*-*-*-*		
! - use xft for drawing fonts
!urxvt*font:		xft:Terminus:8
! - cursor
urxvt*cursorColor:	#DCDCCC
! - pseudo transparency
urxvt*shading: 	50
urxvt*transparent:	true

! - color scheme

urxvt.background: 	#000000
urxvt.foreground: 	#EBEBFF
! black * red
!urxvt*color0:		#3f3f3f
urxvt*color0:		#000000
urxvt*color1:		#e01010
! green + yellow
urxvt*color2:		#00aa00
urxvt*color3:		#FFFF00
! blue + purple
urxvt*color4:		#112037
urxvt*color5:		#a020F0
! cyan + white
urxvt*color6:		#5B5BC7
urxvt*color7:		#FEFEFE
! bright black + bright red
urxvt*color8:		#6A6A6A
urxvt*color9:		#FF5555
! bright green + bright yellow
urxvt*color10:		#90EE90
urxvt*color11:		#FFFF2F
! bright blue + bright purple
urxvt*color12:		#5B5BC7
urxvt*color13:		#E628BA
! bright cyan + bright white
urxvt*color14:		#7D7DFB
urxvt*color15:		#FFFFFF

.Xinitrc:

#!/bin/sh
#
# ~/.xinitrc
#
# Executed by startx (run your window manager from here)

if [ -d /etc/X11/xinit/xinitrc.d ]; then
  for f in /etc/X11/xinit/xinitrc.d/*; do
    [ -x "$f" ] && . "$f"
  done
  unset f
fi

# exec gnome-session
# exec startkde
# exec startxfce4
# ...or the Window Manager of your choice
exec awesome
[[ -f ~/.Xresources ]] && xrdb -merge ~/.Xresources

Offline

#5 2013-02-01 21:49:19

skanky
Member
From: WAIS
Registered: 2009-10-23
Posts: 1,839

Re: [SOLVED] Need Help Configuring My URXVT Terminal in Awesome

Try moving the xrdb line to above the exec awesome line.


"...one cannot be angry when one looks at a penguin."  - John Ruskin
"Life in general is a bit shit, and so too is the internet. And that's all there is." - scepticisle

Offline

#6 2013-02-01 21:55:22

w201
Member
Registered: 2012-10-04
Posts: 243

Re: [SOLVED] Need Help Configuring My URXVT Terminal in Awesome

skanky wrote:

Try moving the xrdb line to above the exec awesome line.

I tried that and my terminal doesn't open, so I had to change it back.

drcouzelis, I haven't tried the .Xdefaults, but I guess if nothing else works I can give that a whirl?

Offline

#7 2013-02-01 22:02:11

skanky
Member
From: WAIS
Registered: 2009-10-23
Posts: 1,839

Re: [SOLVED] Need Help Configuring My URXVT Terminal in Awesome

w201 wrote:
skanky wrote:

Try moving the xrdb line to above the exec awesome line.

I tried that and my terminal doesn't open, so I had to change it back.

As it is, the xrdb line doesn't get executed until after awesome closes - eg the end of your session.


"...one cannot be angry when one looks at a penguin."  - John Ruskin
"Life in general is a bit shit, and so too is the internet. And that's all there is." - scepticisle

Offline

#8 2013-02-01 22:08:03

w201
Member
Registered: 2012-10-04
Posts: 243

Re: [SOLVED] Need Help Configuring My URXVT Terminal in Awesome

skanky wrote:
w201 wrote:
skanky wrote:

Try moving the xrdb line to above the exec awesome line.

I tried that and my terminal doesn't open, so I had to change it back.

As it is, the xrdb line doesn't get executed until after awesome closes - eg the end of your session.

Hmmm.... I see your point.

Does xrdb absoutely have to be before exec awesome?  Because I can change it again and if urxvt not opening is a seperate issue, then at least I can look for that.

Offline

#9 2013-02-01 22:14:32

the sad clown
Member
From: 192.168.0.X
Registered: 2011-03-20
Posts: 833

Re: [SOLVED] Need Help Configuring My URXVT Terminal in Awesome

More for my own edification than a solution to the op, what would happen if he changed the .xinitrc line for "exec awesome" to "exec awesome &"


I laugh, yet the joke is on me

Offline

#10 2013-02-01 22:14:34

skanky
Member
From: WAIS
Registered: 2009-10-23
Posts: 1,839

Re: [SOLVED] Need Help Configuring My URXVT Terminal in Awesome

w201 wrote:
skanky wrote:
w201 wrote:

I tried that and my terminal doesn't open, so I had to change it back.

As it is, the xrdb line doesn't get executed until after awesome closes - eg the end of your session.

Hmmm.... I see your point.

Does xrdb absoutely have to be before exec awesome?  Because I can change it again and if urxvt not opening is a seperate issue, then at least I can look for that.

Yes, that's the course, I think. It's the first line in my xinitrc. I use urxvt okay, but urxvtd:

urxvtd -q -f -o

In the .xinitrc between the xrdb and exec lines.

My command to open urxvt is:

urxvtc "$@"
if [ $? -eq 2 ]; then
    urxvtd -q -f -o
    urxvtc "$@"
fi

I think that's a red herring though, just using urxvt should work.


"...one cannot be angry when one looks at a penguin."  - John Ruskin
"Life in general is a bit shit, and so too is the internet. And that's all there is." - scepticisle

Offline

#11 2013-02-01 22:17:01

skanky
Member
From: WAIS
Registered: 2009-10-23
Posts: 1,839

Re: [SOLVED] Need Help Configuring My URXVT Terminal in Awesome


"...one cannot be angry when one looks at a penguin."  - John Ruskin
"Life in general is a bit shit, and so too is the internet. And that's all there is." - scepticisle

Offline

#12 2013-02-01 22:18:17

kaszak696
Member
Registered: 2009-05-26
Posts: 543

Re: [SOLVED] Need Help Configuring My URXVT Terminal in Awesome

You can just debug why urxvt refuses to launch, my idea:

  1. With .xinitrc as it is, launch awesome with working urxvt (not urxvtd!).

  2. Run the 'xrdb -merge ~/.Xresources' inside that opened urxvt.

  3. Try running urxvt from within opened urxvt, you'll see errors it spews.

  4. ...or just search the journal for these errors, they usually end up there.

To reset your xrdb settings inside a running terminal/WM, type 'xrdb -remove'.


'What can be asserted without evidence can also be dismissed without evidence.' - Christopher Hitchens
'There's no such thing as addiction, there's only things that you enjoy doing more than life.' - Doug Stanhope
GitHub Junkyard

Offline

#13 2013-02-01 22:20:38

2ManyDogs
Member
Registered: 2012-01-15
Posts: 1,706

Re: [SOLVED] Need Help Configuring My URXVT Terminal in Awesome

w201 wrote:
skanky wrote:

Try moving the xrdb line to above the exec awesome line.

I tried that and my terminal doesn't open, so I had to change it back.

Try it with an ampersand after the xrdb call (so it runs in the background).

(edit) -- never mind. the link skanky posted indicates it should work without needing to do this. You do definitely need to do everything in .xinitrc before the "exec" call -- this replaces the running process, so nothing after "exec" will run until your window manager closes.

You could just try "xrdb ~/.Xresources" -- you don't need that conditional code, and you don't need "merge"

Last edited by 2ManyDogs (2013-02-01 22:24:07)

Offline

#14 2013-02-01 22:22:32

doug piston
Member
From: Seattle
Registered: 2011-09-11
Posts: 387
Website

Re: [SOLVED] Need Help Configuring My URXVT Terminal in Awesome

Use the merge command before the 'exec' command. This is what I use

xrdb -merge ~/.Xresources &
exec awesome

Last edited by doug piston (2013-02-01 22:23:39)

Offline

#15 2013-02-01 22:24:39

w201
Member
Registered: 2012-10-04
Posts: 243

Re: [SOLVED] Need Help Configuring My URXVT Terminal in Awesome

the sad clown wrote:

More for my own edification than a solution to the op, what would happen if he changed the .xinitrc line for "exec awesome" to "exec awesome &"

If I do that, X11 doesn't starts up and terminates.

I see a few more suggestions here so let me try out some of these and I'll post back shortly...

Offline

#16 2013-02-01 22:28:57

skanky
Member
From: WAIS
Registered: 2009-10-23
Posts: 1,839

Re: [SOLVED] Need Help Configuring My URXVT Terminal in Awesome

w201 wrote:
the sad clown wrote:

More for my own edification than a solution to the op, what would happen if he changed the .xinitrc line for "exec awesome" to "exec awesome &"

If I do that, X11 doesn't starts up and terminates.

I see a few more suggestions here so let me try out some of these and I'll post back shortly...

You should also fix the typos in the .Xresources file.

You have a load of "fale"s in there, when they should be "false".


"...one cannot be angry when one looks at a penguin."  - John Ruskin
"Life in general is a bit shit, and so too is the internet. And that's all there is." - scepticisle

Offline

#17 2013-02-01 22:38:10

the sad clown
Member
From: 192.168.0.X
Registered: 2011-03-20
Posts: 833

Re: [SOLVED] Need Help Configuring My URXVT Terminal in Awesome

w201 wrote:
the sad clown wrote:

More for my own edification than a solution to the op, what would happen if he changed the .xinitrc line for "exec awesome" to "exec awesome &"

If I do that, X11 doesn't starts up and terminates.

I see a few more suggestions here so let me try out some of these and I'll post back shortly...

Well, I wasn't proposing as a solution so much as for my own curiousity.  I'm not that surprised that it just killed X.


I laugh, yet the joke is on me

Offline

#18 2013-02-01 22:38:39

w201
Member
Registered: 2012-10-04
Posts: 243

Re: [SOLVED] Need Help Configuring My URXVT Terminal in Awesome

skanky wrote:
w201 wrote:
the sad clown wrote:

More for my own edification than a solution to the op, what would happen if he changed the .xinitrc line for "exec awesome" to "exec awesome &"

If I do that, X11 doesn't starts up and terminates.

I see a few more suggestions here so let me try out some of these and I'll post back shortly...

You should also fix the typos in the .Xresources file.

You have a load of "fale"s in there, when they should be "false".


Wow, I just noticed that. I'll correct those errors... I tried a most of the suggestions but so far nothing has worked. I'm still trying a few things....bbs

Thanks for helping out guys!

Offline

#19 2013-02-01 22:44:09

skanky
Member
From: WAIS
Registered: 2009-10-23
Posts: 1,839

Re: [SOLVED] Need Help Configuring My URXVT Terminal in Awesome

Just for the record, kaszak696's steps would have thrown them up as issues, and if fixing "fale" doesn't solve it, I'd follow those to look for more.


"...one cannot be angry when one looks at a penguin."  - John Ruskin
"Life in general is a bit shit, and so too is the internet. And that's all there is." - scepticisle

Offline

#20 2013-02-01 22:46:52

w201
Member
Registered: 2012-10-04
Posts: 243

Re: [SOLVED] Need Help Configuring My URXVT Terminal in Awesome

skanky wrote:

Just for the record, kaszak696's steps would have thrown them up as issues, and if fixing "fale" doesn't solve it, I'd follow those to look for more.

I fixed those errors but it's still no-go. Kaszak696's suggestion is next....

Offline

#21 2013-02-01 22:51:40

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 19,329
Website

Re: [SOLVED] Need Help Configuring My URXVT Terminal in Awesome

This is why you should never just copy a config from the internet and expect it to behave in a uniform fashion.

Remove every line from .Xresources that you don't understand (like the login shell one), ensure that your wm start line is the last line in .xinitrc and
build it up from there...


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Online

#22 2013-02-01 22:57:36

skanky
Member
From: WAIS
Registered: 2009-10-23
Posts: 1,839

Re: [SOLVED] Need Help Configuring My URXVT Terminal in Awesome

Hmmm, okay looks like I was wrong (not the first or last time wink ), as I've just successfully applied the above Xresources file (typos and all) and upened urxvt.
Running

xrdb -query

Will show you the settings in use.


"...one cannot be angry when one looks at a penguin."  - John Ruskin
"Life in general is a bit shit, and so too is the internet. And that's all there is." - scepticisle

Offline

#23 2013-02-01 23:20:33

w201
Member
Registered: 2012-10-04
Posts: 243

Re: [SOLVED] Need Help Configuring My URXVT Terminal in Awesome

jasonwryan wrote:

This is why you should never just copy a config from the internet and expect it to behave in a uniform fashion.

Remove every line from .Xresources that you don't understand (like the login shell one), ensure that your wm start line is the last line in .xinitrc and
build it up from there...

I totally agree with you and under normal circumstances I would never run scripts or code that I copy and paste. but I copied this from a urxvt wiki page.... I know that's not an excuse, but I figured they would have some cred.

Hey skanky...this is where I'm at...

I completely cleaned out my .Xresources config...so it's a blank slate and my .Xinitrc config is the way it should be, and I got urxvt to run.

I'm getting somewhere... now I need to start with my .Xresources from the ground up, if anyone would care to throw me some known working configurations, nothing too fancy, so i can at least see if it'll take effect I would greatly appreciate it.

OH, and when I checked for errors xrdb was spitting out a bunch of junk...mostly it was a missing colon in almost every line of code....!!!

Last edited by w201 (2013-02-01 23:22:38)

Offline

#24 2013-02-02 02:16:10

anonymous_user
Member
Registered: 2009-08-28
Posts: 3,058

Re: [SOLVED] Need Help Configuring My URXVT Terminal in Awesome

Turning off the scrollbar is pretty simple to check:

URxvt.scrollBar: 		off

Also I don't know which wiki you check earlier but Arch wiki does have a page for rxvt:

https://wiki.archlinux.org/index.php/Rxvt

I would read it thoroughly and only apply settings you actually want.

Offline

#25 2013-02-02 03:06:54

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 14,190
Website

Re: [SOLVED] Need Help Configuring My URXVT Terminal in Awesome

I haven't caught up on this whole thread, but I didn't see anyone mentione case-sensitivity:

urxvt != URxvt.


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

Board footer

Powered by FluxBB