You are not logged in.

#1 2013-02-01 22:07:46

dlin
Member
From: Taipei,Taiwan
Registered: 2005-09-21
Posts: 264

[SOLVED] Building perl failed cannot load libperl.so

I'm trying build base packages on another arch (sh4).

Is there any tip about this build error?

yaourt -SAb perl
...
omit
...
http://archlinuxarm.org/developers/building-packages
ERROR: ld.so: object 'libfakeroot.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libfakeroot.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libfakeroot.so' from LD_PRELOAD cannot be preloaded: ignored.
==> Starting package()...
./perl: error while loading shared libraries: libperl.so: cannot open shared object file: No such file or directory
==> ERROR: A failure occurred in package().
    Aborting...
==> ERROR: Makepkg was unable to build perl.
==> Restart building perl ? [y/N]
==> -----------------------------
$ sudo find . -name libperl.so
./src/perl-5.16.2/libperl.so

temp solution
----------------------
added LD_LIBRARY_PATH in PKGBUILD of package()

Last edited by dlin (2013-02-02 05:01:39)


Running 4 ArchLinux including sh4twbox,server,notebook,desktop. my AUR packages, old project Arch on colinux,

Offline

Board footer

Powered by FluxBB