You are not logged in.

#26 2005-10-06 20:31:44

phunni
Member
From: Bristol, UK
Registered: 2003-08-13
Posts: 672

Re: ATI again...

I think the problem may be with permissions on /dev/dri/card0:

crw-rw----   1 root root 226, 0 2005-10-06 20:24 card0

Not sure how to fix it though - maybe I should set up a group, or perhaps one already exists...

Offline

#27 2005-10-06 20:43:35

nightfrost
Member
From: Sweden
Registered: 2005-04-16
Posts: 647

Re: ATI again...

as a temporary fix, to make sure that's it, you could just change the permission manually... and try it...

Offline

#28 2005-10-06 20:49:15

phunni
Member
From: Bristol, UK
Registered: 2003-08-13
Posts: 672

Re: ATI again...

Any chmoding I try and do won't stick when I restart X...

I think the fact that it works as root pretty much confirm this is it.  The question is, how do I fix the permissions in such a way that will stick beyond an X restart and a machine reboot...?

Offline

#29 2005-10-06 20:50:19

nightfrost
Member
From: Sweden
Registered: 2005-04-16
Posts: 647

Re: ATI again...

have you made sure you have the latest udev?

Offline

#30 2005-10-06 20:54:02

phunni
Member
From: Bristol, UK
Registered: 2003-08-13
Posts: 672

Re: ATI again...

I do have the latest version - but I'm fairly clueless on configing it...

Offline

#31 2005-10-06 20:59:18

nightfrost
Member
From: Sweden
Registered: 2005-04-16
Posts: 647

Re: ATI again...

Yeah, me too. But I remember havin similar problems at some point (with /dev/null, believe it or not!). Try this; just run udevstart as root and then check the permission to see if it's fixed... I remember it did the trick for me. If it works you can add it to /etc/rc.local.

Offline

#32 2005-10-06 21:08:36

phunni
Member
From: Bristol, UK
Registered: 2003-08-13
Posts: 672

Re: ATI again...

Fixed it - somehwere along the line of me twekaing the xorg.conf the

Section "DRI"
    Mode 0666
EndSection

section got commented out  :oops:

I now have almost 1500 FPS which will do!

Thanks everyone for all your help!

Offline

#33 2005-10-06 21:12:01

DarkPath
Member
Registered: 2004-11-15
Posts: 50

Re: ATI again...

Great to hear! Glad you finally solved your issue. I know how annoying rendering can be. wink

Offline

#34 2005-10-06 21:12:54

nightfrost
Member
From: Sweden
Registered: 2005-04-16
Posts: 647

Re: ATI again...

t's probably something really obvious that you've missed. One of those shit-how-could-I-miss-that kinda thing Smile

There you go smile   Glad it worked out for you!

Offline

#35 2005-10-08 23:33:43

drojid
Member
Registered: 2005-02-21
Posts: 13

Re: ATI again...

DarkPath, You mentioned that You had a similar issue with Your r9600 in Your laptop. May I ask how did You solve it?

My problem is that everything worked fine in my r9600 equipped notebook, until on 4th Oct I made the Big Arch Upgrade :-) and now 3D is not working.

First I thought that it's gcc4's fault and recompiled my 2.6.12-5 vanilla kernel (as I always do) manually, recompiled the 8.16.20 fglrx driver... but DRI is still not working. That's weird, because permissions are OK, X.org (6.8.2) claims that

(II) fglrx(0): DRIScreenInit done
(II) fglrx(0): Kernel Module Version Information:
(II) fglrx(0):     Name: fglrx
(II) fglrx(0):     Version: 8.16.20
(II) fglrx(0):     Date: Aug 16 2005
(II) fglrx(0):     Desc: ATI FireGL DRM kernel module
(II) fglrx(0): Kernel Module version matches driver.
(II) fglrx(0): Kernel Module Build Time Information:
(II) fglrx(0):     Build-Kernel UTS_RELEASE:        2.6.12.5
(II) fglrx(0):     Build-Kernel MODVERSIONS:        no
(II) fglrx(0):     Build-Kernel __SMP__:            no
(II) fglrx(0):     Build-Kernel PAGE_SIZE:          0x1000
(II) fglrx(0): [drm] register handle = 0xd7ef0000
(II) fglrx(0): [agp] Mode=0x1f000207 bridge: 0x1039/0x0646
(II) fglrx(0): [agp] AGP v1/2 disable mask 0x00000000
(II) fglrx(0): [agp] AGP v3 disable mask   0x00000000
(II) fglrx(0): [agp] enabling AGP with mode=0x1f000304
(II) fglrx(0): [agp] AGP protocol is enabled for graphics board. (cmd=0x1f000304)
(II) fglrx(0): [agp] graphics chipset has AGP v2.0
(II) fglrx(0): [drm] ringbuffer size = 0x00100000 bytes
(II) fglrx(0): [drm] DRM buffer queue setup: nbufs = 100 bufsize = 28672
(II) fglrx(0): [drm] texture shared area handle = 0xe1b01000
(II) fglrx(0): shared FSAAScale=1
(II) fglrx(0): DRI initialization successfull!

So I should have DRM, DRI, AGP, but glxinfo writes that

direct rendering: No

The only one suspicious thing is that when I ask for verbose debugging from libgl it says

libGL: XF86DRIGetClientDriverName: 8.16.20 fglrx (screen 0)
libGL: OpenDriver: trying /usr/X11R6/lib/modules/dri/fglrx_dri.so
drmOpenByBusid: Searching for BusID PCI:1:0:0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 4, (OK)
drmOpenByBusid: drmOpenMinor returns 4
drmOpenByBusid: drmGetBusid reports PCI:1:0:0
fglrx: libGL version undetermined - OpenGL module is using glapi fallback
...
display: :0  screen: 0
direct rendering: No

Does this glapi fallback mean fallback to Mesa? If so, why?

(]$ ls -al /usr/X11R6/lib/modules/dri/fglrx_dri.so
-rwxr-xr-x  1 root root 7931216 2005-08-16 18:13 /usr/X11R6/lib/modules/dri/fglrx_dri.so)

Guys, do You have any idea?

Offline

#36 2005-10-09 05:02:33

DarkPath
Member
Registered: 2004-11-15
Posts: 50

Re: ATI again...

drojid, this sounds almost exactly like the problem I had. What happens is that, for some reason, the fglrx module's libGL doesn't get installed right into the X.Org libraries... so when fglrx tries to load it's libGL, it actually tries to load the normal Mesa libGL and throws up that error.

What you need to do is mv or rename the Mesa libGL file before you install the fglrx drivers. Install the fglrx drivers... then, to be safe, you may want to redo the symlinks in the lib folder that point to libGL... make sure they're pointing to the one just installed by fglrx.

Hopefully, that should get your 3D accel working just fine. smile

Offline

#37 2005-10-09 11:37:15

drojid
Member
Registered: 2005-02-21
Posts: 13

Re: ATI again...

DarkPath, thanks fot Your help, almost everything is working again.
I completely removed Mesa as I don't think I'd need it at all, and nothing in my system required it. After replacing libGL, most applications are working as expected. Some don't, e.g. the Really Slick Screensaver package, but I'll try to recompile it, maybe it will help (or not, I don't really care smile ).

Thanks again,
drojid

Offline

#38 2005-10-09 20:42:47

DarkPath
Member
Registered: 2004-11-15
Posts: 50

Re: ATI again...

drojid wrote:

DarkPath, thanks fot Your help, almost everything is working again.

Awesome, great to hear! Glad to see people getting ATI's crazy drivers working...  tongue

Offline

#39 2005-11-07 16:09:34

matsche
Member
From: .at
Registered: 2004-04-27
Posts: 120

Re: ATI again...

maybe someone can help me:

17:06:05 matze@~ $ fgl_glxgears
Using GLX_SGIX_pbuffer
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  142 (GLX)
  Minor opcode of failed request:  5 (X_GLXMakeCurrent)
  Serial number of failed request:  32
  Current serial number in output stream:  32

i load in my rc.conf agpgart then radeon

my xorg.conf

Section "Device"
    Identifier  "ati"
    Driver      "radeon"
        # unsupported card
    #VideoRam    4096
    # Insert Clocks lines here if appropriate
EndSection

I got no comments in the DRI Section!


THX!!
cu matsche

Offline

#40 2005-11-08 09:56:52

sudman1
Member
From: Huntingdon, UK
Registered: 2005-02-18
Posts: 143

Re: ATI again...

try replacing

Driver      "radeon"

with

Driver      "fglrx"

to use the official ATI driver.


v/r
Suds

Offline

#41 2005-11-08 10:03:39

matsche
Member
From: .at
Registered: 2004-04-27
Posts: 120

Re: ATI again...

if i do that, X is a white blank screen! :-( sorry.


THX!!
cu matsche

Offline

Board footer

Powered by FluxBB