You are not logged in.

#376 2013-01-27 19:19:02

mityukov
Member
Registered: 2010-10-10
Posts: 66

Re: 3x+ battery life

Could you advise anything to add to the power{down,up} for the ATI cards owners (using proprietary Catalyst driver)?

Offline

#377 2013-01-28 01:49:55

taylorchu
Member
Registered: 2010-08-09
Posts: 405

Re: 3x+ battery life

@kaustic
I don't think powerdown is too bloated. It grows from a single bash script because it needs a library to maintain code readablity.
I know some people do not like powerdown takes over pm-utils but as far as I know powerdown should already have all rules anyone will need for powersaving.

@mityukov
catalyst has automatic pm; you dont need powerdown in this case

@everyone
* fix usb autosuspend
* add open source ati pm support


"After you do enough distro research, you will choose Arch."

Offline

#378 2013-01-28 11:45:48

Earnestly
Member
Registered: 2011-08-18
Posts: 804

Re: 3x+ battery life

A few simple udev rules are a much better solution. For example: https://github.com/vodik/powersave

Also, pm-utils is garbage and needs to die tongue

Offline

#379 2013-01-28 15:10:46

dartfira
Member
Registered: 2010-08-23
Posts: 63

Re: 3x+ battery life

@taylorchu are you updating only the git files or also the AUR script?

Offline

#380 2013-01-29 15:51:30

nierro
Member
From: Milan, Italy
Registered: 2011-09-02
Posts: 808

Re: 3x+ battery life

@taylorchu: i see you're still using powersave cpu governor in your script. As far as I know, ondemand is the best (or at least, a tweaked conservative can be better, but how much more?).
Please, consider this: with powersave governor, you lock your cpu at lowest speed; ie, without scaling your cpu (as with ondemand default governor), it takes much more time to, for example, compile something, or open a browser, or doing everything. More time cpu is used, less time idles, more power usage. There are tests somewhere on internet whose result is that powersave is not a "powersave" governor.
Please, consider that, and change it! Leave ondemand, as kernel default.
Hope this can help smile

EDIT: here it is: http://www.codon.org.uk/~mjg59/power/go … tices.html .

Last edited by nierro (2013-01-30 10:01:41)

Offline

#381 2013-01-30 15:07:34

orschiro
Member
Registered: 2009-06-04
Posts: 2,136
Website

Re: 3x+ battery life

As for now does Powerdown provide any settings which are not covered by TLP?

https://wiki.archlinux.org/index.php/TLP

Regards

Robert

Offline

#382 2013-01-30 15:14:12

jakob
Member
From: Berlin
Registered: 2005-10-27
Posts: 419

Re: 3x+ battery life

orschiro wrote:

As for now does Powerdown provide any settings which are not covered by TLP?

https://wiki.archlinux.org/index.php/TLP

Due to intentions of the TLP developer, it doesn't affect display brightness…

Offline

#383 2013-01-30 15:18:02

orschiro
Member
Registered: 2009-06-04
Posts: 2,136
Website

Re: 3x+ battery life

Jakob,

Is that the only difference?

If so, brightness can be easly regulated by a single separate Udev rule.

Offline

#384 2013-01-30 15:25:03

jakob
Member
From: Berlin
Registered: 2005-10-27
Posts: 419

Re: 3x+ battery life

orschiro wrote:

Jakob,

Is that the only difference?

If so, brightness can be easly regulated by a single separate Udev rule.

I don't know, it's just a very obvious one as screen brightness doesn't change when using TLP… yeah, I haven't checked out the github repo with the udev rules on that…

Offline

#385 2013-02-01 11:02:24

mityukov
Member
Registered: 2010-10-10
Posts: 66

Re: 3x+ battery life

Wanted to add the following to the end of powerdown:

...
# Suspend ktorrent
qdbus org.ktorrent.ktorrent /core setSuspended true

, but got this error message:

Could not connect to D-Bus server: org.freedesktop.DBus.Error.Spawn.ExecFailed: /usr/bin/dbus-launch terminated abnormally with the following error: No protocol specified
Autolaunch error: X11 initialization failed.

(when running the same command under the user, it works)


Could anyone help me to implement this behavior (to suspend KTorrent when AC is unplugged)?

Offline

#386 2013-02-01 11:52:11

nierro
Member
From: Milan, Italy
Registered: 2011-09-02
Posts: 808

Re: 3x+ battery life

I guess it's because you need to lauch that from your user. Try

su yourusername -c "qdbus org.ktorrent.ktorrent /core setSuspended true"

If it won't work, read here: https://wiki.archlinux.org/index.php/Pm … or_suspend . Read carefully the first script, then you'll know what to do smile

Last edited by nierro (2013-02-01 11:56:01)

Offline

#387 2013-02-02 03:36:13

n125
Member
Registered: 2011-12-30
Posts: 38

Re: 3x+ battery life

I've got a small problem that first appeared a few months ago. I can't remember if it started happening after an update. Basically, when I unplug the AC powerdown runs as expected, but when I plug the AC back in, nothing happens. A lock file in /tmp/ prevents powerup from running. I have to manually delete this file and run powerup myself to restore performance settings.

This is the output when I try running powerup manually (or powernow) without deleting the lock file first.

$ sudo powerup
cannot acquire lock: /tmp/powerdown.lock

This only seems to happen when going from battery to AC.

powerdown version 20121014-1. None of scripts in the package have been modified.

Offline

#388 2013-02-02 11:57:07

taylorchu
Member
Registered: 2010-08-09
Posts: 405

Re: 3x+ battery life

@n125
thats a long time ago. please update.
I think powerdown will automatically remove the lock after it is completed.


"After you do enough distro research, you will choose Arch."

Offline

#389 2013-02-02 12:31:36

n125
Member
Registered: 2011-12-30
Posts: 38

Re: 3x+ battery life

Yeah, reinstalling pulled a newer version from Git and that fixed it. I'm sorry for the trouble. Pacman hadn't prompted me to update powerdown in a very long time so I thought I was running the latest version.

Last edited by n125 (2013-02-02 12:31:46)

Offline

#390 2013-02-02 12:32:40

Unia
Member
From: The Netherlands
Registered: 2010-03-30
Posts: 2,471
Website

Re: 3x+ battery life

n125 wrote:

Yeah, reinstalling pulled a newer version from Git and that fixed it. I'm sorry for the trouble. Pacman hadn't prompted me to update powerdown in a very long time so I thought I was running the latest version.

Pacman will not ever notify you of AUR package that are out-of-date. Those you will have to check yourself, or with a wrapper like yaourt or packer.


If you can't sit by a cozy fire with your code in hand enjoying its simplicity and clarity, it needs more work. --Carlos Torres

Offline

#391 2013-02-06 21:14:35

dura
Member
From: interzone
Registered: 2013-01-18
Posts: 41

Re: 3x+ battery life

Thanks taylorchu. I have been slightly disappointed with power consumption since (uneccessary reference) moving from Debian. Complete with some udev rules, kernel parameters, and this, I have got watts down to a reasonable level (Powertop reads 3.11w baseline; powernow is reading about 7-8 being used). Let them trees grow, man.

Offline

#392 2013-02-07 00:23:04

dura
Member
From: interzone
Registered: 2013-01-18
Posts: 41

Re: 3x+ battery life

Another thing I've just found very handy is thinkfan. On my x121e my fan has always run constantly. Forcing thinkpad_acpi and then running thinkfan brings it under control. Very useful. Not really the thread for it, but seeing as this is a good tip (for myself at least...), anyone have any idea how I would go about adding thinkpad_acpi to run from boot? Just an option in modprobe.d ? (p.s. I'm a researcher so please excuse my ignorant, and innocent, hijacking of this thread).

Offline

#393 2013-02-07 00:29:11

Unia
Member
From: The Netherlands
Registered: 2010-03-30
Posts: 2,471
Website

Re: 3x+ battery life

If it's just a module, then yes, modprobe.d is the way to go.

EDIT: see https://wiki.archlinux.org/index.php/Modprobe.d#Loading

Last edited by Unia (2013-02-07 00:34:08)


If you can't sit by a cozy fire with your code in hand enjoying its simplicity and clarity, it needs more work. --Carlos Torres

Offline

#394 2013-02-07 09:02:04

dura
Member
From: interzone
Registered: 2013-01-18
Posts: 41

Re: 3x+ battery life

Thanks unia.

Some info:

taGRwNw

Last edited by dura (2013-02-07 09:27:00)

Offline

#395 2013-02-07 10:09:19

kozaki
Member
From: London >. < Paris
Registered: 2005-06-13
Posts: 638
Website

Re: 3x+ battery life

Thanks to powerdown I got my 2 years old Atom powered netbook's consumption down to 6.9-8.5 W. Tested the 3-cells battery life up to 6-7 hours (from 4-5 hours max till now)
The device is a Dell Mini Inspiron that serves files through torrent, occasionnaly synchronize (sshfs), is a proxy relay and music playing.

[powerdown] BAT1 using 8.272 watts
Battery 0: Discharging, 96%, 06:20:50 remaining

 :: Detail
 -> /proc/sys/kernel/nmi_watchdog: 0
 -> /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor: ondemand
 -> /sys/devices/system/cpu/cpu1/cpufreq/scaling_governor: ondemand
 -> /sys/module/pcie_aspm/parameters/policy: default performance [powersave] 
 -> /proc/sys/vm/laptop_mode: 5
 -> /proc/sys/vm/dirty_ratio: 90
 -> /proc/sys/vm/dirty_background_ratio: 1
 -> /proc/sys/vm/dirty_expire_centisecs: 60000
 -> /proc/sys/vm/dirty_writeback_centisecs: 60000
 -> /dev/sda5 readahead: 4096
 -> /dev/sda9 readahead: 4096
 -> /dev/sda3 readahead: 4096
 -> /dev/sda10 readahead: 4096
 -> /dev/sda8 readahead: 4096
 -> /sys/class/scsi_host/host0/link_power_management_policy: min_power
 -> /sys/class/scsi_host/host1/link_power_management_policy: min_power
 -> /sys/class/scsi_host/host2/link_power_management_policy: min_power
 -> /sys/class/scsi_host/host3/link_power_management_policy: min_power
 -> /sys/module/snd_hda_intel/parameters/power_save: 1
 -> /sys/module/snd_hda_intel/parameters/power_save_controller: Y
 -> /sys/class/backlight/acpi_video0/brightness: 0
 -> /sys/module/i915/parameters/i915_enable_rc6: 1
 -> wlan0 Power save: on

Note that whether i put the disc at 127 or 254, i never hear it spin down and up (like it does with hdparm -y), and hdparm -C /dev/sd? consistently prints:

/dev/sda:
 drive state is:  active/idle

Here's the disc activity for the last couple of days:
# iostat -m /dev/sda

Linux 3.7.5-2-ck      07/02/2013      _i686_  (2 CPU)

avg-cpu:  %user   %nice %system %iowait  %steal   %idle
           0,35    0,00   99,38    0,00    0,00    0,27

Device:            tps    MB_read/s    MB_wrtn/s    MB_read    MB_wrtn
sda               1,68         0,24         0,01      68846       2637

I just let disc spin down at 254 for now. I bet this is no issue for (torrent) uploading at 120 KB/sec max. But wouldn't setting it to more than 127 be counter productive as soon as it needs to write often.
Please which setting would you set on the disc(s) for file sharing and sync through rsync?
rtorrent used to let you define send,receive buffer size, which is not the case anymore.

Edit: typos in hdparm -B values.

Last edited by kozaki (2013-02-07 12:43:28)


Seeded week #28: Arch 25 gig (stock 12, Talking 1, Anywhere 11, Apricity 1)
Desktop @3.30GHz 8 gig RAM, Arch linux-ck
laptop1 Atom 2 gig RAM, Arch linux stock i686 (5+H battery smile) & 2: ARM Tegra K1 4 gig RAM, ChrOS
Atom Z520 2 gig RAM, OMV (Debian 7) kernel 3.16 bpo on SDHC | PGP Key: 0xFF0157D9

Offline

#396 2013-02-07 13:52:27

eruditorum
Member
Registered: 2012-11-12
Posts: 130

Re: 3x+ battery life

I always set disk with "hdparm -B 254". Plus "hdparm -S 0" when on AC or "hdparm -S 6" when on battery.

Advantages are that heads won't park too often anymore (I heard clicks from HDD before and now it is gone).
With "-S 0" spindown is disabled, with "-S 6" it must do spindown after 30 seconds timeout of inactivity (according to "man hdparm"), but I don't know why HDD on my system won't respect this setting - it does spindown but amount of time after which this happens is totally unknown to me (don't know how to measure it): from 5 to 10 minutes, or I really don't know.

Last edited by eruditorum (2013-02-07 13:53:51)

Offline

#397 2013-02-09 01:34:10

kozaki
Member
From: London >. < Paris
Registered: 2005-06-13
Posts: 638
Website

Re: 3x+ battery life

Thanks for sharing eruditorum.
What kind of tasks is your system handling?

torrent uploading and tcp relay are really putting nothing on the HDD compared to web server database. Reason I'm checking to make the disks use their standby feature, even on AC. And the netbook sometimes is used on the move.
Now I better check syslog and systemd journal features, and maybe compile rtorrent if it can give me the hand back on its   send|receive buffer size options.

btw, i checked the (much) more powerfull Core i3-based machine consumption while ~idle, and it is as low as 19 W. I mean with a 450 W power supply, 1 ssd, 1 hdd and more :-O Wonder how low juice it'd take with powerdown!
CORRECTION: system idle takes 30-33 W (have somehow read the Amp last night haha)

Last edited by kozaki (2013-02-09 11:19:41)


Seeded week #28: Arch 25 gig (stock 12, Talking 1, Anywhere 11, Apricity 1)
Desktop @3.30GHz 8 gig RAM, Arch linux-ck
laptop1 Atom 2 gig RAM, Arch linux stock i686 (5+H battery smile) & 2: ARM Tegra K1 4 gig RAM, ChrOS
Atom Z520 2 gig RAM, OMV (Debian 7) kernel 3.16 bpo on SDHC | PGP Key: 0xFF0157D9

Offline

#398 2013-02-09 11:31:39

kozaki
Member
From: London >. < Paris
Registered: 2005-06-13
Posts: 638
Website

Re: 3x+ battery life

taylorchu wrote:
graysky wrote:

@op- Some of your powersaving tweaks causes both touchpads and usb mice to stop responding.  Suggest you update removing them.

@graysky
usb does not stop responding. The are in autosuspend once not used for 1 sec. click right or left button to start it again.
to disable powersave, replugin the usb mouse.

taylorshu, I gave powerdown a try on the Core i3 desktop a moment ago, but the PS2 keyboard and USB mice stopped responding as soon as I started powerdown.
Tapping on the keyboard, moving, left/right clickin the mice and unplugging/replugging them didn't help as in fact the system freezed (I could tell from the freezed i3-wm clock) :-/

févr. 09 11:37:43 XXX sudo[27254]: kozaki : TTY=pts/2 ; PWD=/tmp/yaourt-tmp-kozaki/aur-powerdown ; USER=root ; C
févr. 09 11:37:43 XXX sudo[27254]: pam_unix(sudo:session): session opened for user root by (uid=0)
févr. 09 11:37:48 XXX sudo[27254]: pam_unix(sudo:session): session closed for user root
févr. 09 11:38:13 XXX kernel: EXT4-fs (sda2): re-mounted. Opts: (null)
-- Reboot --
févr. 09 11:44:46 XXX systemd-journal[175]: Allowing runtime journal files to grow to 182.5M.
févr. 09 11:44:46 XXX kernel: Initializing cgroup subsys cpuset

hmmm, that's all journalctl --since="DATE TIME" says.


Seeded week #28: Arch 25 gig (stock 12, Talking 1, Anywhere 11, Apricity 1)
Desktop @3.30GHz 8 gig RAM, Arch linux-ck
laptop1 Atom 2 gig RAM, Arch linux stock i686 (5+H battery smile) & 2: ARM Tegra K1 4 gig RAM, ChrOS
Atom Z520 2 gig RAM, OMV (Debian 7) kernel 3.16 bpo on SDHC | PGP Key: 0xFF0157D9

Offline

#399 2013-02-09 11:36:31

nierro
Member
From: Milan, Italy
Registered: 2011-09-02
Posts: 808

Re: 3x+ battery life

@kozaki: change the powerdown script commenting out here:

# usb autosuspend
for i in /sys/bus/usb/devices/*/power/autosuspend; do opt "$i" 10; done
usb_powersave

. Reboot and see if you have other problems.

@taylorchu: i see you finally set ondemand governor. Since it is the default governor, you can remove these lines from powerdown and powerup (since kernel 3.4 correct cpufreq driver is autoloaded:

Note: As of kernel 3.4; the native cpu module is loaded automatically

-> archwiki)

Offline

#400 2013-02-09 17:38:06

dura
Member
From: interzone
Registered: 2013-01-18
Posts: 41

Re: 3x+ battery life

taylorshu, I gave powerdown a try on the Core i3 desktop a moment ago, but the PS2 keyboard and USB mice stopped responding as soon as I started powerdown.
Tapping on the keyboard, moving, left/right clickin the mice and unplugging/replugging them didn't help as in fact the system freezed (I could tell from the freezed i3-wm clock) :-/

You need to change the delay for switching off usb periperals in the powerdown config file. See earlier in this thread for more info I think.

Offline

Board footer

Powered by FluxBB