You are not logged in.

#1 2013-02-03 06:10:24

kevdog
Member
Registered: 2013-01-26
Posts: 46

[SOLVED] Where did the arrows on the scrollbars go?

I'm currently using Cinnamon (Gnome 3) with the default Adwaita theme.  It's the base install that I haven't customized anything to.

One of my first problems was the lack of the up and down arrows on the top and bottom of the scrollbar -- ie like in Firefox and Gnome Terminal

I was able to add the arrows within Firefox by modification of the /usr/share/themes/Adwaita/gtk-2.0/gtkrc file and specifically changing the sections:
    GtkScrollbar::has-backward-stepper        = 1 
    GtkScrollbar::has-forward-stepper        = 1

Although this solved my lack of arrows with Firefox, I still don't have any up/down arrows in programs like gnome shell and within the file manager.  Is there any suggestion on where I can make a modification to add these?  Gnome Tweak Tool didn't really help.

Last edited by kevdog (2013-02-03 14:59:40)

Offline

#2 2013-02-03 07:15:18

Stebalien
Member
Registered: 2010-04-27
Posts: 1,227
Website

Re: [SOLVED] Where did the arrows on the scrollbars go?

Try appending the following to /usr/share/themes/Adwaita/gtk-3.0/gtk.css:

.scrollbar {
  -GtkScrollbar-has-forward-stepper: true;
  -GtkScrollbar-has-backward-stepper: true;
}

Steven [ web : git ]
GPG:  327B 20CE 21EA 68CF A7748675 7C92 3221 5899 410C
Do not email: honeypot@stebalien.com

Offline

#3 2013-02-03 14:55:55

kevdog
Member
Registered: 2013-01-26
Posts: 46

Re: [SOLVED] Where did the arrows on the scrollbars go?

Thanks a ton for that helpful hint.  What threw me off was that I had nothing in the gtk-3.0 folder. 

I ended up putting the following in ~/.config/gtk-3.0/gtk.css
.scrollbar {
-GtkScrollbar-has-backward-stepper: 1;
-GtkScrollbar-has-forward-stepper: 1;
-GtkRange-slider-width: 15;
-GtkRange-stepper-size: 20;
}

Offline

#4 2013-03-07 15:48:46

chanslor
Member
Registered: 2013-03-07
Posts: 1

Re: [SOLVED] Where did the arrows on the scrollbars go?

I had been modifying the global /usr setting.
This is the best solution I have found - in the users home directory!

Pick up your changes without logging out:

Close terminal window
Hit ALT-F2
type restart
hit enter


chanslor

Last edited by chanslor (2013-10-23 03:15:45)

Offline

Board footer

Powered by FluxBB