You are not logged in.

#1 2013-02-03 10:21:05

bergonzini
Member
From: Barcelona
Registered: 2012-02-06
Posts: 6
Website

Conflict error on Pacman -Syu

When i update system to 3.7.4-1 i have a lot of conflict error like this

(79/79) verificando conflictos entre archivos                               
error: error al realizar la transacción (archivos en conflicto)
linux-api-headers: /usr/include/asm-generic/auxvec.h existe en el sistema de archivos
linux-api-headers: /usr/include/asm-generic/bitsperlong.h existe en el sistema de archivos
linux-api-headers: /usr/include/asm-generic/errno-base.h existe en el sistema de archivos
linux-api-headers: /usr/include/asm-generic/errno.h existe en el sistema de archivos
linux-api-headers: /usr/include/asm/a.out.h existe en el sistema de archivos
linux-api-headers: /usr/include/asm/auxvec.h existe en el sistema de archivos
linux-api-headers: /usr/include/asm/bitsperlong.h existe en el sistema de archivos
linux-api-headers: /usr/include/asm/boot.h existe en el sistema de archivos

How i can fix this conflict files?


@Bergonzini | 0x1685F522

Offline

#2 2013-02-03 11:31:36

gs93
Member
Registered: 2012-10-19
Posts: 16

Re: Conflict error on Pacman -Syu

Have you read I get an error when updating: "file exists in filesystem"! (I guess it's the same error, I don't speak spanish)?

Offline

#3 2013-02-03 12:08:20

bergonzini
Member
From: Barcelona
Registered: 2012-02-06
Posts: 6
Website

Re: Conflict error on Pacman -Syu

Thank you for answer gs93

Yes, it's the same error. When i try to install the new linux-3.7.5-1  linux-api-headers-3.7.4-1  linux-headers-3.7.5-1 i get this error. I'd rather wait out the kernel 3.7.6 before using --force or delete those files


@Bergonzini | 0x1685F522

Offline

#4 2013-02-03 15:26:55

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,205

Re: Conflict error on Pacman -Syu

I have linux 3.7.5.1 , linux-headers 3.7.5.1 and linux-api-headers 3.7.4-1 and no problems.

what is the output of

pacman -Qo /usr/include/asm-generic/auxvec.h

?


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#5 2013-02-03 17:14:08

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 18,524
Website

Re: Conflict error on Pacman -Syu

bergonzini wrote:

I'd rather wait out the kernel 3.7.6 before using --force or delete those files

Neither of those strategies will fix your issue: follow the instructions in the link provided...


Moving to Newbie Corner.


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

Board footer

Powered by FluxBB