You are not logged in.

#1 2013-02-04 08:35:33

Registered: 2011-12-29
Posts: 12

Video Acceleration with Virtualbox

(Note: This is a seperate approach from my other post so I'm keeping the discussions on them seperate)

I have a fresh Arch install running as a guest in the latest version of Virtualbox.  I'm using Gnome-Shell as the DE.

I have the virtualbox guest utils installed and the vbox* modules installed and running as per the wiki.

However, the graphics perfromance is *terrible*  There is about a second or two delay between typing and showing and I seem to be getting about a 1 second update rate.

I think that the vboxvideo is not working quite right because when I do a

glxinfo | grep OpenGL

i get

vOpenGL Warning: Failed to connect to host. Make sure 3D acceleration is enabled for this VM.
libGL error: failed to load driver: 
libGL error: Try again with LIBGL_DEBUG=verbose for more details.
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 0x302)
OpenGL version string: 2.1 Mesa 9.0.2
OpenGL shading language version string: 1.20
OpenGL extensions:

I have 3d acceleration  enabled on the virtualbox.


#2 2013-02-04 09:02:37

From: Romania
Registered: 2009-08-23
Posts: 2,273

Re: Video Acceleration with Virtualbox

Do you have the Guest Additions installed?

Try bumping up the video memory because the default is 12 MB, I think.

"How to Succeed with Linux"

I have made a personal commitment not to reply in topics that start with a lowercase letter. Proper grammar and punctuation is a sign of respect, and if you do not show any, you will NOT receive any help (at least not from me).


#3 2013-02-04 20:19:19

Registered: 2011-12-29
Posts: 12

Re: Video Acceleration with Virtualbox

Video memory is set to 128 mb. 

I have the guest additions installed from the sources in pacman not the sources in provided by virtualbox.


Board footer

Powered by FluxBB