You are not logged in.

#1 2010-03-22 19:49:38

Garret
Member
From: Palermo, Italy
Registered: 2006-07-09
Posts: 168
Website

Remove the tearing effect on nvidia cards without recurring to Compiz

On my desktop (with nvidia proprietary driver) the only way to remove the general tearing effect is by enabling compiz.
I would find a way where I don't need Compiz.

Enabling the "sync to VBlank" option on compiz-settings-manager resolves my issue.
compizconfigsettingsman.png

I don't understand why if I have checked the two "Sync To VBlank" boxes on nvidia-settings app it isn't enough.
nvidiaxserversettings25.png

Offline

#2 2010-05-30 10:50:23

lastchancetosee
Member
From: Berlin
Registered: 2009-02-19
Posts: 118

Re: Remove the tearing effect on nvidia cards without recurring to Compiz

Same problem here. Does anyone know what causes this? Or how to go about finding the cause?


Video without a compmgr is fine.
Video with Compiz is fine.
Video with xcompmgr and cairo-compmgr tears, regardless of output driver (vdpau, gl, xv etc), video player, driver settings (Sync to VBlank, TripleBuffering ...). The refresh rate in cairo-compmgr is set to the right value, but to no avail.

I haven't tried gnome or xfce compositing, but I hear that they have the same problem. I also hear that Compiz used to have this problem, so some sort of solution seems to exist.

(Yes I know this thread is old & ignored, but there has to be some sort of idea what the problem is with other composition managers besides compiz)


My ship don't crash! She crashes, you crashed her!

Offline

#3 2013-02-03 21:00:27

PLANTROON
Member
From: Slovakia
Registered: 2012-08-08
Posts: 61

Re: Remove the tearing effect on nvidia cards without recurring to Compiz

old thread ... I'm having the same problem in 2012 ... just bought GT 520 card smile

Offline

#4 2013-02-04 14:37:40

David Batson
Member
Registered: 2011-10-13
Posts: 640

Re: Remove the tearing effect on nvidia cards without recurring to Compiz

I was having a tearing issue in Bodhi and read a post this morning that solved the issue for me (in VLC anyway).

Turn off compositing and choose GL video output in VLC.  FTR I was using Enlightenment's compositor in Bodhi.

http://askubuntu.com/questions/77552/te … -10-amd-64

Offline

#5 2013-02-10 22:42:15

PLANTROON
Member
From: Slovakia
Registered: 2012-08-08
Posts: 61

Re: Remove the tearing effect on nvidia cards without recurring to Compiz

I need compositing, cant disable composite extension lol

Offline

#6 2013-02-10 23:05:44

Gusar
Member
Registered: 2009-08-25
Posts: 3,409

Re: Remove the tearing effect on nvidia cards without recurring to Compiz

What exactly is "same problem"? The first post is confusing as hell, I can't figure out what it's actually saying (it talks about removing tearing without compiz, but then it shows compiz settings).

Where exactly do you see tearing, and which compositor are you using?

Offline

#7 2013-02-11 12:13:04

David Batson
Member
Registered: 2011-10-13
Posts: 640

Re: Remove the tearing effect on nvidia cards without recurring to Compiz

Tearing when watching videos, such as those on youtube.  When the motion gets fast, you see horizontal breaks appear momentarily, usually every few seconds.  I've seen this in my browser while watching youtube and in vlc watching videos I had downloaded.

* When using Compiz, no problem with video tearing with v-sync enabled.
* When using Fedora 18 Gnome (with clutter/mutter), no problem with video tearing.  Older versions require a clutter environment variable to be set.
* When using Bodhi Enlightenment (with evas), have to disable compositor and chose OpenGL video output.

Bug report below describes the problem in more detail.
https://bugs.freedesktop.org/show_bug.cgi?id=37686

In the comment below, the user links to a couple of videos where this problem can occur.
https://bugs.freedesktop.org/show_bug.cgi?id=37686#c13

Offline

#8 2013-02-11 12:56:08

Gusar
Member
Registered: 2009-08-25
Posts: 3,409

Re: Remove the tearing effect on nvidia cards without recurring to Compiz

Does Enlightenment's compositor use xrender or opengl? If it uses xrender, it's impossible to not have tearing, because xrender doesn't provide vsync.

As for flash... well, it's flash. Though in theory it shouldn't have tearing because it uses VDPAU. Oh, I see you don't have nvidia graphics. You should've mentioned that. That's a whole different thing then. Modern hardware is designed with a compositor in mind, so getting it to not tear without one is tricky.

Last edited by Gusar (2013-02-11 12:57:29)

Offline

#9 2013-02-11 13:13:54

Grinch
Member
Registered: 2010-11-07
Posts: 265

Re: Remove the tearing effect on nvidia cards without recurring to Compiz

For me this is fixed by using compton (an updated version of xcompmgr) with the '--vsync drm' option. Atleast I can't detect any tearing when using this option and watching video in mplayer. Also I'm using the Nouveau driver.

Offline

#10 2013-02-11 20:11:54

David Batson
Member
Registered: 2011-10-13
Posts: 640

Re: Remove the tearing effect on nvidia cards without recurring to Compiz

I take back what I said about Bodhi Enlightenment (17).  I found there is a setting for the compositor to enable v-sync (was already set), and a second setting to use OpenGL rendering (was not set).  Instead of OpenGL rendering it was using Software rendering.  [I've only had Bodhi Enlightenment installed a few days - still setting up everything.]

With v-sync enabled and OpenGL rendering enabled, my videos are now tear free.

Offline

Board footer

Powered by FluxBB