You are not logged in.

#1 2013-01-17 23:27:51

rhoit
Member
From: 977
Registered: 2012-07-05
Posts: 62
Website

[SOLVED] Hide drives & bind folder from nautilus

I have trying to hide some of my drives from nautilus side-bar for long time after i moved to arch.

i had been following the post 124445 but /etc/udev/rules.d is not working for me!

I'm using
# Window Manager: Compiz
# Desktop Environment: Xfce
# File Browser: Nautilus

EDITED:

Binded Folder problem detail in post #9

Last edited by rhoit (2013-02-04 19:42:41)

Offline

#2 2013-01-18 03:56:28

murb
Member
Registered: 2013-01-14
Posts: 7

Re: [SOLVED] Hide drives & bind folder from nautilus

If your drives are mounted under /media try mounting them to another path.
I remember doing this in Ubuntu. Never tried with Arch tho.

Offline

#3 2013-01-18 04:05:43

rhoit
Member
From: 977
Registered: 2012-07-05
Posts: 62
Website

Re: [SOLVED] Hide drives & bind folder from nautilus

yup! you are correct but i can't keep everything in /media or /mnt
but i got binded folders and stuff! which also keep on showing in nautilus

[rho@i7520 ~]$ lsblk 
NAME    MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda       8:0    0 931.5G  0 disk 
├─sda1    8:1    0     2M  0 part 
├─sda2    8:2    0    98M  0 part /boot
├─sda3    8:3    0    15G  0 part /
├─sda4    8:4    0    10G  0 part /var
├─sda5    8:5    0    50G  0 part /home
├─sda6    8:6    0    20G  0 part /mnt/Core
├─sda7    8:7    0    30G  0 part /mnt/elib
├─sda8    8:8    0    50G  0 part /home/rho/Music
├─sda9    8:9    0   250G  0 part 
├─sda10   8:10   0   250G  0 part /media/Dump
├─sda11   8:11   0   100G  0 part 
├─sda12   8:12   0   100G  0 part 
└─sda13   8:13   0   6.4G  0 part [SWAP]
sr0      11:0    1  1024M  0 rom  

[rho@i7520 ~]$ findmnt -o TARGET,SOURCE -t ext4
TARGET              SOURCE
/                   /dev/sda3
/boot               /dev/sda2
/var                /dev/sda4
/media/Dump         /dev/sda10
/home               /dev/sda5
/home/rho/Downloads /dev/sda10[/downloads]
/mnt/Core           /dev/sda6
/home/rho/Music     /dev/sda8
/mnt/elib           /dev/sda7

Offline

#4 2013-01-18 05:38:25

anonymous_user
Member
Registered: 2009-08-28
Posts: 3,058

Re: [SOLVED] Hide drives & bind folder from nautilus

For the udev rules, try using UDISKS_IGNORE instead of UDISKS_PRESENTATION_HIDE.

Offline

#5 2013-01-18 05:49:38

rhoit
Member
From: 977
Registered: 2012-07-05
Posts: 62
Website

Re: [SOLVED] Hide drives & bind folder from nautilus

anonymous_user wrote:

For the udev rules, try using UDISKS_IGNORE instead of UDISKS_PRESENTATION_HIDE.

it didn't work!

here is my rule

[rho@i7520 ~]$ cat /etc/udev/rules.d/90-hide-partitions.rule 
KERNEL=="sda7",ENV{UDISKS_IGNORE}="1"
KERNEL=="sda8",ENV{UDISKS_IGNORE}="1"
KERNEL=="sda9",ENV{UDISKS_IGNORE}="1"

EDITED:

Thanx anonymous_user
IT works! the extension should have been *.rules

But it doesn't solve the binded folder problem! details in post #9

Last edited by rhoit (2013-01-18 10:02:10)

Offline

#6 2013-01-18 06:01:18

anonymous_user
Member
Registered: 2009-08-28
Posts: 3,058

Re: [SOLVED] Hide drives & bind folder from nautilus

After making the rules did you either reboot or run the following commands:

sudo udevadm control --reload-rules
sudo udevadm trigger

Offline

#7 2013-01-18 06:03:43

rhoit
Member
From: 977
Registered: 2012-07-05
Posts: 62
Website

Re: [SOLVED] Hide drives & bind folder from nautilus

yup i did reboot my system!

Offline

#8 2013-01-18 09:09:23

graysky
Member
From: The worse toilet in Scotland
Registered: 2008-12-01
Posts: 8,825
Website

Re: [SOLVED] Hide drives & bind folder from nautilus


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Online

#9 2013-01-18 09:58:38

rhoit
Member
From: 977
Registered: 2012-07-05
Posts: 62
Website

Re: [SOLVED] Hide drives & bind folder from nautilus

'/etc/udev/rules.d/10-hide-drives.rules' solved my problem! BUT still few more

# Problem 1
Some weird problem Occured NOW Music drive still seems to be shown when i open file browser ( nautilus ) and it remains there.
but if i open

$ nautilus /

before opening my home folder then its not shown!

# Problem 2
It seems that the binded folder seems to have the problem! and it add the device icons!
i have used fstab to mount it with option auto,x-systemd.automount

Weird Problem /dev/sda8 ==> /home/rho/Music
Binded folder   /media/Dump/downloads ==> /home/rho/Downloads
iBFMw.png

here is my fstab

# 
# /etc/fstab: static file system information
#
# <file system>	<dir>	<type>	<options>	<dump>	<pass>

# System
UUID="f12d8af7-5482-4a05-b40f-816d3f574236"	/         	ext4      	rw,relatime,data=ordered	0 1
UUID="8119c92f-2fc5-4016-8925-bb5bed013be6"	/boot     	ext4      	rw,relatime,data=ordered	0 2
UUID="bbb2e2a0-63b8-4896-b7f4-f77884e791c0"	/var      	ext4      	rw,relatime,data=ordered	0 2
UUID="c08ea485-32b2-4e14-a589-c335592c7a9b"	/home     	ext4      	rw,relatime,data=ordered	0 3
UUID="125620a5-a6c4-41cb-9bb5-1fe28c0f84ab"	none		swap		defaults			0 0

# Custom
UUID="e96e950a-b733-495e-9d22-32843e6dea22"	/mnt/Core	ext4		noauto,x-systemd.automount	0 3
UUID="bccecaef-d098-4b67-9cd3-fce05ed3d363"	/mnt/elib	ext4		noauto,x-systemd.automount	0 3
UUID="e1b574dc-062e-4be6-ba12-9aae8ef6c9c2"	/home/rho/Music	ext4		noauto,x-systemd.automount	0 3
UUID="9f204245-5c6a-45cb-8138-5025218ad3c8"	/media/Dump	ext4		x-systemd.automount		0 3

### Bindings
/media/Dump/downloads				/home/rho/Downloads	none	bind				0 0

none /sys/kernel/debug debugfs defaults 0 0

Last edited by rhoit (2013-01-18 09:59:24)

Offline

#10 2013-01-20 21:59:51

alexoz
Member
Registered: 2012-12-14
Posts: 5

Re: [SOLVED] Hide drives & bind folder from nautilus

You can remove these entries from fstab and use systemd mount units instead. This way nautilus will not display these drives/directories.

To give you an example, for your bind mount you could create the file /etc/systemd/system/home-rho-Downloads.mount with the following contents:

[Unit]
Description=Bind mount for my Downloads

[Mount]
What=/media/Dump/downloads
Where=/home/rho/Downloads
Type=none
Options=bind

[Install]
WantedBy=local-fs.target

Then you can activate it with systemctl start home-rho-Downloads.mount and/or start it automatically at boot with systemctl enable ...
Systemd should be smart enough to mount any other needed drives/directories first.

For more options check the manpages of systemd.unit and systemd.mount.

Offline

#11 2013-02-03 23:19:54

Leduck
Member
From: Brazil
Registered: 2011-04-25
Posts: 48
Website

Re: [SOLVED] Hide drives & bind folder from nautilus

I'm having the same problem, but my mount point contains space in the directory name, I tried \ 040 as in fstab and it did not work, searched the wiki and found nothing, anyone know what to do?

Offline

#12 2013-02-04 17:12:03

alexoz
Member
Registered: 2012-12-14
Posts: 5

Re: [SOLVED] Hide drives & bind folder from nautilus

Leduck wrote:

I'm having the same problem, but my mount point contains space in the directory name, I tried \ 040 as in fstab and it did not work, searched the wiki and found nothing, anyone know what to do?

You can check the .mount file that systemd creates at runtime from the fstab entry in /run/systemd/generator to see how the space character is handled.

Offline

#13 2013-02-04 18:07:48

Leduck
Member
From: Brazil
Registered: 2011-04-25
Posts: 48
Website

Re: [SOLVED] Hide drives & bind folder from nautilus

I copied the file and still gave error:

gdrive.mount 's Where setting does not match unit name. Refusing

Offline

#14 2013-02-04 18:21:54

alexoz
Member
Registered: 2012-12-14
Posts: 5

Re: [SOLVED] Hide drives & bind folder from nautilus

Leduck wrote:

I copied the file and still gave error:

gdrive.mount 's Where setting does not match unit name. Refusing

systemd.mount(5):

Mount units must be named after the mount point directories they control. Example: the mount point /home/lennart must be configured in a unit file home-lennart.mount. For details about the escaping logic used to convert a file system path to a unit name see systemd.unit(5).

systemd.unit(5):

Some unit names reflect paths existing in the file system name space. Example: a device unit dev-sda.device refers to a device with the device node /dev/sda in the file system namespace. If this applies a special way to escape the path name is used, so that the result is usable as part of a file name. Basically, given a path, "/" is replaced by "-", and all unprintable characters and the "-" are replaced by C-style "\x20" escapes. The root directory "/" is encoded as single dash, while otherwise the initial and ending "/" is removed from all paths during transformation. This escaping is reversible.

So unless you are trying to mount something at /gdrive, your unit filename is wrong.

Offline

#15 2013-02-04 18:56:58

Leduck
Member
From: Brazil
Registered: 2011-04-25
Posts: 48
Website

Re: [SOLVED] Hide drives & bind folder from nautilus

Sorry, I do not yet fully accustomed with systemd. Really, the problem was in the file name that I changed to get better visually. I left as I was on / run / systemd / generator and I found strange because the status says no is ok, but this mounting the folder correctly. I copied the file manually to / etc / systemd / system / local-fs.target.wants because I could not do enable. The .mount is enabled equal the .service?

Offline

#16 2013-02-04 19:15:10

alexoz
Member
Registered: 2012-12-14
Posts: 5

Re: [SOLVED] Hide drives & bind folder from nautilus

To be able to enable/disable automounting at boot, you need an [Install] section in your .mount file (see post #10 above). Then you can keep your .mount file in /etc/systemd/system, and systemd will create the necessary shortcuts when you "enable" it.

Offline

#17 2013-02-04 19:42:11

rhoit
Member
From: 977
Registered: 2012-07-05
Posts: 62
Website

Re: [SOLVED] Hide drives & bind folder from nautilus

Every thing worked! big_smile thanx a lot alexoz
thanks Leduck too..without your comment i wouldn't have look into the thread!

alexoz wrote:

You can remove these entries from fstab and use systemd mount units instead. This way nautilus will not display these drives/directories.

To give you an example, for your bind mount you could create the file /etc/systemd/system/home-rho-Downloads.mount with the following contents:

[Unit]
Description=Bind mount for my Downloads

[Mount]
What=/media/Dump/downloads
Where=/home/rho/Downloads
Type=none
Options=bind

[Install]
WantedBy=local-fs.target

Then you can activate it with systemctl start home-rho-Downloads.mount and/or start it automatically at boot with systemctl enable ...
Systemd should be smart enough to mount any other needed drives/directories first.

For more options check the manpages of systemd.unit and systemd.mount.

Offline

Board footer

Powered by FluxBB