You are not logged in.

#1 2012-08-09 15:50:35

iateyourgranny
Member
Registered: 2012-08-09
Posts: 1

Arch keeps muting Windows headphones

I have a dual-boot with Archlinux (using KDE) and Windows 7. This has been going on for a while (seemed to be fixed after an update, but now it is back). If I close Archlinux normally and switch to windows, my laptop speakers work but if I plug in my headphones, there is no sound (in my headphones or through the speakers). It used to work if I used the "reboot" command on Arch to reboot to windows, but now my only option is a hard reset (using the power key). Before, it had also worked on certain occasions, like: 1. when I uninstalled pulseaudio and just stuck with alsamixer 2. when I made alsamixer save and restore states during startup 3. when I commented out the "if [ "$MUTE_VOLUME" == "yes" ]; then
" option under the stop section of the alsa demon in /etc/rc.d/alsa. But each time, the problem came back after a while. I can't think of anything else to do now.

By the way, the problem seems to be that Arch mutes a certain channel for the headphones, which Windows has no access to. It used to be that alsamixer showed this channel as muted each time I restarted Arch, but now I have fixed that, but still my headphones get muted on Windows. It seems that for some reason Arch mutes the headphones channel each time it normally shuts down. But I don't know what is doing it.

Offline

#2 2012-08-09 22:46:53

rvdli
Member
Registered: 2011-08-25
Posts: 27

Re: Arch keeps muting Windows headphones

I thought I was the only one who had this issue. Never found anything related here on the forums, neither Google.
I have this issue on two laptops, both using Intel chipsets and Conexant audio devices. Tried another Linux distros, but all of them have this problem.

I can have my headphones working again on Windows only if I shut down the laptop then turn again. Just rebooting keeps the headphones mute.

Thanks for the $MUTE_VOLUME line, never heard anything about this. Will try here.

Offline

#3 2012-08-16 19:47:55

runny6play
Member
Registered: 2012-02-18
Posts: 85

Re: Arch keeps muting Windows headphones

It has to be something  that's muting or deactivating the hardware on shutdown that windows isn't picking up on. Neater like to play nice. I've heard plenty of cases of the opposite happening. You could try uninstalling both for a short period to confirm that ether is the cause. That would isolate the problem.

Offline

#4 2013-01-27 10:41:12

jilen
Member
Registered: 2013-01-17
Posts: 11

Re: Arch keeps muting Windows headphones

I would say I am suffering the same pain?
Any idea to get around of this?

Last edited by jilen (2013-01-27 10:41:45)

Offline

#5 2013-02-05 20:59:50

takiemil
Member
Registered: 2013-02-05
Posts: 1

Re: Arch keeps muting Windows headphones

Hi Everyone!
Same problem here: everytime I reboot (eg by typing "reboot") my Fedora 17 and than select wind0w$ in grub I have no audio in headphones - even drivers reinstallation does not help.
All I can do to enable sound in my headphones is to boot Linux again and type "halt -p" and than turn on the pc.
imho there must be something that Linux is disabling on very low level while rebooting - I'm not a hardware expert, but this may be the place for start.

cheers smile

Offline

Board footer

Powered by FluxBB