You are not logged in.

#1 2013-02-05 21:55:47

Registered: 2013-02-04
Posts: 10

Stani's Python Editor (SPE)

I installed it from the AUR here, with yaourt: AUR (en) - spe

Now, when I try to run it just by clicking on it in the launcher, it tries for a few seconds but does not open.  When I run "spe" in the console, I get

  File "/usr/bin/spe", line 23
    print 'You need to upgrade wxPython to v%s (or higher) to run SPE.'%MIN_WX_VERSION
SyntaxError: invalid syntax

in return.  wxPython and all other dependencies are installed.  I triple checked.  If I run /usr/bin/spe with python2, SPE opens just fine.

So, with the great knowledge of the Archers on here, I was hoping one of you would be able to let me know why it won't work if I just launch it normally?  Thanks!


#2 2013-02-05 21:58:51

Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 19,608

Re: Stani's Python Editor (SPE)

Moving to AUR Issues...

Also, see the Python page on the wiki: … ld_scripts

There is already a comment on the AUR page.

Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438


Board footer

Powered by FluxBB