You are not logged in.

#1 2005-11-09 13:17:37

hjorthboggild
Member
From: Denmark
Registered: 2005-11-05
Posts: 89

powernowd not working - or being overruled ?

I have Pentium M Dothan processor 1.5GHz on an Asus M6Ne laptop.

I recently installed powernowd from AUR, build the package and put the daemon into the rc.conf. I also added speedstep_centrino and cpufreq_userspace modules to be loaded.
The daemon starts up nicely and initially brings the cpu down to 600MHz. Not long after, however, I notice that the cat /sys/devices/system/cpu/cpu0/cpufreq/cpuinfo_cur_freq yields 1.5GHz, even though there's no load on the cpu whatsoever. The cpu stays at 1.5GHz no matter what. If I restart the daemon the frequency again initially goes down to 600MHz, but again, not long after rises to 1.5 GHz even though there's no load on the cpu. This pattern continues for every restart of the daemon.
If I stop the daemon and instead directly invoke /usr/sbin/powernowd with options -dvvvv, to get output from powernow, I get the following:

[root@archlinux sims]# powernowd -dvvvv
PowerNow Daemon v0.96, (c) 2003-2005 John Clemens
Settings:
  verbosity:        4
  mode:             1     (AGGRESSIVE)
  step:           100 MHz (100000 kHz)
  lowwater:        20 %
  highwater:       80 %
  poll interval: 1000 ms
Found 1 cpu:  -- 1 thread (or core) per physical cpu
  cpu0: 600Mhz - 1500Mhz (10 steps)
     step1 : 1500Mhz
     step2 : 1500Mhz
     step3 : 1500Mhz
     step4 : 1500Mhz
     step5 : 1500Mhz
     step6 : 1500Mhz
     step7 : 1200Mhz
     step8 : 1000Mhz
     step9 : 800Mhz
     step10 : 600Mhz
PCT = 0.000000
Setting speed to 1500000
mode=0, str=1500000
PCT = 0.060606
Setting speed to 1500000
mode=0, str=1500000
PCT = 0.000000
Setting speed to 1500000
mode=0, str=1500000
PCT = 0.000000
Setting speed to 1500000
mode=0, str=1500000
PCT = 0.000000
Setting speed to 1500000
mode=0, str=1500000
PCT = 0.000000
Setting speed to 1200000
mode=0, str=1200000
PCT = 0.000000
Setting speed to 1000000
mode=0, str=1000000
PCT = 0.009901
Setting speed to 800000
mode=0, str=800000
PCT = 0.000000
Setting speed to 600000
mode=0, str=600000
PCT = 0.000000
PCT = 0.009901
PCT = 0.010000
PCT = 0.000000
PCT = 0.009901
PCT = 0.029703

which seems to be fine, only the frequency still goes up to 1.5GHz, even though powernowd claims it has still been set to 600MHz.
The question is, is something else overruling the powernowd and cracking up the frequency, or is powernowd just not working properly?

Offline

#2 2005-11-09 16:24:29

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: powernowd not working - or being overruled ?

are you modprobing the "userspace" governer?  I'm pretty sure that needs to be there for powernowd

Offline

#3 2005-11-09 16:34:32

hjorthboggild
Member
From: Denmark
Registered: 2005-11-05
Posts: 89

Re: powernowd not working - or being overruled ?

I have the cpufreq_userspace module loaded:

lsmod |grep userspace
cpufreq_userspace       4752  0

The funny thing is that powernowd starts up fine, and presumably works fine for the first 30 seconds, after that somehow the frequency climbs up to 1.5GHz again. No output from powernowd shows, however, that it is changing the frequency upwards.

Loading the module cpufreq_ondemand followed by:
echo ondemand > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor

does work fine though, that seems to be able to control the processor nicely. Only powernowd is not working

Offline

#4 2005-11-09 17:06:11

kth5
Member
Registered: 2004-04-29
Posts: 655
Website

Re: powernowd not working - or being overruled ?

this is my setup with powernowd which works alright on a Kontron Jrex-PM board with a centrino chipset and a 1.6Ghz Pentium Mobile CPU:

lsmod:

cpufreq_userspace       4444  1
speedstep_centrino      7764  1
freq_table              4484  1 speedstep_centrino

note that these are the only CPU frequency scaling related modules probed.

powernowd startup parameters:

powernowd -n -v

and here is what it says in daemon.log:

Nov  4 17:26:27 AEE-L110 powernowd: PowerNow Daemon v0.96, (c) 2003-2005 John Clemens
Nov  4 17:26:27 AEE-L110 powernowd: Settings:
Nov  4 17:26:27 AEE-L110 powernowd:   verbosity:        1
Nov  4 17:26:27 AEE-L110 powernowd:   mode:             0     (SINE)
Nov  4 17:26:27 AEE-L110 powernowd:   step:           100 MHz (100000 kHz)
Nov  4 17:26:27 AEE-L110 powernowd:   lowwater:        20 %
Nov  4 17:26:27 AEE-L110 powernowd:   highwater:       80 %
Nov  4 17:26:27 AEE-L110 powernowd:   poll interval: 1000 ms
Nov  4 17:26:27 AEE-L110 powernowd: Found 1 cpu:  -- 1 thread (or core) per physical cpu
Nov  4 17:26:27 AEE-L110 powernowd:   cpu0: 600Mhz - 1600Mhz (6 steps)
Nov  4 17:26:27 AEE-L110 powernowd:      step1 : 1600Mhz
Nov  4 17:26:27 AEE-L110 powernowd:      step2 : 1400Mhz
Nov  4 17:26:27 AEE-L110 powernowd:      step3 : 1200Mhz
Nov  4 17:26:27 AEE-L110 powernowd:      step4 : 1000Mhz
Nov  4 17:26:27 AEE-L110 powernowd:      step5 : 800Mhz
Nov  4 17:26:27 AEE-L110 powernowd:      step6 : 600Mhz
Nov  4 17:27:03 AEE-L110 powernowd: Statistics:
Nov  4 17:27:03 AEE-L110 powernowd:   6 speed changes in 36 seconds

I recognize that while theory and practice are, in theory, the same, they are, in practice, different. -Mark Mitchell

Offline

#5 2005-11-10 09:16:54

hjorthboggild
Member
From: Denmark
Registered: 2005-11-05
Posts: 89

Re: powernowd not working - or being overruled ?

That is exactly my setup too, those are the only cpu related modules loaded, and as I said, powernowd is working for the first 30 seconds or, after which the frequency goes up again. I don't know why the frequency goes up again, because when you look at the output from powernowd, there's no indication that powernowd is causing the rise in frequency, the questions is just what causes the frequency to rise, and why doesn't powernowd try to get it down again?

Offline

#6 2005-11-10 09:26:53

kth5
Member
Registered: 2004-04-29
Posts: 655
Website

Re: powernowd not working - or being overruled ?

good question! in any case, powernowd seems to modify the frequency here up and down just fine but i actually never see any entries regarding this in my logs. even the verbose mode does not display any more than what it detected on startup.  roll

maybe it is worth a shot to try the acpi scaling stuff?


I recognize that while theory and practice are, in theory, the same, they are, in practice, different. -Mark Mitchell

Offline

#7 2005-11-10 15:32:51

hjorthboggild
Member
From: Denmark
Registered: 2005-11-05
Posts: 89

Re: powernowd not working - or being overruled ?

You can increase the verbosity from powernowd by adding more v's, and choose not to detach it from the terminal:

powernowd -dvvvv

that way you will get a lot more output from powernowd, and you can watch it as it changes the frequencies

Offline

Board footer

Powered by FluxBB