You are not logged in.

#1 2013-02-08 10:39:46

siriusb
Member
From: Hungary
Registered: 2010-01-01
Posts: 414

laptop-mode-tools no power saving

Hi,

I use laptop-mode-tools for several months and it worked fine, however lately when my laptop runs on battery it seems that no power saving options kick in, since I get a battery time around 1 and half an hour, while it used to be 4 hours.
It may be connected to that I removed initscripts from the system, however laptop-mode.service is enabled and started, journal says events are picked up, laptop-mode-tool modules are loaded, I can see e.g. that cpu freq is cut back, so I'm confused a bit. I spent hours going through the config files and browsing the journal, but I must have missed something.
Please advise where to look or what to check. Thank you.
If you need any log or config file, additional information, please let me know.

Offline

#2 2013-02-08 11:01:11

valr
Member
From: Belgium
Registered: 2012-01-08
Posts: 62

Re: laptop-mode-tools no power saving

Intel cpu ? If so, try powertop and see what it says.

Offline

#3 2013-02-08 12:18:49

siriusb
Member
From: Hungary
Registered: 2010-01-01
Posts: 414

Re: laptop-mode-tools no power saving

Yes, Intel i5-2450M.

Here's the report from powertop, you can download the html version:
http://speedy.sh/RdhTg/powertophtml

Last edited by siriusb (2013-02-08 12:25:18)

Offline

#4 2013-02-10 00:03:07

frank604
Member
From: BC, Canada
Registered: 2011-04-20
Posts: 929
Website

Re: laptop-mode-tools no power saving

Have you tried powerdown? Here's a link to one of their threads.  https://bbs.archlinux.org/viewtopic.php?id=134109&p=1

Link to aur = https://aur.archlinux.org/packages.php?ID=57421
Wiki = https://wiki.archlinux.org/index.php/Powerdown

It is just a bunch of scripts written by a forum member.  I just came across it recently as I only used arch on desktop until now.  Fuduntu was boasting their battery life preset on their distro but I find that with these scripts and changing them to your needs, you get far better results.  I have a 9 cell on my asus eee 1005ha getting 11-12 hours of internet browsing and writing.


github       bible       blog

Offline

#5 2013-02-10 07:29:24

siriusb
Member
From: Hungary
Registered: 2010-01-01
Posts: 414

Re: laptop-mode-tools no power saving

I've never heard of it. It's worth a try, but first I would like to resolve my laptop-mode-tools issue. If I can't I'll have no choice.
Thanks for sharing.

Offline

#6 2013-02-10 08:13:36

frank604
Member
From: BC, Canada
Registered: 2011-04-20
Posts: 929
Website

Re: laptop-mode-tools no power saving

It sounds like you aren't interested in powerdown.  This post explains the difference between lmt and powerdown.  https://bbs.archlinux.org/viewtopic.php … 6#p1108536

You don't have to remove lmt, just try the powerdown script.  Check your battery.  If you don't like it, reboot or revert to normal by running 'powerup'.  Then Uninstall and go back to your lmt troubles.  Mind as well in the meantime.


github       bible       blog

Offline

#7 2013-02-10 08:27:53

siriusb
Member
From: Hungary
Registered: 2010-01-01
Posts: 414

Re: laptop-mode-tools no power saving

I'd just like to know, what went wrong. Do you think it's such a bad idea to look into an issue/bug? If there is no feedback (bug report), you think it's good for any developer?

Offline

#8 2013-02-10 09:21:51

frank604
Member
From: BC, Canada
Registered: 2011-04-20
Posts: 929
Website

Re: laptop-mode-tools no power saving

It is totally ok to troubleshoot.  I just figured the lack of battery to be of emergency so I am recommending a substitute until a time you fix or file in a bug and wait.  Either way, it is up to you.  As far as I know, lmt's daemon is hard to "test" to see that it is working.  In a way you are configuring it a bit blindly.  The powerdown script is far superior of choice imho.  Good luck!


github       bible       blog

Offline

#9 2013-02-11 11:49:04

vl.still
Member
Registered: 2013-01-08
Posts: 7

Re: laptop-mode-tools no power saving

There is long lasting SandyBridge bug in kernel: https://bbs.archlinux.org/viewtopic.php?id=150743 but I'm not sure if it relates to your CPU and what is current state since I downgraded to kernel 3.5.6 (it should be fixed in 3.8).

Offline

#10 2013-02-11 12:09:47

lucke
Member
From: Poland
Registered: 2004-11-30
Posts: 4,017

Re: laptop-mode-tools no power saving

On my netbook, laptop-mode-tools doesn't set /proc/sys/vm/laptop_mode to non-zero on boot, only restarting it makes it do that. I didn't look deeply into it. Perhaps laptop-mode-tools isn't setting stuff properly for you? Kernel itself takes care of frequency changes, no userspace tools are needed.

Last edited by lucke (2013-02-11 12:10:43)

Offline

#11 2013-02-11 20:01:58

siriusb
Member
From: Hungary
Registered: 2010-01-01
Posts: 414

Re: laptop-mode-tools no power saving

@vl.still, lucke

Thanks for replying. I have been thinking of installing linux-lts, but downgrading is not a bad idea, too. I'll give it a try tomorrow.
Anyway, I tried powerdown, I got more battery time at this moment than with laptop-mode-tools, but not that much than it was earlier.

Offline

#12 2013-02-12 10:12:24

siriusb
Member
From: Hungary
Registered: 2010-01-01
Posts: 414

Re: laptop-mode-tools no power saving

I installed linux-lts and downgraded to linux-3.5.3, too, no avail.
I boot into the factory installed SLED11 and at 50% it gave me 1hr 40 min battery time.

I have a dGPU, but using intel anyway, with vgaswitcheroo the discrete one is disabled. Now I disabled dGPU in BIOS and discharge rate dropped to 13-15W, so I'm getting somewhere. I think I have to go through kernel 3.6.2 power regression thread in details. Thanks for linking that.

Offline

Board footer

Powered by FluxBB