You are not logged in.

#1 2012-06-18 15:08:17

Kilzool
Member
From: Ireland
Registered: 2010-08-04
Posts: 228

Dmesg NVRM / VGA mode?

# dmesg | tail

[   15.458823] NVRM: Your system is not currently configured to drive a VGA console
[   15.458830] NVRM: on the primary VGA device. The NVIDIA Linux graphics driver
[   15.458834] NVRM: requires the use of a text-mode VGA console. Use of other console
[   15.458838] NVRM: drivers including, but not limited to, vesafb, may result in
[   15.458841] NVRM: corruption and stability problems, and is not supported.

# cat /boot/grub/menu.lst (kernel line)
kernel /vmlinuz-linux root=/dev/sdb3 ro quiet vga=795 5

# uname -a

Linux desktop 3.4.2-2-ARCH #1 SMP PREEMPT Tue Jun 12 07:19:42 UTC 2012 i686 GNU/Linux

# lspvi -v
01:00.0 VGA compatible controller: NVIDIA Corporation G96 [GeForce 9400 GT] (rev a1) (prog-if 00 [VGA controller])
    Subsystem: Micro-Star International Co., Ltd. Device 1413
    Flags: bus master, fast devsel, latency 0, IRQ 16
    Memory at fd000000 (32-bit, non-prefetchable) [size=16M]
    Memory at e0000000 (64-bit, prefetchable) [size=256M]
    Memory at fa000000 (64-bit, non-prefetchable) [size=32M]
    I/O ports at dc80 [size=128]
    [virtual] Expansion ROM at fea00000 [disabled] [size=512K]
    Capabilities: [60] Power Management version 3
    Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
    Capabilities: [78] Express Endpoint, MSI 00
    Capabilities: [b4] Vendor Specific Information: Len=14 <?>
    Capabilities: [100] Virtual Channel
    Capabilities: [128] Power Budgeting <?>
    Capabilities: [600] Vendor Specific Information: ID=0001 Rev=1 Len=024 <?>
    Kernel driver in use: nvidia

# pacman -Ss nvidia | grep installed

extra/libvdpau 0.4.1-2 [installed]
extra/nvidia 302.17-1 [installed]
extra/nvidia-utils 302.17-1 [installed]

Last edited by Kilzool (2012-06-18 15:54:12)

Offline

#2 2012-06-19 08:54:47

paulb787
Member
Registered: 2011-10-22
Posts: 49

Re: Dmesg NVRM / VGA mode?

let me take a guess you are booting UEFI?

Offline

#3 2012-06-19 09:15:23

skunktrader
Member
From: Brisbane, Australia
Registered: 2010-02-14
Posts: 1,319

Re: Dmesg NVRM / VGA mode?

paulb787 wrote:

let me take a guess you are booting UEFI?

I have the same error/message and there is no UEFI

Offline

#4 2012-06-19 09:18:51

Gusar
Member
Registered: 2009-08-25
Posts: 3,428

Offline

#5 2012-06-19 13:14:19

kjell
Member
From: Norway
Registered: 2012-03-26
Posts: 97

Re: Dmesg NVRM / VGA mode?

Got same error (im back on older kernel +nvidia due to other issues) but this didnt seem to cause any problems, in the short time I did run it..

Offline

#6 2012-06-19 16:30:31

paulb787
Member
Registered: 2011-10-22
Posts: 49

Re: Dmesg NVRM / VGA mode?

My story is i got this error with uefi and grub2 and nvividia and a framebufer . it related to the console resoultion and the framebuffer i believe. nvidia is not supoorting a console framebuffer with UEFI booting.


Remove vga=xxx and see if that removes the message

Last edited by paulb787 (2012-06-19 16:33:11)

Offline

#7 2012-06-20 05:20:44

Kilzool
Member
From: Ireland
Registered: 2010-08-04
Posts: 228

Re: Dmesg NVRM / VGA mode?

paulb787 wrote:

My story is i got this error with uefi and grub2 and nvividia and a framebufer . it related to the console resoultion and the framebuffer i believe. nvidia is not supoorting a console framebuffer with UEFI booting.


Remove vga=xxx and see if that removes the message


No on UEFI booting.
When leaving out the vga=xxx it does not give that error...  but that creates very large fonts when booting and/or switching to another getty (ALT-F2, etc)
It doesn't seem to create a problem when I use vga=795, it just causes that warning in the dmesg | tail.

Thanks for replying.

Last edited by Kilzool (2012-06-20 05:29:28)

Offline

#8 2012-06-20 08:51:59

Gusar
Member
Registered: 2009-08-25
Posts: 3,428

Re: Dmesg NVRM / VGA mode?

Another one of those weird phenomenons I observe every now and then...

Why are so many people association this with UEFI?

Offline

#9 2012-09-25 17:01:57

Ypnose
Member
From: Jailed in the shell
Registered: 2011-04-21
Posts: 353
Website

Re: Dmesg NVRM / VGA mode?

I got these errors with a non UEFI system. Got vga=792 on my boot line too (with syslinux).

Last edited by Ypnose (2012-09-25 17:17:14)


Github -- My terminal font Envypn

Offline

#10 2012-09-25 19:09:02

Gusar
Member
Registered: 2009-08-25
Posts: 3,428

Re: Dmesg NVRM / VGA mode?

Ypnose wrote:

Got vga=792 on my boot line too (with syslinux).

That's exactly why you get the message.

Offline

#11 2012-09-25 19:14:50

Ypnose
Member
From: Jailed in the shell
Registered: 2011-04-21
Posts: 353
Website

Re: Dmesg NVRM / VGA mode?

Yes, I know it. But before Nvidia driver 30x, we didn't have any warnings. Even if it's not very serious, I prefer removing "vga=792" and keep my logs clean.
The drawback is a tty with a poor resolution.


Github -- My terminal font Envypn

Offline

#12 2013-01-31 20:12:23

hugogee
Member
Registered: 2012-07-31
Posts: 1

Re: Dmesg NVRM / VGA mode?

Solved, thanks to the nice people in #archlinux

Add following to the end of kenel line in /boot/grub/grub.cfg

video=vesa:off vga=normal

e.g.
linux    /vmlinuz-linux root=/dev/mapper/vgroup-root ro cryptdevice=/dev/sda2:vgroup quiet video=vesa:off vga=normal

Last edited by hugogee (2013-01-31 20:13:38)

Offline

#13 2013-01-31 20:19:26

cinelli
Trusted User (TU)
From: Los Angeles, California
Registered: 2012-08-10
Posts: 22
Website

Re: Dmesg NVRM / VGA mode?

hugogee wrote:

Solved, thanks to the nice people in #archlinux

Add following to the end of kenel line in /boot/grub/grub.cfg

video=vesa:off vga=normal

e.g.
linux    /vmlinuz-linux root=/dev/mapper/vgroup-root ro cryptdevice=/dev/sda2:vgroup quiet video=vesa:off vga=normal

Glad that I could help.

::edit::
Please mark as [solved]

Last edited by cinelli (2013-01-31 20:29:19)


aur::dotshare.it::blog
"Stay true."

Offline

#14 2013-01-31 21:08:56

beta990
Member
Registered: 2011-07-10
Posts: 162

Re: Dmesg NVRM / VGA mode?

Sorry for replying to this topic. I still have this message and I'm booting in UEFI. rEFInd is what I use, so I don't think the grub-edits don't work. Any solution?

[    2.673959] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  313.18  Wed Jan  9 17:02:09 PST 2013
[    4.697485] NVRM: Your system is not currently configured to drive a VGA console
[    4.697487] NVRM: on the primary VGA device. The NVIDIA Linux graphics driver
[    4.697489] NVRM: requires the use of a text-mode VGA console. Use of other console
[    4.697490] NVRM: drivers including, but not limited to, vesafb, may result in
[    4.697491] NVRM: corruption and stability problems, and is not supported.

Last edited by beta990 (2013-01-31 21:10:25)

Offline

#15 2013-02-01 08:10:47

Gusar
Member
Registered: 2009-08-25
Posts: 3,428

Re: Dmesg NVRM / VGA mode?

The driver officially supports only a standard VGA text console. But with EFI that one doesn't exist, there's only efifb.

Offline

#16 2013-02-01 11:25:55

beta990
Member
Registered: 2011-07-10
Posts: 162

Re: Dmesg NVRM / VGA mode?

OK, thanks for the info. smile

When searching I found these kernel flags, is this the way to get it to work with rEFInd? (not showing the debug-message)
pci=nocrs
video=efifb

Last edited by beta990 (2013-02-01 11:26:15)

Offline

#17 2013-02-01 16:00:10

Gusar
Member
Registered: 2009-08-25
Posts: 3,428

Re: Dmesg NVRM / VGA mode?

What exactly is the problem? Do you just get that message (which is not an error as such, just a warning that things might not work), or does the driver not work at all? The driver does not officially support EFI, so it wouldn't be weird if it doesn't, but I've seen reports that it does anyway.

If the driver doesn't work, boot the machine in BIOS mode, or switch to the nouveau driver.

Last edited by Gusar (2013-02-01 16:01:07)

Offline

#18 2013-02-01 20:57:24

beta990
Member
Registered: 2011-07-10
Posts: 162

Re: Dmesg NVRM / VGA mode?

Gusar wrote:

What exactly is the problem? Do you just get that message (which is not an error as such, just a warning that things might not work), or does the driver not work at all? The driver does not officially support EFI, so it wouldn't be weird if it doesn't, but I've seen reports that it does anyway.

If the driver doesn't work, boot the machine in BIOS mode, or switch to the nouveau driver.

The driver works without any problems. Although I seem to get some problem with DVD-playback/divx in VLC, but that might be a codec problem.

Is there no way to remove the (debug) message?

Offline

#19 2013-02-01 23:30:01

Gusar
Member
Registered: 2009-08-25
Posts: 3,428

Re: Dmesg NVRM / VGA mode?

beta990 wrote:

Is there no way to remove the (debug) message?

Well, there's the loglevel kernel parameter. But why would you need to remove it? OCD? smile

Last edited by Gusar (2013-02-01 23:42:08)

Offline

#20 2013-02-04 10:32:58

beta990
Member
Registered: 2011-07-10
Posts: 162

Re: Dmesg NVRM / VGA mode?

Gusar wrote:
beta990 wrote:

Is there no way to remove the (debug) message?

Well, there's the loglevel kernel parameter.

Thanks, I will leave the log-message as it is. smile

Offline

#21 2013-02-08 19:48:31

walderich
Member
Registered: 2011-04-28
Posts: 10

Re: Dmesg NVRM / VGA mode?

Again sorry to post here, but I also get this warning message after switching from nouveau to nvidia driver.
My problem is, that I don't use a graphical login manager, and my screen stays black until logged into X.

I already tried the "video=vesa:off vga=normal" option, but without success. Any other suggestions?

Offline

#22 2013-02-08 19:55:58

MrCode
Member
Registered: 2010-02-06
Posts: 373

Re: Dmesg NVRM / VGA mode?

I get this same message on a BIOS lappy, and all it means is that they don't support a framebuffer console in their driver, and using e.g. vesafb is unsupported, but may work.  It shouldn't have anything to do with X.  Console framebuffer works for me, but at a limited resolution that only closely matches the native resolution of the display panel (1360x768; native is 1366x768).

Offline

#23 2013-02-08 20:45:46

walderich
Member
Registered: 2011-04-28
Posts: 10

Re: Dmesg NVRM / VGA mode?

But in my case, the framebuffer does not work. The display only shows up,
after X was (blindly) started. The dmesg output says:

[    0.410599] vesafb: mode is 1920x1080x32, linelength=7680, pages=0
[    0.410600] vesafb: scrolling: redraw
[    0.410602] vesafb: Truecolor: size=8:8:8:8, shift=24:16:8:0
[    0.411380] vesafb: framebuffer at 0xe9000000, mapped to 0xffffc90005000000, using 8128k, total 8128k

So it actually detects the native display resolution correctly, but still no
picture. What I do see are the status messages, only the login is "hidden".
Switching to another TTY doesn't help either. But after X was started,
switching back to any TTY works again.

Offline

#24 2013-02-08 22:00:23

blackout23
Member
Registered: 2011-11-16
Posts: 780

Re: Dmesg NVRM / VGA mode?

I remember this message from the first time i played around with the vga= kernel option long time ago. There is basically now way around it and I'm not sure if it does produce any problems afterall.

On my laptop I can only get what my bios allows as resolution (1024x768x32) on a 1280x800 display. Only way to get true native resolution is with nouveau and KMS.

Tried uvesafb and everything in the wiki but simply can't get any high than 1024x768. Syslinux Hardware Detection Tools also only listes this has the highest possible vga mode and provides the appropriate number for it.

Let's hope that NVIDA will support KMS in the future. Not only for prettier ttys but also for wayland.
Also like to use KMSCON in the future as kernel console replacement. Anti-Aliased hardware accelerated FullHD console Hello!
kmscon-git is already in the AUR.

Last edited by blackout23 (2013-02-08 22:02:34)

Offline

Board footer

Powered by FluxBB