You are not logged in.

#1 2013-02-11 19:46:23

frumble
Member
From: Germany
Registered: 2012-05-20
Posts: 73
Website

[SOLVED] [KDE] No window decoration and borders, only 1 window visible

Hello, my last pacman -Syu was in December, I think. Today I have made a new upgrade for KDE SC 4.10 and this has caused me a couple of problems. The most serious one is that I have no window decoration and window borders with Kwin in compositing mode and only one window is visible at a time. Other windows disappear when I focus another. When I turn off compositing mode with Ctrl + Shift + F12, the window manager works correctly but I really want compositing and effects so this is no option. My graphics card is an AMD Radeon HD 7770 with the newest Catalyst 13.2-1, but I have tested my old Catalyst 12.11 as well with the same result. Here a demonstration video. Has anyone an idea? Thank you very much!

Last edited by frumble (2013-02-12 13:33:51)

Offline

#2 2013-02-11 21:18:09

Zancarius
Member
From: NM, USA
Registered: 2012-05-06
Posts: 203

Re: [SOLVED] [KDE] No window decoration and borders, only 1 window visible

It seems to me that your issues might be caused by several different problems. I do know a possible fix for one of them since I just upgraded to KDE 4.10 and experienced the "only one window visible" at a time issue. I tracked it down to ~/.kde4/share/config/kconf_updaterc. If you logout, delete that file (such as from a virtual terminal), and log back in, it should restore kwin's behavior. I wager that some of the configurations haven't been correctly migrated for whatever reason, but I don't know anything about KDE's internals to say for certain.

I think there was at least one other post related to compositing. It might be worth snooping around since there are a half dozen other KDE threads. Maybe someone else has run into similar problems.

Edit:

Possibly related post. Wouldn't hurt to bump that thread and share your observations.

There is a "cannot unlock" lock screen bug that seems to be fixable when reapplying the desktop theme, so I'm wondering if that might be tied to your window decorations. Might be worth seeing if that fixes it for you in the event tinkering with the config doesn't work. I haven't encountered this, so I don't know if deleting kconf_updaterc did anything to fix the lock screen. I also didn't have issues with my decorations, though...

Last edited by Zancarius (2013-02-11 21:25:53)


He who has no .plan has small finger.
~Confucius on UNIX.

Offline

#3 2013-02-12 11:36:48

George
Member
Registered: 2011-05-11
Posts: 165

Re: [SOLVED] [KDE] No window decoration and borders, only 1 window visible

Disable the transparency effect in the Desktop Effects Settings if you've ever experimented with that - I think that older kwin versions didn't always apply the transparency correctly meaning that it was possible to set the settings really low (i.e. virtually invisible) without it having a visible effect until you upgrade...
Thankfully when messing about I'd left the settings at about half so it was fairly obvious what had happened.

Offline

#4 2013-02-12 13:38:24

frumble
Member
From: Germany
Registered: 2012-05-20
Posts: 73
Website

Re: [SOLVED] [KDE] No window decoration and borders, only 1 window visible

Very much thanks to both of you! It was the transparency settings! Decorations, inactive windows, dialogs, combined fields and the three menu options were set to completely transparent, the opposite from their position before the 4.10 upgrade. Now is everything fine, I have window decorations, borders and I can see unfocused windows. smile

Offline

#5 2013-03-17 16:22:35

bobwya
Member
Registered: 2012-01-09
Posts: 36

Re: [SOLVED] [KDE] No window decoration and borders, only 1 window visible

Ditto. Had the same 2 problems... Both solved!!

Thanks guys cool

Offline

Board footer

Powered by FluxBB