You are not logged in.

#1 2013-02-11 16:02:12

odin89
Member
Registered: 2011-09-23
Posts: 21

[SOLVED]vmware doesnt start after last update

Hello,
yesterday i updated my System with "pacman -Syu" and since then im not able to run vmware anymore.
At start i get the following error:

Gtk-Message: Failed to load module "canberra-gtk-module": libcanberra-gtk-module.so: Kann die Shared-Object-Datei nicht öffnen: Datei oder Verzeichnis nicht gefunden

(vmware-modconfig:1741): Gtk-WARNING **: Im Modulpfad »adwaita« konnte keine Themen-Engine gefunden werden,
/usr/share/themes/Adwaita/gtk-2.0/gtkrc:989: error: unexpected identifier `direction', expected character `}'
Gtk-Message: Failed to load module "canberra-gtk-module": libcanberra-gtk-module.so: Kann die Shared-Object-Datei nicht öffnen: Datei oder Verzeichnis nicht gefunden
Logging to /tmp/vmware-odin/vmware-modconfig-1741.log
filename:       /lib/modules/3.7.6-1-ARCH/misc/vmmon.ko
supported:      external
license:        GPL v2
description:    VMware Virtual Machine Monitor.
author:         VMware, Inc.
depends:        
vermagic:       3.7.6-1-ARCH SMP preempt mod_unload modversions 
/usr/share/themes/Adwaita/gtk-2.0/gtkrc:989: error: unexpected identifier `direction', expected character `}'
Gtk-Message: Failed to load module "canberra-gtk-module": libcanberra-gtk-module.so: Kann die Shared-Object-Datei nicht öffnen: Datei oder Verzeichnis nicht gefunden

(vmware-tray:1764): Gtk-WARNING **: Im Modulpfad »adwaita« konnte keine Themen-Engine gefunden werden,
/usr/share/themes/Adwaita/gtk-2.0/gtkrc:989: error: unexpected identifier `direction', expected character `}'
Gtk-Message: Failed to load module "canberra-gtk-module": libcanberra-gtk-module.so: Kann die Shared-Object-Datei nicht öffnen: Datei oder Verzeichnis nicht gefunden
Abgebrochen (Speicherabzug geschrieben)

Is there someone who have the same problem and know how to fix it?

odin89

Last edited by odin89 (2013-02-12 12:25:50)

Offline

#2 2013-02-11 16:19:42

Zygote
Member
Registered: 2013-01-15
Posts: 75

Re: [SOLVED]vmware doesnt start after last update

I got the same error here.. Popped into the IRC channel to see if anyone could help out, but without any luck..

(vmware-modconfig:1866): Gtk-WARNING **: Unable to locate theme engine in module_path: "adwaita",
/usr/share/themes/Adwaita/gtk-2.0/gtkrc:989: error: unexpected identifier `direction', expected character `}'
Gtk-Message: Failed to load module "canberra-gtk-module": libcanberra-gtk-module.so: cannot open shared object file: No such file or directory
Logging to /tmp/vmware-aegis/vmware-modconfig-1866.log
HostinfoReadDistroFile: Cannot work with empty file.
HostinfoOSData: Error: no distro file found
filename:       /lib/modules/3.7.6-1-ARCH/misc/vmmon.ko
supported:      external
license:        GPL v2
description:    VMware Virtual Machine Monitor.
author:         VMware, Inc.
depends:        
vermagic:       3.7.6-1-ARCH SMP preempt mod_unload modversions 
/usr/share/themes/Adwaita/gtk-2.0/gtkrc:989: error: unexpected identifier `direction', expected character `}'
 
(vmware-tray:1892): Gtk-WARNING **: Unable to locate theme engine in module_path: "adwaita",
/usr/share/themes/Adwaita/gtk-2.0/gtkrc:989: error: unexpected identifier `direction', expected character `}'
Gtk-Message: Failed to load module "canberra-gtk-module": libcanberra-gtk-module.so: cannot open shared object file: No such file or directory
Aborted (core dumped)

Offline

#3 2013-02-11 22:37:15

odin89
Member
Registered: 2011-09-23
Posts: 21

Re: [SOLVED]vmware doesnt start after last update

No one who can help us to solve the problem?

Offline

#4 2013-02-12 06:07:14

Treeki
Member
Registered: 2013-02-12
Posts: 2

Re: [SOLVED]vmware doesnt start after last update

I'm not sure if it's the same problem, but I tried running vmplayer under gdb (gdb /usr/lib/vmware/bin/vmplayer) and it segfaults in curl_multi_cleanup (). I installed an older curl package and it worked again, but I'm not really comfortable running my system with just one outdated package, so I reinstalled the newer version after I was done using VMware.

I'm currently running 'VMware-Player-5.0.0-812388.x86_64.bundle'. It looks like there's a 5.0.1 out since November but the release notes don't mention anything related, and it's a bit of a hassle to download and install when it might not even fix this issue.

Would love any suggestions!

Offline

#5 2013-02-12 07:46:46

fax
Member
Registered: 2013-01-07
Posts: 16

Re: [SOLVED]vmware doesnt start after last update

Yep, I am seeing the same thing with VMware 9.0.1:

Program received signal SIGSEGV, Segmentation fault.
0x00007fffec2934a0 in curl_multi_cleanup () from /usr/lib/libcurl.so.4

Downgrading curl to 7.28.1-1 got me up and running again.

Last edited by fax (2013-02-12 07:51:53)

Offline

#6 2013-02-12 07:49:51

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 4,966

Re: [SOLVED]vmware doesnt start after last update

There is a bug is libcurl 7.29. It's fixed in the version in the testing repo.

Offline

#7 2013-02-12 09:34:03

Thomas_Do
Member
Registered: 2011-08-12
Posts: 53

Re: [SOLVED]vmware doesnt start after last update

Scimmia wrote:

There is a bug is libcurl 7.29. It's fixed in the version in the testing repo.

Yes, upgrading to curl 7.29.0-2 solved the issue for me, too.

Offline

#8 2013-02-12 12:25:14

odin89
Member
Registered: 2011-09-23
Posts: 21

Re: [SOLVED]vmware doesnt start after last update

Thank you very much. I installed the curl package from testing and vmware is working again :-)

Offline

#9 2013-02-12 15:53:37

Thomas_Do
Member
Registered: 2011-08-12
Posts: 53

Re: [SOLVED]vmware doesnt start after last update

Problem solved. The new curl version is in core (mirrors should update soon).

Offline

#10 2013-02-13 12:41:10

duber
Member
Registered: 2013-02-01
Posts: 1

Re: [SOLVED]vmware doesnt start after last update

Thank you, as mentioned installing curl 7.29.0-2 from testing solved the problem for me as well

Offline

Board footer

Powered by FluxBB