You are not logged in.

#1 2013-02-13 11:21:18

engraze
Member
Registered: 2013-01-26
Posts: 21

[SOLVED] Forcedeth wired connection problems

Thanks, skanky.
Solution, in my case was:

(as root)

systemctl start dhcpcd@eth0

--

Ok, so.

After the latest kernel update, my internet connection doesn't work at all.
I have turned it on/off, checked cables, and it's clearly a problem on the inside.

ifconfig:

eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::e2cb:4eff:fe3f:dfbe  prefixlen 64  scopeid 0x20<link>
        ether e0:cb:4e:3f:df:be  txqueuelen 1000  (Ethernet)
        RX packets 64  bytes 19520 (19.0 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 24  bytes 1872 (1.8 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 0  (Local Loopback)
        RX packets 530  bytes 17722 (17.3 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 530  bytes 17722 (17.3 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

iwconfig:

eth0      no wireless extensions.

lo        no wireless extensions.

ip link:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP mode DEFAULT qlen 1000
    link/ether e0:cb:4e:3f:df:be brd ff:ff:ff:ff:ff:ff

I didn't need to configure my network when I first installed arch, so I have as much as no clue of what I'm supposed to do...
Mind helping...? :(

Last edited by engraze (2013-02-13 13:29:45)

Offline

#2 2013-02-13 11:48:22

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,321

Re: [SOLVED] Forcedeth wired connection problems

ip link output looks normal, please post the output of ip addr and ethtool eth0 .

Are you using dhcp on your home network ?
If so try running systemctl dhcpcd@eth0.service .


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#3 2013-02-13 12:07:40

engraze
Member
Registered: 2013-01-26
Posts: 21

Re: [SOLVED] Forcedeth wired connection problems

I got ip addr but ethtool was not found as a command.

ip addr:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether e0:cb:4e:3f:df:be brd ff:ff:ff:ff:ff:ff
    inet6 fe80::e2cb:4eff:fe3f:dfbe/64 scope link 
       valid_lft forever preferred_lft forever

systemctl dh(...) says Operation not found.

Thanks for the help, by the way. smile

Offline

#4 2013-02-13 12:54:20

skanky
Member
From: WAIS
Registered: 2009-10-23
Posts: 1,838

Re: [SOLVED] Forcedeth wired connection problems

Try

# systemctl start dhcpcs@eth0

then

$ systemctl status dhcpcd@eth0

ethtool is in a package of the same name ans needs to be explicitly installed.


"...one cannot be angry when one looks at a penguin."  - John Ruskin
"Life in general is a bit shit, and so too is the internet. And that's all there is." - scepticisle

Offline

#5 2013-02-13 13:26:23

engraze
Member
Registered: 2013-01-26
Posts: 21

Re: [SOLVED] Forcedeth wired connection problems

Thanks a bunch, skanky. Worked wonders.

Here's the stats:

dhcpcd@eth0.service - dhcpcd on eth0
	  Loaded: loaded (/usr/lib/systemd/system/dhcpcd@.service; disabled)
	  Active: active (running) since Wed 2013-02-13 13:18:12 WET; 5min ago
	 Process: 765 ExecStart=/usr/sbin/dhcpcd -q -w %I (code=exited, status=0/SUCCESS)
	Main PID: 807 (dhcpcd)
	  CGroup: name=systemd:/system/dhcpcd@.service/eth0
		  └─807 /usr/sbin/dhcpcd -q -w eth0

Feb 13 13:18:05 hf dhcpcd[765]: eth0: broadcasting for a lease
Feb 13 13:18:06 hf dhcpcd[765]: eth0: Router Advertisement from fe80::5a98:...f6
Feb 13 13:18:06 hf dhcpcd[765]: eth0: did not fork due to an absent RDNSS o...RA
Feb 13 13:18:06 hf dhcpcd[765]: eth0: no support for DHCPv6 management
Feb 13 13:18:06 hf dhcpcd[765]: eth0: fe80::5a98:35ff:feb8:d8f6: expired de...er
Feb 13 13:18:07 hf dhcpcd[765]: eth0: offered 192.168.1.102 from 192.168.1.254
Feb 13 13:18:07 hf dhcpcd[765]: eth0: acknowledged 192.168.1.102 from 192.1...54
Feb 13 13:18:07 hf dhcpcd[765]: eth0: checking for 192.168.1.102
Feb 13 13:18:12 hf dhcpcd[765]: eth0: leased 192.168.1.102 for 3600 seconds
Feb 13 13:18:12 hf systemd[1]: Started dhcpcd on eth0.

--

Also, is it "permanent" or do I have to put it in .xinitrc or something?

Last edited by engraze (2013-02-13 13:30:54)

Offline

#6 2013-02-13 13:34:18

skanky
Member
From: WAIS
Registered: 2009-10-23
Posts: 1,838

Re: [SOLVED] Forcedeth wired connection problems

Edit: You can check networking's up with ip:

$ ip addr

and

$ ip -s link

If it works now, you'll need to enable it to have it start at startup:

# systemctl enable dhcpcd@eth0

I'd have a look at both the network and systemd pages of the wiki.
Not sure what the change was that broke your networking, but it may be that you'll need to make some other changes and check your systemd config.

Last edited by skanky (2013-02-13 13:36:35)


"...one cannot be angry when one looks at a penguin."  - John Ruskin
"Life in general is a bit shit, and so too is the internet. And that's all there is." - scepticisle

Offline

#7 2013-02-13 13:36:17

engraze
Member
Registered: 2013-01-26
Posts: 21

Re: [SOLVED] Forcedeth wired connection problems

Thanks again.

I'll take a look at them.

Offline

Board footer

Powered by FluxBB