You are not logged in.

#1 2013-02-14 16:07:56

beetlejuice7
Member
Registered: 2012-02-28
Posts: 49

Trouble with laptop-mode-tools turning on

Hi --
I have just installed arch and am noticing that laptop mode is not turned on when I boot up.  I installed the packages and enabled the service using systemctl.  I see after boot that the service starts up (looking at journalctl as well as the /var/run/ file that laptop mode creates), but when I log in I can see that laptop mode is disabled:

cat /proc/sys/vm/laptop_mode
0

When I run

systemctl restart laptop-mode.service

It will output "2" and I notice that lots of things go from "bad" to "good" in powertop.
Lastly, running

sudo systemctl status laptop-mode.service

I see that it was loaded and was active (and exited, as is normal).

I wonder is this some quirk with systemd?  Am I missing something here?

Offline

#2 2013-02-14 16:37:59

the sad clown
Member
From: 192.168.0.X
Registered: 2011-03-20
Posts: 833

Re: Trouble with laptop-mode-tools turning on

Did you do 'systemctl enable laptop-mode.service'?


I laugh, yet the joke is on me

Offline

#3 2013-02-14 17:13:29

beetlejuice7
Member
Registered: 2012-02-28
Posts: 49

Re: Trouble with laptop-mode-tools turning on

Yep, that was the first thing I did!

Offline

#4 2013-02-14 19:00:21

frank604
Member
From: BC, Canada
Registered: 2011-04-20
Posts: 1,061
Website

Re: Trouble with laptop-mode-tools turning on

Maybe the information http://samwel.tk/laptop_mode/faq might help.  Particularly #3 and onward.

I only use powerdown. Thread = https://bbs.archlinux.org/viewtopic.php?id=134109
packer -S powerdown

substitute packer with yaourt or do manually if you wish so.


github       bible       blog       screenshot

Offline

#5 2013-02-14 20:35:51

beetlejuice7
Member
Registered: 2012-02-28
Posts: 49

Re: Trouble with laptop-mode-tools turning on

Thanks frank i'll check this out.

Offline

Board footer

Powered by FluxBB