You are not logged in.

#1 2013-02-17 11:42:11

tcn
Member
Registered: 2011-09-30
Posts: 24

USB wakeup: rules works when triggered manually but not during boot

Hi!

Rule:

# cat /etc/udev/rules.d/90-hid-wakeup-enable.rules 
# udev rule for USB wake-up of selected devices
#
# Saitek PLC 
SUBSYSTEM=="usb", ATTRS{idVendor}=="06a3", ATTRS{idProduct}=="0cfa" RUN+="/bin/sh -c 'echo enabled > /sys$env{DEVPATH}/../../power/wakeup'"
# Apple, Inc. Aluminium Keyboard (ISO)
SUBSYSTEM=="usb", ATTRS{idVendor}=="05ac", ATTRS{idProduct}=="0250" RUN+="/bin/sh -c 'echo enabled > /sys$env{DEVPATH}/../../power/wakeup'"

Manual test:

# udevadm test /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.6/2-1.6.2 2>&1 | tail -2
run: '/usr/share/virtualbox/VBoxCreateUSBNode.sh 189 132 00 vboxusers'
run: '/bin/sh -c 'echo enabled > /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.6/2-1.6.2/../../power/wakeup''

Manual execution:

# cat /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.6/2-1.6.2/../../power/wakeup
disabled
# udevadm trigger /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.6/2-1.6.2
# cat /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.6/2-1.6.2/../../power/wakeup
enabled

So, everything looks alright, doesn't it? But when I reboot it's disabled.

Anybody having any idea?

Also tried to put the echo commands directly in rc.local but that fails. I can see the log output only very shortly but I think it's "no such file or directory".

thx
tcn

Last edited by tcn (2013-02-17 11:42:44)

Offline

#2 2013-02-22 01:11:28

freud_zoid
Member
Registered: 2011-08-12
Posts: 33

Re: USB wakeup: rules works when triggered manually but not during boot

Are both devices Bluetooth?

I had tried to use the same rule configured for my wireless non-Bluetooth keyboard and it didn't work until I renamed it 10-enable-wake-from-S3-via-keyboard.rules.

More about it in this thread:

https://bbs.archlinux.org/viewtopic.php?id=154112

Last edited by freud_zoid (2013-02-22 01:12:34)

Offline

Board footer

Powered by FluxBB