You are not logged in.

#1 2013-02-17 00:10:21

pschyrum
Member
Registered: 2013-02-16
Posts: 8

keyboard issue with '~' (stays alive)

hi there,

(with X)
except for the '~' everything s' working fine with my keyboard. Unfortunaly, whenever I press ALT-GR and '+'  the '~' appears immediately. Well, of course I have not set 'nodeadkeys':

$ cat /etc/X11/xorg.conf.d/20-keyboard.conf 
Section "InputClass"
	Identifier "keyboard"
	MatchIsKeyboard "yes"
	Option "XkbModel" "latitude"	
	Option "XkbLayout" "de"
	Option "XkbOptions" ""
EndSection

I also tried playing with a few 'XkbOptions' and everything s' just working fine. ^ ´` the all behave the way they should - except for '~'.
^ needs two hits, ~ just one. hmpf.

Oh, without running X, means typing in tty typing AltGr + does nothing (well, in there i don't need ~, although it would be useful sometimes)

$ cat /etc/vconsole.conf 
KEYMAP=de-latin1
FONT=Lat2-Terminus16

Anybody has an idea how to fix that? Is there maybe another file that's supposed to change?

Thanks
pschyrum

Offline

#2 2013-02-17 05:02:15

smsware
Member
From: Szczecin, Poland
Registered: 2012-08-14
Posts: 149
Website

Re: keyboard issue with '~' (stays alive)

What DE are you using? AFAIK, e.g. Gnome doesn't use X.Org configuration files... you have to set your language and keyboard the other way, e.g. via GUI; options can be added by dconf-editor and there is also some bug with keyboard layout while not using GDM to log in... all that and more at https://wiki.archlinux.org/index.php/GNOME - search for "keyboard" keyword and will find all you need. Same with other mayor DEs, like KDE, I believe.

Edit: AltGr++ should work on tty too; I've missed that part of your post, sorry. So it's not DE-related after all...

Last edited by smsware (2013-02-17 05:07:41)

Offline

#3 2013-02-17 08:50:11

pschyrum
Member
Registered: 2013-02-16
Posts: 8

Re: keyboard issue with '~' (stays alive)

hi,

thanks for your answer.

I'm using LXDE with Openbox as FM (and lxdm with autologin)

Well, finally i managed to fix it by adapting the '/usr/share/X11/xkb/symbols/de' - replacing every 'asciitilde' by 'dead_tilde'
However a simple update would rechange everything -- and there s' definetely a way to change ~ the right way.

Thanks
pschyrum

Offline

#4 2013-02-17 12:11:40

bernarcher
Forum Fellow
From: Germany
Registered: 2009-02-17
Posts: 2,271

Re: keyboard issue with '~' (stays alive)

I use .Xmodmap for this purpose (see "man Xmodmap"):

bp:~$ cat .Xmodmap 
keycode  35 = plus asterisk Cyrillic_hardsign Cyrillic_HARDSIGN dead_tilde dead_macron NoSymbol NoSymbol U093C U091E

To know or not to know ...
... the questions remain forever.

Offline

#5 2013-02-17 20:11:03

pschyrum
Member
Registered: 2013-02-16
Posts: 8

Re: keyboard issue with '~' (stays alive)

ah, ok, thanks - gonna fix it that way for X - sounds like an update-secure-option.

Well, regarding tty, is there any workaround i can use?

Last edited by pschyrum (2013-02-17 20:13:05)

Offline

Board footer

Powered by FluxBB