You are not logged in.

#1 2013-02-17 20:26:55

twelveeighty
Member
From: Alberta, Canada
Registered: 2011-09-04
Posts: 309

Request for merging new package wireless-bcm43142-dkms with other

As per the AUR Wiki, I'd like to request the merging of "new" package wireless-bcm43142-dkms (https://aur.archlinux.org/packages/wire … 3142-dkms/) with the older package wireless-bcm43142-oneiric-dkms (https://aur.archlinux.org/packages/wire … iric-dkms/). The primary reason for the new package vs. updating the old is that the original package has "oneiric" in the name, which is an Ubuntu version name. I did not know this when I first build the PKGCONFIG; myself and several others just needed to get this stupid driver to work on our Dell laptops at the time since we had no wireless.

The new package also has a much more reliable and applicable upstream link (Ubuntu, where Dell maintains this codebase).

Of course, people will have to uninstall the old package before installing the new one, this is explained in the comments section as well as the forum topic that is linked to this driver (https://bbs.archlinux.org/viewtopic.php?id=145884).

Offline

#2 2013-02-18 11:17:50

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,205

Re: Request for merging new package wireless-bcm43142-dkms with other

send that merge request to the aur general mailing list, see ArchLinux_User-community_Repository_(AUR)#Other_requests.

To make the transition easier, you can use provides= , conflicts= and replaces= in the PKGBUILD for the new package.
Check the man page for details.


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

Board footer

Powered by FluxBB