You are not logged in.

#1 2013-02-16 19:55:01

cezarrangel
Member
Registered: 2013-02-11
Posts: 53

(solved) grug.cfg configuration fails

when I try to configure the grub.cfg file I get an error message which says:

#grub-mkconfig -o /boot/grub/grub.cfg

generating grub.cfg...
found linux image:/boot/vmlinuz-linux...
found initrd image:/boot/initramfs-linux.img

[669.873050]EXT4-fs (sda4):unable to read superblock
[669.855533]SQUASHFS ERROR: can't find a SQUASHFS superblock on sda4
ext4 sda4 unable to read superblock [/quote]

there are two HD and the  partitions are as below:

[quote]bash-4.2# fdisk -l 

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512=512 bytes
Sector size (logical/physical): [512 bytes]/[512 bytes]
IO size (minimum/optimal): [512 bytes]/[512 bytes]
Disk identifier: 0x7df3d782

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048   613730303   306864128    7  HPFS/NTFS/exFAT
/dev/sda2       613731195   789667839    87968322+   5  Extended
/dev/sda3       789667840   933027839    71680000   83  Linux
/dev/sda4       933027840   976773119    21872640   83  Linux
/dev/sda5       613731258   688320989    37294866   83  Linux
/dev/sda6       688321053   789667839    50673393+  83  Linux

Disk /dev/sdb: 250.1 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders, total 488397168 sectors
Units = sectors of 1 * 512=512 bytes
Sector size (logical/physical): [512 bytes]/[512 bytes]
IO size (minimum/optimal): [512 bytes]/[512 bytes]
Disk identifier: 0x94110a5e

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *       16065   148087169    74035552+  83  Linux
/dev/sdb2       148087170   404661284   128287057+   5  Extended
/dev/sdb3       404664320   478511103    36923392   83  Linux
/dev/sdb4       478512090   488392064     4939987+  82  Linux swap
/dev/sdb5       148087233   292961339    72437053+  83  Linux
/dev/sdb6       292961403   404661284    55849941   83  Linux
bash-4.2#]

I am trying to install Arch on /dev/sda5 the /home is on the partition /dev/sdb6

If I uninstall os-prober the configuration is well succeeded

Thanks

Last edited by cezarrangel (2013-02-19 23:27:07)

Offline

#2 2013-02-16 23:35:56

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,662

Re: (solved) grug.cfg configuration fails

What problem are you trying to solve? You say that it works fine without os-prober so I'm not clear why that's not a solution.

Please use [code ][/code ] tags (without the spaces).

fstab? What's on sda4?


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#3 2013-02-17 01:09:52

cezarrangel
Member
Registered: 2013-02-11
Posts: 53

Re: (solved) grug.cfg configuration fails

1)the problem is: the coonfigutation of grub.cfg fails as shown
2)not to use os-prober is not a solution because I want that the configuration of the grub.cfg recognizes the other linux and ntfs systems that exist on the two HD
3)sda4 is the extended partition that contains sda5 and sda6 where I am trying to install Arch

Offline

#4 2013-02-17 01:12:50

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,662

Re: (solved) grug.cfg configuration fails

cezarrangel wrote:

1)the problem is: the coonfigutation of grub.cfg fails as shown
2)not to use os-prober is not a solution because I want that the configuration of the grub.cfg recognizes the other linux and ntfs systems that exist on the two HD
3)sda4 is the extended partition that contains sda5 and sda6 where I am trying to install Arch

Not according to fdisk -l, it isn't.

Post fstab, grub.cfg.


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#5 2013-02-17 02:27:04

cezarrangel
Member
Registered: 2013-02-11
Posts: 53

Re: (solved) grug.cfg configuration fails

Cfr, thanks. Yes sda4 used to be the extended partition, please have a look what the fdisk -l output used to be:

root@darkstar:/home/cezar# fdisk -l
Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): [512 bytes]/[512 bytes]
IO size (minimum/optimal): [512 bytes]/[512 bytes]
Disk identifier: 0x7df3d782

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048   613730303   306864128    7  HPFS/NTFS/exFAT
/dev/sda2       789667840   933027839    71680000   83  Linux
/dev/sda3       933027840   976773119    21872640   83  Linux
/dev/sda4       613731195   789667839    87968322+   5  Extended
/dev/sda5       613731258   688320989    37294866   83  Linux
/dev/sda6       688321053   789667839    50673393+  83  Linux
Partition table entries are not in disk order

Disk /dev/sdb: 250.1 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders, total 488397168 sectors
Units = sectors of 1 * 512=512 bytes
Sector size (logical/physical): [512 bytes]/[512 bytes]
IO size (minimum/optimal): [512 bytes]/[512 bytes]
Disk identifier: 0x94110a5e

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *       16065   148087169    74035552+  83  Linux
/dev/sdb2       404664320   478511103    36923392   83  Linux
/dev/sdb3       478512090   488392064     4939987+  82  Linux swap
/dev/sdb4       148087170   404661284   128287057+   5  Extended
/dev/sdb5       148087233   292961339    72437053+  83  Linux
/dev/sdb6       292961403   404661284    55849941   83  Linux
Partition table entries are not in disk order

As the partition table entries were not in disk order, I tried to fix it with

fdisk /dev/sda
Command (m for help): x
Expert command (m for help): f
Expert command (m for help): w

after that, the new fdisk -l  output is

bash-4.2# fdisk -l
Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512=512 bytes
Sector size (logical/physical): [512 bytes]/[512 bytes]
IO size (minimum/optimal): [512 bytes]/[512 bytes]
Disk identifier: 0x7df3d782

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048   613730303   306864128    7  HPFS/NTFS/exFAT
/dev/sda2       613731195   789667839    87968322+   5  Extended
/dev/sda3       789667840   933027839    71680000   83  Linux
/dev/sda4       933027840   976773119    21872640   83  Linux
/dev/sda5       613731258   688320989    37294866   83  Linux
/dev/sda6       688321053   789667839    50673393+  83  Linux

Disk /dev/sdb: 250.1 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders, total 488397168 sectors
Units = sectors of 1 * 512=512 bytes
Sector size (logical/physical): [512 bytes]/[512 bytes]
IO size (minimum/optimal): [512 bytes]/[512 bytes]
Disk identifier: 0x94110a5e

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *       16065   148087169    74035552+  83  Linux
/dev/sdb2       148087170   404661284   128287057+   5  Extended
/dev/sdb3       404664320   478511103    36923392   83  Linux
/dev/sdb4       478512090   488392064     4939987+  82  Linux swap
/dev/sdb5       148087233   292961339    72437053+  83  Linux
/dev/sdb6       292961403   404661284    55849941   83  Linux
bash-4.2# 

there is not the warning Partition table entries are not in disk order. However, I think I have made a mess

and here is the fstab:

# /etc/fstab: static file system information
#
# <file system> <dir>   <type>  <options>       <dump>  <pass>
# UUID=85a58fc1-d84c-4433-bbcc-75a452480ad1 LABEL=boot
/dev/sda5/ext4rw,relatime,data=ordered        0 1

# UUID=31b7ad20-16b7-4308-b914-6121c193797d
/dev/sda6/home           ext4            rw,relatime,data=ordered        0 2

# UUID=59504bb3-5c76-4580-9e29-d3ca782f5cbf LABEL=swap
/dev/sdb3               none            swap            defaults                   0 0                                                                                                                                        
                                                                                                                     
the grub.cfg is like this:

#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN/etc/grub.d/00_header ###
insmod part_gpt
insmod part_msdos
if [ -s $prefix/grubenv ]; then
  load_env
fi
set default="0"

if [ x"${feature_menuentry_id}" = xy ]; then
  menuentry_id_option="--id"
else
  menuentry_id_option=""
fi

export menuentry_id_option

if [ "${prev_saved_entry}" ]; then
  set saved_entry="${prev_saved_entry}"
  save_env saved_entry
  set prev_saved_entry=
  save_env prev_saved_entry
  set boot_once=true
fi

function savedefault {
  if [ -z "${boot_once}" ]; then
    saved_entry="${chosen}"
    save_env saved_entry
  fi
}

function load_video {
  if [ x$feature_all_video_module = xy ]; then
    insmod all_video
  else
    insmod efi_gop
    insmod efi_uga
    insmod ieee1275_fb
    insmod vbe
    insmod vga
    insmod video_bochs
    insmod video_cirrus
  fi
}

if [ x$feature_default_font_path = xy ] ; then
   font=unicode
else
insmod part_msdos
insmod ext2
set root='hd0,msdos5'
if [ x$feature_platform_search_hint = xy ]; then
  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos5 --hint-efi=hd0,msdos5 --hint-baremetal=ahci0,msdos5  ad4103fa-d940-47ca-8506-301d8071
d467
else
  search --no-floppy --fs-uuid --set=root ad4103fa-d940-47ca-8506-301d8071d467
fi
    font="/usr/share/grub/unicode.pf2"
fi

if loadfont $font ; then
  set gfxmode=auto
  load_video
  insmod gfxterm
  set locale_dir=$prefix/locale
  set lang=en_US
 insmod gettext
fi
terminal_input console
terminal_output gfxterm
set timeout=5
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/10_linux ###
menuentry 'Arch GNU/Linux, with Linux core repo kernel' --class arch --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-core repo
 kernel-true-ad4103fa-d940-47ca-8506-301d8071d467' {
        load_video
        set gfxpayload=keep
        insmod gzio
        insmod part_msdos
        insmod ext2
        set root='hd0,msdos5'
        if [ x$feature_platform_search_hint = xy ]; then
          search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos5 --hint-efi=hd0,msdos5 --hint-baremetal=ahci0,msdos5  ad4103fa-d940-47ca-8506-
301d8071d467
        else
          search --no-floppy --fs-uuid --set=root ad4103fa-d940-47ca-8506-301d8071d467
        fi
        echo    'Loading Linux core repo kernel ...'
        linux   /boot/vmlinuz-linux root=UUID=ad4103fa-d940-47ca-8506-301d8071d467 ro  quiet
        echo    'Loading initial ramdisk ...'
        initrd  /boot/initramfs-linux.img
}
menuentry 'Arch GNU/Linux, with Linux core repo kernel (Fallback initramfs)' --class arch --class gnu-linux --class gnu --class os $menuentry_id_optio
n 'gnulinux-core repo kernel-fallback-ad4103fa-d940-47ca-8506-301d8071d467' {
        load_video
        set gfxpayload=keep
        insmod gzio
        insmod part_msdos
        insmod ext2
        set root='hd0,msdos5'
        if [ x$feature_platform_search_hint = xy ]; then
        search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos5 --hint-efi=hd0,msdos5 --hint-baremetal=ahci0,msdos5  ad4103fa-d940-47ca-8506-
301d8071d467
        else
          search --no-floppy --fs-uuid --set=root ad4103fa-d940-47ca-8506-301d8071d467
        fi
        echo    'Loading Linux core repo kernel ...'
        linux   /boot/vmlinuz-linux root=UUID=ad4103fa-d940-47ca-8506-301d8071d467 ro  quiet
        echo    'Loading initial ramdisk ...'
        initrd  /boot/initramfs-linux-fallback.img
}

### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/20_linux_xen ###
### END /etc/grub.d/20_linux_xen ###

### BEGIN /etc/grub.d/20_memtest86+ ###
### END /etc/grub.d/20_memtest86+ ###

### BEGIN /etc/grub.d/30_os-prober ###
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###

### BEGIN /etc/grub.d/41_custom ###
if [ -f  ${config_directory}/custom.cfg ]; then
  source ${config_directory}/custom.cfg
elif [ -z "${config_directory}" -a -f  $prefix/custom.cfg ]; then
  source $prefix/custom.cfg;
fi
### END /etc/grub.d/41_custom ###

Last edited by cezarrangel (2013-02-17 21:53:00)

Offline

#6 2013-02-17 03:12:01

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,662

Re: (solved) grug.cfg configuration fails

Please edit your post to use

[code ][/code ]

tags!

Are the UUIDs in grub.cfg correct? They don't match the commented lines in fstab. You should probably switch fstab to using labels or UUIDs since references like /dev/sda may change from boot to boot.

Have you rebooted since last writing the partition table? Have you checked the table with fdisk since rebooting?

Last edited by cfr (2013-02-17 03:18:17)


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#7 2013-02-17 10:32:21

cezarrangel
Member
Registered: 2013-02-11
Posts: 53

Re: (solved) grug.cfg configuration fails

cfr, thanks again for your quick answer. I am sorry: please for me to obey you and edit my post  could you kindly explain what does " mean? I apologize and thank you . I will edit as soon as I understand. I will try to edit in advance,ok? if it is not correct please tell me. thank you

1)ok you are correct Cfr. the new partition table in fact is not a mess. It arranged the wrong partition entries. so the entries changed. swap is not /dev/sdb3 any more, but /dev/sdb4 and the extended  partition is not /dev/sdb4 any more, but /dev/sdb2. Only the logical partition are the same: sdb5 and sdb6 (inside sdb2). so I have made the changes in the fstab. but I will swithch everything to UUIDs.
2)Yes I have rebooted. the table now is always the same:

bash-4.2# fdisk -l
Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): [512 bytes]/[512 bytes]
IO size (minimum/optimal): [512 bytes]/[512 bytes]
Disk identifier: 0x7df3d782

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048   613730303   306864128    7  HPFS/NTFS/exFAT
/dev/sda2       613731195   789667839    87968322+   5  Extended
/dev/sda3       789667840   933027839    71680000   83  Linux
/dev/sda4       933027840   976773119    21872640   83  Linux
/dev/sda5       613731258   688320989    37294866   83  Linux
/dev/sda6       688321053   789667839    50673393+  83  Linux

Disk /dev/sdb: 250.1 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders, total 488397168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): [512 bytes]/[512 bytes]
IO size (minimum/optimal): [512 bytes]/[512 bytes]
Disk identifier: 0x94110a5e

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *       16065   148087169    74035552+  83  Linux
/dev/sdb2       148087170   404661284   128287057+   5  Extended
/dev/sdb3       404664320   478511103    36923392   83  Linux
/dev/sdb4       478512090   488392064     4939987+  82  Linux swap
/dev/sdb5       148087233   292961339    72437053+  83  Linux
/dev/sdb6       292961403   404661284    55849941   83  Linux
bash-4.2#

well I will switch fstab and post the result here

Last edited by cezarrangel (2013-02-17 21:50:13)

Offline

#8 2013-02-17 11:30:58

cezarrangel
Member
Registered: 2013-02-11
Posts: 53

Re: (solved) grug.cfg configuration fails

It is no use. I have edited fstab with UUID only
but the error message that is output when I apply

 #grub-mkconfig -o /boot/grub/grub.cfg is always the same:

can't find SQUASH superblock on sda2
ext4-fs (sda2):unable to read superblock

can't find SQUASH superblock on sdb2
ext4-fs (sdb2):unable to read superblock

I remark sda2 e sdb2 are both extended partitions as the table partition entries:

bash-4.2# fdisk -l
Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512=512bytes
Sector size (logical/physical): 512bytes/512bytes
I/O size (minimum/optimal): 512bytes/512bytes
Disk identifier: 0x7df3d782

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048   613730303   306864128    7  HPFS/NTFS/exFAT
/dev/sda2       613731195   789667839    87968322+   5  Extended
/dev/sda3       789667840   933027839    71680000   83  Linux
/dev/sda4       933027840   976773119    21872640   83  Linux
/dev/sda5       613731258   688320989    37294866   83  Linux
/dev/sda6       688321053   789667839    50673393+  83  Linux

Disk /dev/sdb: 250.1 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders, total 488397168 sectors
Units = sectors of 1 * 512=512bytes
Sector size (logical/physical): 512byte/512bytes
I/O size (minimum/optimal): 512bytes/512bytes
Disk identifier: 0x94110a5e

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *       16065   148087169    74035552+  83  Linux
/dev/sdb2       148087170   404661284   128287057+   5  Extended
/dev/sdb3       404664320   478511103    36923392   83  Linux
/dev/sdb4       478512090   488392064     4939987+  82  Linux swap
/dev/sdb5       148087233   292961339    72437053+  83  Linux
/dev/sdb6       292961403   404661284    55849941   83  Linux

Last edited by cezarrangel (2013-02-17 21:54:17)

Offline

#9 2013-02-17 15:45:29

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,662

Re: (solved) grug.cfg configuration fails

In fstab, you don't seem to have any spaces in the line for /.

To use [code ][/code ] tags, quote my message with an example and just see how I did it.

Can you mount the partitions correctly in the live environment?

Last edited by cfr (2013-02-17 15:47:35)


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#10 2013-02-17 17:10:43

cezarrangel
Member
Registered: 2013-02-11
Posts: 53

Re: (solved) grug.cfg configuration fails

cfr wrote:

In fstab, you don't seem to have any spaces in the line for /.

To use [code ][/code ] tags, quote my message with an example and just see how I did it.

Can you mount the partitions correctly in the live environment?

No the fstab is ok as below

# /etc/fstab: static file system information

# <file system> <dir>   <type>  <options>       <dump>  <pass>
# UUID=85a58fc1-d84c-4433-bbcc-75a452480ad1 LABEL=boot
UUID=85a58fc1-d84c-4433-bbcc-75a452480ad1               /               ext4
        rw,relatime,data=ordered        0 1

# UUID=31b7ad20-16b7-4308-b914-6121c193797d
UUID=31b7ad20-16b7-4308-b914-6121c193797d               /home           ext4
        rw,relatime,data=ordered        0 2

# UUID=513a1740-4f36-4476-a464-74d58cf2186f LABEL=swap
UUID=513a1740-4f36-4476-a464-74d58cf2186f               none            swap
        defaults        0 0

Yes, I can mount the partitions. for example, I mount sda5 (where is the installation I am doing) in /mnt/arch-new that I have created in sdb1 (#mkdir /mnt/arch-new #nano /mnt/arch-new/etc/fstab). that is how I can check the files of the new Arch in sda5.

Last edited by cezarrangel (2013-02-17 21:51:45)

Offline

#11 2013-02-18 02:07:59

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,662

Re: (solved) grug.cfg configuration fails

You should not have line breaks in those lines in fstab. For example:

UUID=85a58fc1-d84c-4433-bbcc-75a452480ad1               /               ext4         rw,relatime,data=ordered        0 1

must be all on one line.

Since os-prober is causing the issue, have you considered just adding custom entries for the OSs you want grub to recognise? In /etc/grub.d/40_custom, for example? I do know that os-prober can be kind of dumb - at least, that's my impression from reading people's problems using it.


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#12 2013-02-19 11:01:21

cezarrangel
Member
Registered: 2013-02-11
Posts: 53

Re: (solved) grug.cfg configuration fails

Thank you cfr. your suggestion was perfect. I have uninstalled os-prober. then I edited /etc/grub.d/40_custom followed by #grub-mkconfig -o /boot/grub/grub.cfg. now I can boot both ntfs partition and alll linux partitions by using the grub menu. the entries are like below.

#!/bin/sh
exec tail -n +3 $0
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
#Arch-sda5

menuentry "Windows7"{
    insmod ntfs
    set root='(hd0,1)'
    chainloader +1
}

menuentry "Slack-sda3"{
    set root=(hd0,3)
    linux /boot/vmlinuz root=/dev/sda3 ro quiet splash
}

menuentry "Arch-sda5"{
    set root=(hd0,5)
    linux /boot/vmlinuz-linux root=/dev/sda5  ro quiet splash
    initrd /boot/initramfs-linux.img
}

menuentry "Slack-sdb1"{
    set root=(hd1,1)
    linux /boot/vmlinuz root=/dev/sdb1 ro quiet splash
}

menuentry "Arch-sdb5"{
    set root=(hd1,5)
    linux /boot/vmlinuz-linux root=/dev/sdb5 ro quiet splash
    initrd /boot/initramfs-linux.img 
"/mnt/sda5/etc/grub.d/40_custom" 35 lines, 947 characters

however there are still  two things I would like to fix : the grub menu shows two lines before the entries above (these lines reffer to "core linux..."). I would like to remove these two lines and only let the entries.  Besides: is it possible to change the time I have to choose one of the options of the menu? If I do not choose anything after an amount of time the first line ("core linux....") is the automatic option. I would like to set the meny to stay "for ever" waiting for my choice.

Which file should I edit in order to get rid of these two lines and to set the choice time as "for ever"?

Last edited by cezarrangel (2013-02-19 11:02:02)

Offline

#13 2013-02-19 22:09:50

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,662

Re: (solved) grug.cfg configuration fails

/etc/default/grub

See the grub wiki page for information about the various options.


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#14 2013-02-19 23:26:43

cezarrangel
Member
Registered: 2013-02-11
Posts: 53

Re: (solved) grug.cfg configuration fails

thank you for all.

Offline

Board footer

Powered by FluxBB