You are not logged in.

#1 2013-02-19 06:14:37

ViperDVMan
Member
From: Florida, USA
Registered: 2012-12-29
Posts: 14

Filename issues in KDE... possibly Locale-related

Hello everyone, fairly new Arch user here. I've been running Arch for a little over a couple months now, and I just noticed that some of my songs aren't loading correctly. The same songs load in Kubuntu and in Windows, but not in Arch. After doing a little playing around, I found that the fonts were to blame. And here is my problem:

A number of files I have, namely songs, have european-style accent marks. However, they seem to not appear correctly in KDE. For example:

"Für Elise" shows as "Für Elise"
"La Vallée de cloches" shows as "La Vallée de cloches"
"Liebesträume" shows as "Liebesträume"

...and so on.

How do I fix this so that any filename with such accent marks appears correctly in Arch KDE like they do in Windows and Kubuntu?

Last edited by ViperDVMan (2013-02-23 04:38:32)

Offline

#2 2013-02-19 06:34:26

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: Filename issues in KDE... possibly Locale-related

The first thing you may try is enabling character sets other than UTF-8, namely ISO-8859-1, ISO-8859-15, CP1252. The file names were saved in an encoding that your system doesn't support at the moment.


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#3 2013-02-19 06:57:11

ViperDVMan
Member
From: Florida, USA
Registered: 2012-12-29
Posts: 14

Re: Filename issues in KDE... possibly Locale-related

Wow, that was fast. Thank you for the quick response. How do I enable the other character sets?

Offline

#4 2013-02-19 07:13:15

headkase
Member
From: Canada
Registered: 2011-12-06
Posts: 1,543
Website

Re: Filename issues in KDE... possibly Locale-related

In "/etc/locale.gen" uncomment:

en_US ISO-8859-1

Then execute "sudo locale-gen"
Then in "/etc/locale.conf" set this:

LANG="en_US.UTF-8:ISO-8859-1"

This assumes you want "en_US.UTF-8" to be your primary language (and it is also uncommented in /etc/locale.gen - otherwise replace it with what you are using) and fallback to ISO-8859-1.

https://wiki.archlinux.org/index.php/Locale

Edit: log out and log back in for the changes to take effect.

Last edited by headkase (2013-02-19 07:14:14)


We all make choices, but in the end, our choices make us.

Offline

#5 2013-02-19 07:30:52

ViperDVMan
Member
From: Florida, USA
Registered: 2012-12-29
Posts: 14

Re: Filename issues in KDE... possibly Locale-related

I figured it was something to do with my locale. Again, I just went with what the Beginner's Guide said. But I'll try your suggestion and see if it works smile

Offline

#6 2013-02-19 07:33:55

headkase
Member
From: Canada
Registered: 2011-12-06
Posts: 1,543
Website

Re: Filename issues in KDE... possibly Locale-related

I was having the issue with French characters.  I saw this thread and decided to fix it once and for all.  The suggestion I gave above is what I did to get "Frédéric Chopin" to display correctly on my machine in Dolphin. wink  Previously I only had en_US.UTF-8, the ISO-8859-1 is what I enabled and that worked for me.. smile


We all make choices, but in the end, our choices make us.

Offline

#7 2013-02-19 07:50:01

ViperDVMan
Member
From: Florida, USA
Registered: 2012-12-29
Posts: 14

Re: Filename issues in KDE... possibly Locale-related

I tried it, and it seems to not be working for me. I logged out and back in... no change. Then I rebooted... still no change.

Offline

#8 2013-02-19 07:53:17

headkase
Member
From: Canada
Registered: 2011-12-06
Posts: 1,543
Website

Re: Filename issues in KDE... possibly Locale-related

I copy/pasted one of your texts into a new file:

http://i.imgur.com/43xdviP.png

It's working here.  I ONLY have the two locales in /etc/locale.conf that I listed above.


We all make choices, but in the end, our choices make us.

Offline

#9 2013-02-19 07:59:13

headkase
Member
From: Canada
Registered: 2011-12-06
Posts: 1,543
Website

Re: Filename issues in KDE... possibly Locale-related

Edit: also, what fonts do you have installed?  I know some characters didn't show right for myself until I installed all the fonts I could get my hands on.  Seriously, I installed every ttf font in the repo's because on Facebook especially people like to use non-English characters as "custom emoticons" which are found in those non-English character sets.

In my above screenshot everything is using the "Ubuntu" font.


We all make choices, but in the end, our choices make us.

Offline

#10 2013-02-19 08:07:18

ViperDVMan
Member
From: Florida, USA
Registered: 2012-12-29
Posts: 14

Re: Filename issues in KDE... possibly Locale-related

I think I have mainly the default ones, outside of a few cyrillic and japanese fonts so that I could see those in apps and webpages with no problems. Currently, my Arch KDE is using Sans Serif. I don't know what my Kubuntu's KDE is using.

Last edited by ViperDVMan (2013-02-19 08:14:06)

Offline

#11 2013-02-19 08:12:36

headkase
Member
From: Canada
Registered: 2011-12-06
Posts: 1,543
Website

Re: Filename issues in KDE... possibly Locale-related

Sorry, I'm out of suggestions if a different font doesn't solve the issue.  I did "pacman -Ss ttf" to get a list of all packages with ttf in their name.  Then I installed all of those that were fonts.  In KDE system settings, Application Appearance, Fonts, I set every font to Ubuntu.  That ttf is "ttf-ubuntu-font-family" in a pacman search.


We all make choices, but in the end, our choices make us.

Offline

#12 2013-02-19 08:14:51

ViperDVMan
Member
From: Florida, USA
Registered: 2012-12-29
Posts: 14

Re: Filename issues in KDE... possibly Locale-related

Changing to DejaVu Sans and Droid Sans and Ubuntu didn't help either. I looked in Konsole, and any odd characters show up as "??". How does "Fur Elise" appear in your Konsole?

Last edited by ViperDVMan (2013-02-19 08:16:30)

Offline

#13 2013-02-19 08:19:34

headkase
Member
From: Canada
Registered: 2011-12-06
Posts: 1,543
Website

Re: Filename issues in KDE... possibly Locale-related

http://i.imgur.com/xYy9oKK.png

Verify: Do what I did, copy the text off of this web-page and middle-click-paste it into the konsole.  It may be that when I copy the text I'm getting a different character than what your file names are encoded using.

Edit: and my konsole font is "Ubuntu Mono".

Last edited by headkase (2013-02-19 08:28:05)


We all make choices, but in the end, our choices make us.

Offline

#14 2013-02-19 08:38:04

ViperDVMan
Member
From: Florida, USA
Registered: 2012-12-29
Posts: 14

Re: Filename issues in KDE... possibly Locale-related

I copied and pasted straight into my Konsole, and it shows as "Für Elise". However, the filename as shown in my Konsole appears like "Ludwig van Beethoven - Bagatelle No.25 in A minor 'F??r Elise'".Another strange thing is that the filenames do show correctly Audacious and Audacity (I don't have a lot of other GTK apps in which to test this), but in all my KDE/Qt apps, the filenames don't appear correctly. I'm lost as to why this is.

Edit: I just switched over to Kubuntu, curious as to how the exact same files appear in that distro... and they show correctly in Dolphin and Konsole. Then again, (K)(X)(L)Ubuntu is designed to work out-of-the-box... minus the *-restricted-extras

Last edited by ViperDVMan (2013-02-19 08:45:59)

Offline

#15 2013-02-19 08:45:43

headkase
Member
From: Canada
Registered: 2011-12-06
Posts: 1,543
Website

Re: Filename issues in KDE... possibly Locale-related

Ok, so we know that copying from this web-page will pick up a different character coding than what your file-names are using.  If you would like to replicate that file name on a different machine then tar (to preserve the coding) a file with a non-functional character and post a link to it here - use mediafire or similar to host the file.

Before you do this, you can try uncommenting the various German locales in /etc/locale.gen, running # locale-gen and adding them in /etc/locale.conf LANG with ":" between each locale you would like to fall back to in order.

Edit: "like"/"link" what's the difference.. wink

Last edited by headkase (2013-02-19 08:49:18)


We all make choices, but in the end, our choices make us.

Offline

#16 2013-02-19 10:19:20

thisoldman
Member
From: Pittsburgh
Registered: 2009-04-25
Posts: 1,172

Re: Filename issues in KDE... possibly Locale-related

Offline

#17 2013-02-21 04:33:36

ViperDVMan
Member
From: Florida, USA
Registered: 2012-12-29
Posts: 14

Re: Filename issues in KDE... possibly Locale-related

I tried that suggestion, however, I get this error:

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "",
        LC_ALL = (unset),
        LANG = "en_US.UTF-8:ISO-8859-1"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").

Now what do I do?

Offline

#18 2013-02-21 06:08:22

thisoldman
Member
From: Pittsburgh
Registered: 2009-04-25
Posts: 1,172

Re: Filename issues in KDE... possibly Locale-related

This sounds like a locale problem rather than a font problem.  Do you have to set your language and locale using KDE's System Settings as well as with locale-gen?  It has been years since I've used KDE.

Here's what happens converting the filename "Für Elise.txt" on my machine, not using KDE.

$ convmv -f UTF-8 -t iso-8859-1 "Für Elise.txt"
Starting a dry run without changes...
mv "./Für Elise.txt"   "./Für Elise.txt"
No changes to your files done. Use --notest to finally rename the files.

Offline

#19 2013-02-21 17:39:06

ViperDVMan
Member
From: Florida, USA
Registered: 2012-12-29
Posts: 14

Re: Filename issues in KDE... possibly Locale-related

That didn't work either. I'm || this close to just giving up. It's a minor issue, but it's really frustrating me.

Offline

#20 2013-02-21 23:53:25

thisoldman
Member
From: Pittsburgh
Registered: 2009-04-25
Posts: 1,172

Re: Filename issues in KDE... possibly Locale-related

Would you please post the output of 'locale'?

$ locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE=C
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

Edit – I just found this on KDE's bugtracking, listed as 'WONTFIX', https://bugs.kde.org/show_bug.cgi?id=204768.

Last edited by thisoldman (2013-02-22 00:01:20)

Offline

#21 2013-02-22 19:28:40

ViperDVMan
Member
From: Florida, USA
Registered: 2012-12-29
Posts: 14

Re: Filename issues in KDE... possibly Locale-related

Here's mine:

[arch@ADA ~]$ locale                                                                                                                                                                                                      
locale: Cannot set LC_CTYPE to default locale: No such file or directory                                                                                                                                                  
locale: Cannot set LC_MESSAGES to default locale: No such file or directory                                                                                                                                               
locale: Cannot set LC_ALL to default locale: No such file or directory                                                                                                                                                    
LANG=en_US.UTF-8:en_US.ISO-8859-1                                                                                                                                                                                         
LC_CTYPE="en_US.UTF-8:en_US.ISO-8859-1"                                                                                                                                                                                   
LC_NUMERIC="en_US.UTF-8:en_US.ISO-8859-1"                                                                                                                                                                                 
LC_TIME="en_US.UTF-8:en_US.ISO-8859-1"                                                                                                                                                                                    
LC_COLLATE=C                                                                                                                                                                                                              
LC_MONETARY="en_US.UTF-8:en_US.ISO-8859-1"                                                                                                                                                                                
LC_MESSAGES="en_US.UTF-8:en_US.ISO-8859-1"                                                                                                                                                                                
LC_PAPER="en_US.UTF-8:en_US.ISO-8859-1"                                                                                                                                                                                   
LC_NAME="en_US.UTF-8:en_US.ISO-8859-1"
LC_ADDRESS="en_US.UTF-8:en_US.ISO-8859-1"
LC_TELEPHONE="en_US.UTF-8:en_US.ISO-8859-1"
LC_MEASUREMENT="en_US.UTF-8:en_US.ISO-8859-1"
LC_IDENTIFICATION="en_US.UTF-8:en_US.ISO-8859-1"
LC_ALL=

Offline

#22 2013-02-23 00:19:21

thisoldman
Member
From: Pittsburgh
Registered: 2009-04-25
Posts: 1,172

Re: Filename issues in KDE... possibly Locale-related

I am just guessing, but it might pay to regenerate your locale using the wiki page as a guide.  I don't have enough experience to point you in any specific direction to correct the locale problem.

It might pay to retitle this thread, or start a new thread referencing this one, if you can't find a solution to the locale problem by yourself.

I know we found a problem; I don't know if we found the problem with the filenames.

Offline

#23 2013-02-23 04:39:20

ViperDVMan
Member
From: Florida, USA
Registered: 2012-12-29
Posts: 14

Re: Filename issues in KDE... possibly Locale-related

I have tried to follow the wiki to the letter in regards to Locale... but nothing I've done by following that guide has worked thus far.

Offline

#24 2013-02-23 23:31:49

thisoldman
Member
From: Pittsburgh
Registered: 2009-04-25
Posts: 1,172

Re: Filename issues in KDE... possibly Locale-related

The only thing to try, that I can think of, is to reinstall glibc.

Last edited by thisoldman (2013-02-23 23:32:03)

Offline

#25 2013-02-24 00:12:48

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,675

Re: Filename issues in KDE... possibly Locale-related

ViperDVMan wrote:

I have tried to follow the wiki to the letter in regards to Locale... but nothing I've done by following that guide has worked thus far.

Did you get the output of locale fixed? That is, did you solve that problem but not the filenames or did you not solve that problem?

I'm using KDE:

$ locale
LANG=cy_GB.UTF-8
LC_CTYPE="cy_GB.UTF-8"
LC_NUMERIC="cy_GB.UTF-8"
LC_TIME="cy_GB.UTF-8"
LC_COLLATE=C
LC_MONETARY="cy_GB.UTF-8"
LC_MESSAGES="cy_GB.UTF-8"
LC_PAPER="cy_GB.UTF-8"
LC_NAME="cy_GB.UTF-8"
LC_ADDRESS="cy_GB.UTF-8"
LC_TELEPHONE="cy_GB.UTF-8"
LC_MEASUREMENT="cy_GB.UTF-8"
LC_IDENTIFICATION="cy_GB.UTF-8"
LC_ALL=

$ cat /etc/locale.conf
LANG=cy_GB.UTF-8
LANGUAGE=cy_GB:cy:en_GB:en
LC_COLLATE=C

In KDE settings > Locale, I have country set to "No country (default settings)" - mostly because it doesn't know about my country and I figure this way it will hopefully pick up the locale stuff. So mine is a kludge because KDE is not equipped for my language or country. But certainly KDE shouldn't interfere with the output of locale.

What does

locale -a

give?


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

Board footer

Powered by FluxBB