You are not logged in.

#26 2012-01-23 16:24:45

dimath
Member
Registered: 2012-01-18
Posts: 16

Re: annoying freezes using gnome shell

dimath wrote:

Same problem, ATI X1400,  "irqpoll" didn't work for me.
I'll try "pci=nomsi noapic irqpoll".

No luck, all the same freezes.

Offline

#27 2012-01-23 16:43:07

hadrons123
Member
From: chennai
Registered: 2011-10-07
Posts: 1,249

Re: annoying freezes using gnome shell

I didn't have single freeze since I added the kernel command line options.
Infact lot of video lock ups  and system crawling while playing FullHD,youtube flash videos doesnt exist anymore.My system looks cured.
I 'm not sure why it didn't work out for others.

@dimath
Did you try the kernel command line option without the quotes?

Last edited by hadrons123 (2012-01-23 16:45:50)


LENOVO Y 580 IVYBRIDGE 660M NVIDIA
Unix is user-friendly. It just isn't promiscuous about which users it's friendly with. - Steven King

Offline

#28 2012-01-24 08:32:22

dimath
Member
Registered: 2012-01-18
Posts: 16

Re: annoying freezes using gnome shell

hadrons123 wrote:

@dimath
Did you try the kernel command line option without the quotes?

Yes, I've added "pci=nomsi noapic irqpoll" without quotes at the end of the kernel line of /boot/grub/menu.lst (and reboot after that of course). The menu entry now looks like this:

# (0) Arch Linux
title  Arch Linux  [/boot/vmlinuz-linux]
root   (hd0,0)
kernel /vmlinuz-linux root=/dev/sda3 ro pci=nomsi noapic irqpoll
initrd /initramfs-linux.img

Offline

#29 2012-01-27 11:52:06

bogdan2011
Member
Registered: 2012-01-13
Posts: 44

Re: annoying freezes using gnome shell

After looking into xsession errors file, I think I found what's causing this: unico theme engine is not installed.
Go to AUR and get it (it's not in the repos).
At least now, when I restart X I get my fully functional desktop back. Now to see if it's going to freeze again.

Offline

#30 2012-01-27 12:18:23

hadrons123
Member
From: chennai
Registered: 2011-10-07
Posts: 1,249

Re: annoying freezes using gnome shell

I installed unico when i installed zukitwo themes from AUR.I don't think installing unico  could prevent freezes.


LENOVO Y 580 IVYBRIDGE 660M NVIDIA
Unix is user-friendly. It just isn't promiscuous about which users it's friendly with. - Steven King

Offline

#31 2012-01-28 23:05:46

bogdan2011
Member
Registered: 2012-01-13
Posts: 44

Re: annoying freezes using gnome shell

hadrons123 wrote:

I installed unico when i installed zukitwo themes from AUR.I don't think installing unico  could prevent freezes.

You're right, I still got them. But then I realized maybe nautilus extensions are causing this. So I uninstalled nautilus-open-terminal and nautilus-dropbox and everything is fine now. Hope it stays this way.

Offline

#32 2012-02-01 18:35:19

Slurp
Member
From: Madrid, Spain
Registered: 2008-09-02
Posts: 124

Re: annoying freezes using gnome shell

I've added "pci=nomsi noapic irqpoll" and haven't had any freeze by now, but truth is that now I don't have that much time to use intensively the computer.


Stop the world, I get off...

Offline

#33 2012-02-01 19:43:15

hadrons123
Member
From: chennai
Registered: 2011-10-07
Posts: 1,249

Re: annoying freezes using gnome shell

Actually I didn't have issues for the last 2 weeks but I have some freezes for the last 2 days.Switched to LXDE but still have some occasional glitches.


LENOVO Y 580 IVYBRIDGE 660M NVIDIA
Unix is user-friendly. It just isn't promiscuous about which users it's friendly with. - Steven King

Offline

#34 2012-02-03 10:21:00

bogdan2011
Member
Registered: 2012-01-13
Posts: 44

Re: annoying freezes using gnome shell

Had one today.
Apparently this is happening when scrolling fast in Firefox or when reading PDFs.

Offline

#35 2012-02-03 10:29:49

hadrons123
Member
From: chennai
Registered: 2011-10-07
Posts: 1,249

Re: annoying freezes using gnome shell

bogdan2011 wrote:

Apparently this is happening when scrolling fast in Firefox or when reading PDFs.

same here....

Last edited by hadrons123 (2012-02-03 10:30:53)


LENOVO Y 580 IVYBRIDGE 660M NVIDIA
Unix is user-friendly. It just isn't promiscuous about which users it's friendly with. - Steven King

Offline

#36 2012-02-03 10:53:43

dimath
Member
Registered: 2012-01-18
Posts: 16

Re: annoying freezes using gnome shell

hadrons123 wrote:
bogdan2011 wrote:

Apparently this is happening when scrolling fast in Firefox or when reading PDFs.

same here....

I've noticed this too. Again, I experience the freezes only if some composite window manager is enabled (compiz, mutter).

Offline

#37 2012-02-09 01:29:54

zidarsk8
Member
Registered: 2011-12-06
Posts: 97

Re: annoying freezes using gnome shell

hadrons123 wrote:
bogdan2011 wrote:

Apparently this is happening when scrolling fast in Firefox or when reading PDFs.

same here....

Me too. It's quite silly when cause I have started to be realy gentle with the scool wheel, so I don't "break" anything.

Offline

#38 2012-02-09 01:37:07

hadrons123
Member
From: chennai
Registered: 2011-10-07
Posts: 1,249

Re: annoying freezes using gnome shell

realy gentle with the scool wheel, so I don't "break" anything

I don't think  that might  help you prevent the shell freeze.

Meanwhile I switched to LXDE and things are fine.No freezes in LXDE, yet.


LENOVO Y 580 IVYBRIDGE 660M NVIDIA
Unix is user-friendly. It just isn't promiscuous about which users it's friendly with. - Steven King

Offline

#39 2012-04-22 22:25:07

keivan
Member
Registered: 2011-07-17
Posts: 3

Re: annoying freezes using gnome shell

Hi

I had this problem since the discontinuation of fglrx and introduction of 3D desktops.

I've solved this problem with an extensive try and error. There is a bug in the xorg radeon driver, or in the kernel; I don't know. However, the workaround is simple: Just disable EXAPixmaps in the radeon driver. This is my xorg.conf file which optimized for performance:

Section "Device"
	Identifier			"Radeon"
	Driver				"radeon"

	## edit /etc/modprobe.d/radeon.conf to change the amount of
	## available shared (GART) memory
	## Option GARTsize do not work

	## "man radeon" for more options
	## Enable 3D acceleration compatible with ATI Mobility Radeon x1400
	Option "AccelDFS"		"on"
	# Tuen "EXAPixmaps" off if screen freezed
	Option "EXAPixmaps"		"off"
	#Option "MigrationHeuristic"	"greedy"

	## increase performance
	Option "RenderAccel"		"true"
	Option "AccelMethod"		"EXA"
	Option "ColorTiling"		"on"
	Option "EnablePageFlip"		"on"
	Option "AllowGLXWithComposite"	"true"
	# DO NOT use BackingStore if you use KDE
	Option "BackingStore"		"true"
	Option "DisplayPriority"	"HIGH"
	Option "FBTexPercent"		"0" 

	## Power Saving
	#Option "DynamicPM"		"on"
	#Option "ClockGating"		"on"
	#Option "ForceLowPowerMode"	"on"
EndSection
Section "dri"
  Mode 0666
EndSection

Notes:
1. This solution would reduce the 2d acceleration.

2. I have filled a bug report in the freedesktop.org. Please visit that bug and vote for it. You can, also, continue your discussion there if you want.

Your temporary solution ends here.
But if you want to know more about other issues I've discovered continue:
--------------------------------------------------------------------------
Other issues in kernel 3.2.15 vanilla:
1. Power saving features of the driver do not work properly. Actually, profile method works but there is a kernel confusion.

I have filed 2 bugs in the bugzilla please vote for them.
https://bugzilla.kernel.org/show_bug.cgi?id=43078
https://bugzilla.kernel.org/show_bug.cgi?id=40762

2. Also, I can see this error in the dmesg:

[Firmware Bug]: Duplicate ACPI video bus devices for the same VGA controller, please try module parameter "video.allow_duplicates=1"if the current driver doesn't work.

According to the gentoo wiki , radeon driver needs a firmware to work properly. In the 64 bit version of the kernel, when I bound this firmware to kernel binary, kernel worked fine. But in the 32 bit version of the kernel radeon driver should be built as module and it is impossible to include the firmware to the kernel binary (because kernel crashes!!)

Last edited by keivan (2012-04-22 23:16:30)

Offline

#40 2012-04-23 21:39:23

keivan
Member
Registered: 2011-07-17
Posts: 3

Re: annoying freezes using gnome shell

Good news. This bug was related to the kernel and it is fixed in the new version of the kernel today (3.2.16 or 3.3.3).

Offline

#41 2012-05-08 19:33:57

dimath
Member
Registered: 2012-01-18
Posts: 16

Re: annoying freezes using gnome shell

keivan wrote:

Good news. This bug was related to the kernel and it is fixed in the new version of the kernel today (3.2.16 or 3.3.3).

I had a thought that it was fixed by gnome-shell 3.4 update. But I installed both of them, kernel 3.3.4 and gnome-shell 3.4 on May 4, so I can't tell now.

However, one way or another, I can confirm that I don't experience the freezes anymore since then so the issue was probably fixed.

Last edited by dimath (2012-05-08 19:34:31)

Offline

#42 2013-02-23 19:07:36

XenGi
Member
From: berlin, germany, europe, earth
Registered: 2013-02-23
Posts: 26
Website

Re: annoying freezes using gnome shell

I have a T410 here with nvidia nvs 3100. I have two systems which both have this problem so it seems not to be fixed. I have no problems with pdf viewing or fast scrolling in firefox or chrome. In my case it's just completely raandom.

- Debian Wheezy, kernel 3.2, nvidia and nouveau driver

Random freezes. I have to restart gdm3 and can than relogin and restart all my work.

- Archlinux, kernel 3.7, nouveau driver

Random freezes. The freezes occour less often than under debian but nearly every time I wake up from standby it freezes at the lock screen.

In both cases music keeps playing and windows remain active in the background (mouse cursor changes when hovering etc). It's like a screenshot from the desktop right before your screen that you can click through.

Any new ideas to this problem?

Last edited by XenGi (2013-02-23 19:09:04)


# got root?█

Offline

Board footer

Powered by FluxBB